• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD Releases Radeon Software Crimson Edition 16.7.3

btarunr

Editor & Senior Moderator
Staff member
Joined
Oct 9, 2007
Messages
37,768 (8.50/day)
Location
Hyderabad, India
Processor AMD Ryzen 7 2700X
Motherboard ASUS ROG Strix B450-E Gaming
Cooling AMD Wraith Prism
Memory 2x 16GB Corsair Vengeance LPX DDR4-3000
Video Card(s) Palit GeForce RTX 2080 SUPER GameRock
Storage Western Digital Black NVMe 512GB
Display(s) Samsung U28D590 28-inch 4K UHD
Case Corsair Carbide 100R
Audio Device(s) Creative Sound Blaster Recon3D PCIe
Power Supply Cooler Master MWE Gold 650W
Mouse Razer Abyssus
Keyboard Microsoft Sidewinder X4
Software Windows 10 Pro
AMD signed off July with the month's third Radeon Software Crimson Edition release. Version 16.7.3 features performance optimization for "Rise of the Tomb Raider." The drivers improve performance of the game by up to 10 percent over 16.7.2 drivers. The drivers also address a large amount of game-specific bugs; Radeon Settings UI improvements, and bugs related to task-switching in multi-display setups. Grab them from the links below.



DOWNLOAD: AMD Radeon Software Crimson Edition 16.7.3 for Windows 10 64-bit | Windows 10 32-bit | Windows 8.1 64-bit | Windows 8.1 32-bit | Windows 7 64-bit | Windows 7 32-bit

View at TechPowerUp Main Site
 
Joined
Feb 7, 2013
Messages
119 (0.05/day)
System Name Aki
Processor Intel Core i5-3570
Motherboard Gigabyte GA-H77M-D3H
Cooling CM 212 Evo
Memory Corsair Vengeance 8 GB DDR3-1600
Video Card(s) Sapphire HD7850 2GB
Storage INTEL SSD 520 120 GB, WD Green 2TB, WD Black 2TB, WD Blue 4TB
Display(s) AOC 2353 [23" LCD]
Case Corsair 400R
Power Supply Seasonic 520W S12II
Mouse Logitech G502
Keyboard Corsair K70
Software Windows 8.1 64 bit
is there will be new update for Windows 10 redstone build?
 
Joined
Jun 29, 2016
Messages
140 (0.11/day)
I think I lost the faith in AMD because while HD 6000M and HD 5000M are supported by the new drivers, series HD 7000M and HD 8000M are not fully supported yet.
 
Joined
Aug 9, 2008
Messages
5,003 (1.21/day)
Location
Kingston, Ontario Canada
System Name Aliens Ryzen Rig | Hand Me Down Special
Processor Ryzen R7 2700 @3.6ghz all cores | i5 3570K
Motherboard Gigabyte B450 Aorus Elite (F50a BIOS) | EVGA Z77 FTW
Cooling AMD Wraith spire rgb stock | CM Hyper 212+
Memory 8GB X 2 DDR4 3000mhz Team Group Vulcan | 4 x 2GB DDR3
Video Card(s) Sapphire Pulse RX 5700 8GB | Sapphire RX 480 Reference
Storage Adata XPG 8200 PRO 512GB SSD OS / 240 SSD+480 GB M.2 SSD Games / 1000 GB Data | SSD + HDD
Display(s) Asus VA32AQ 32" IPS 60hz 1440P | Samsung S24D590PL 24" PLS 1080P
Case NZXT H500 Black | NZXT 810 Switcg
Audio Device(s) Onboard Realtek | Onboard Realtek
Power Supply EVGA SuperNOVA G3 650w 80+ Gold | EVGA SuperNOVA G2 750w 80+ Gold
Mouse Steelseries Rival 500 15 button mouse w/ Razor Goliathus Chroma XL mousemat | Logitech G502
Keyboard Logitech G910 Orion Spark RGB w/ Romer G tactile keys | Mad Catz S.T.R.I.K.E. Tournament edition
Software Windows 10 Pro | Windows 10 Pro
Joined
Oct 2, 2004
Messages
13,791 (2.49/day)
I still have stupid CCC driver update constantly whining to update drivers to a newer version and that never version is NOT compatible with E-450 APU GPU. So much stupid.
 
Joined
Sep 11, 2015
Messages
376 (0.24/day)
I'm not entirely sure but after I installed the Crimson drivers on my Saphire 7870 xt Boost one of the fans on the card stopped working entirely. It would switch on for a couple of seconds after boot and then just turn off. A while after using the card like this, it started to shut down under load and then just show random artifacts. I think this update burned my card to a crisp... I probably don't have to mention this, but I'm switching to Nvidia now.
 
Joined
Mar 6, 2012
Messages
502 (0.18/day)
Processor i5 4670K - @ 4.8GHZ core
Motherboard MSI Z87 G43
Cooling Thermalright Ultra-120 *(Modded to fit on this motherboard)
Memory 16GB 2400MHZ
Video Card(s) HD7970 GHZ edition Sapphire
Storage Samsung 120GB 850 EVO & 4X 2TB HDD (Seagate)
Display(s) 42" Panasonice LED TV @120Hz
Case Corsair 200R
Audio Device(s) Xfi Xtreme Music with Hyper X Core
Power Supply Cooler Master 700 Watts
I'm not entirely sure but after I installed the Crimson drivers on my Saphire 7870 xt Boost one of the fans on the card stopped working entirely. It would switch on for a couple of seconds after boot and then just turn off. A while after using the card like this, it started to shut down under load and then just show random artifacts. I think this update burned my card to a crisp... I probably don't have to mention this, but I'm switching to Nvidia now.
Same thing recently happened with my wife's GTX 970, wonder what this guys are doing.

EDIT: Just a second, you are using AIB card so that's not driver's fault if one fan is working other fan failed means its due to hardware failure. In my scenario, my wife has a reference card hence i had to install MSI afterburner and had to set the fan profile manually.
 

Figus

New Member
Joined
Nov 20, 2015
Messages
6 (0.00/day)
Location
Italy
I'm not entirely sure but after I installed the Crimson drivers on my Saphire 7870 xt Boost one of the fans on the card stopped working entirely. It would switch on for a couple of seconds after boot and then just turn off. A while after using the card like this, it started to shut down under load and then just show random artifacts. I think this update burned my card to a crisp... I probably don't have to mention this, but I'm switching to Nvidia now.
Got that card for more than 2 years and now is in my wife pc... fan are working with last drivers without issues.
 
Joined
Aug 1, 2016
Messages
15 (0.01/day)
After upgrading to a new ver. of the drivers on win 10 x64 fps drop observed in Dota 2 and GTA V (games I actually play alot) on my r7 260x, yet I rolled drivers to ver. 16.7.1 for now =(
 
Joined
Apr 29, 2014
Messages
3,837 (1.87/day)
Location
Texas
System Name SnowFire / The Reinforcer / Portable?
Processor i7 8700K 5.0ghz (24/7) / 2x Intel Xeon E52650v2 / Intel i7 7700HQ
Motherboard Asus Z370 Prime-A / Dell Dual Socket (R720) / HP Omen Stock
Cooling RX 360mm + 140mm Custom Loop in Push Pull Config. / Dell Stock / HP Stock
Memory Corsair Vengeance RGB 16gb DDR4 3000 CL 16 / 1600mhz DDR3 128gb 16 x 8gb / 12gb DDR4 3 x 4gb
Video Card(s) GTX Titan XP (2025mhz) / Asus GTX 950 (No Power Connector) / RX 580
Storage Samsung 512gb SSD RAID 0 and 2tb HDD x4 RAID 5 / 300gb x8 RAID 5 / NVME 240gb SSD and 1tb HDD
Display(s) Acer XG270HU 1440p 144hz Freesync, Acer B286HK 4K UHD Monitor / 1080p 60hz Freesync display
Case Corsair Obsidian 800D / Dell Poweredge R720 Rack Mount Case / HP Omen 17
Audio Device(s) Realtec ALC1150 (On board)
Power Supply Rosewill Lightning 1300Watt
Mouse Logitech G5
Keyboard Logitech G19S
Software Windows 10 Pro / Windows Server 2008 R2 / Windows 10 Home
Don't know if I have this version yet or not, have to download it if not.
 
Joined
Apr 18, 2015
Messages
214 (0.13/day)
Apparently I already have this installed. I think I got a popup yesterday or the day before yesterday and did, next next next and now I have it. No issue observed for now, but I'm on R9 not RX.
 
Joined
Aug 9, 2008
Messages
5,003 (1.21/day)
Location
Kingston, Ontario Canada
System Name Aliens Ryzen Rig | Hand Me Down Special
Processor Ryzen R7 2700 @3.6ghz all cores | i5 3570K
Motherboard Gigabyte B450 Aorus Elite (F50a BIOS) | EVGA Z77 FTW
Cooling AMD Wraith spire rgb stock | CM Hyper 212+
Memory 8GB X 2 DDR4 3000mhz Team Group Vulcan | 4 x 2GB DDR3
Video Card(s) Sapphire Pulse RX 5700 8GB | Sapphire RX 480 Reference
Storage Adata XPG 8200 PRO 512GB SSD OS / 240 SSD+480 GB M.2 SSD Games / 1000 GB Data | SSD + HDD
Display(s) Asus VA32AQ 32" IPS 60hz 1440P | Samsung S24D590PL 24" PLS 1080P
Case NZXT H500 Black | NZXT 810 Switcg
Audio Device(s) Onboard Realtek | Onboard Realtek
Power Supply EVGA SuperNOVA G3 650w 80+ Gold | EVGA SuperNOVA G2 750w 80+ Gold
Mouse Steelseries Rival 500 15 button mouse w/ Razor Goliathus Chroma XL mousemat | Logitech G502
Keyboard Logitech G910 Orion Spark RGB w/ Romer G tactile keys | Mad Catz S.T.R.I.K.E. Tournament edition
Software Windows 10 Pro | Windows 10 Pro
dont forget the 16.7.2 drivers are labelled 16.7.3 in gpu z, check the date on the download to ensure proper driver :)
 

rein_psiko4

New Member
Joined
Dec 13, 2013
Messages
4 (0.00/day)
I'm not entirely sure but after I installed the Crimson drivers on my Saphire 7870 xt Boost one of the fans on the card stopped working entirely. It would switch on for a couple of seconds after boot and then just turn off. A while after using the card like this, it started to shut down under load and then just show random artifacts. I think this update burned my card to a crisp... I probably don't have to mention this, but I'm switching to Nvidia now.
another lazy excuse. i have the same problem several weeks ago, n i found out its just a "static electricity" issue that hit my VGA on my PC set, to solve this just pop out your card, put it on the floor for 15-30 sec, and put it back in, just like that. and if you want to get rid of this issue, put some propper grounding system on your PC
 
Joined
Oct 22, 2014
Messages
7,165 (3.83/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Home Premium 64 bit
...its just a "static electricity" issue that hit my VGA on my PC set, to solve this just pop out your card, put it on the floor for 15-30 sec, and put it back in, just like that.
Synthetic carpet is best, just rub the card really fast back and forth on the carpet before putting it back in. :p

Oh, you meant to get rid of static electricity.... o_O
 
Joined
Jul 3, 2014
Messages
31 (0.02/day)
System Name Throne
Processor Intel Core i5 3570K 3.4Ghz ~ 3.8Ghz Turbo
Motherboard GA Z77X-UD3H
Cooling Cooler Master TX3 Hyper
Memory Kingston Hyper X 1866Mhz
Video Card(s) Sapphire r9 280 Dual-X OC 940/1250
Storage Seagate Barracuda 7200rpm 64MB Cache 1TB SATA III
Display(s) LG 22MP55" 1080p IPS
Case Cooler Master Elite 430
Audio Device(s) Onboard Realtek
Power Supply Corsair CX600M
Mouse Lenovo Default Mouse
Keyboard Logitech G15 Gaming Keyboard
Software Windows 7 64b Ultimate
Benchmark Scores Fire Strike Extreme Presets = 7650
im having problems since first Crimson driver, games just crash or stop working in random times. Sapphire r9 280 3GB oc dual-x
 
Joined
Mar 7, 2011
Messages
1,829 (0.57/day)
This driver is crap, I had it installed on my work PC which has R9-290 on Win7 64bit. After driver installation, the system has become unstable and is crashing everytime I try to playback or edit videos. I just reverted back to 15.7 Catalyst and things are working much better for me now.
 
Top