• We've upgraded our forums. Please post any issues/requests in this thread.

Asus P8P67 problem does not detect all memory

Joined
Jan 11, 2014
Messages
56 (0.04/day)
Likes
3
#1
I have 8 GB (4x2GB sticks) installed but BIOS only detect 4GB installed rather than 8GB I expected. I have reseated all 4 of them, I have rearrainged them, BIOS seems to only detect 2 sticks. If I run CPU-Z it does show all 4 sticks for 8GB total. Windows and BIOS however report only 4GB.

Windows 7 64-bit (yes, 64 bits I checked it)
Intel 2700k
Asus P8P67 Pro (uses UEFI rather than legacy BIOS)

Either one of the slot is bad or there's a setting in BIOS that may be inadverantly disabling one set of slots. Anyway to check on that?
 
Joined
Mar 26, 2010
Messages
7,646 (2.71/day)
Likes
1,983
Location
Jakarta, Indonesia
System Name micropage7
Processor Intel G4400
Motherboard MSI B150M Bazooka D3
Cooling Stock ( Lapped )
Memory 16 Gb Team Xtreem DDR3
Video Card(s) Nvidia GTX460
Storage Seagate 1 TB, 5oo Gb and SSD A-Data 128 Gb
Display(s) LG 19 inch LCD Wide Screen
Case HP dx6120 MT
Audio Device(s) Stock
Power Supply Be Quiet 600 Watt
Software Windows 7 64-bit
Benchmark Scores Classified
#2
have you tried to reset your bios too?
 
Joined
Feb 19, 2009
Messages
1,566 (0.49/day)
Likes
546
Location
Warwick
System Name PC-Chips
Processor Intel core I5 4690K
Motherboard Asrock z87 Extreme 3
Cooling Noctua NH-D14
Memory G-Skill Ripjaws 2133mhz 4x4gig
Video Card(s) Sapphire RX-480 Nitro+ 8gig
Storage Samsung 250gig 840 SSD / 1TB HDD
Display(s) Samsung C27F591 27 inch Curved LED
Case NZXT phantom 410
Audio Device(s) Realtek digital out - Yamaha A-S501 - Wharfedale pacific evo 20 speakers - Wharfedale SW150 sub
Power Supply Cooler Master G650M
Mouse logitech G402
Keyboard Logitech delux 250
Software Windows 10 pro 64bit
#3
Don't some mobo's have a memory mapping option in bios that needs to be tunred on or off so all ram is seen? Sure i read about that a few times with asus boards.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
10,401 (4.84/day)
Likes
5,481
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.2Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Zalman CPNS9900MAX 130mm
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) MSI AMD Radeon R9 390 GAMING 8GB @ PCI-E 3.0
Storage 2x120Gb SATA3 Corsair Force GT Raid-0, 4x1Tb RAID-5, 1x500GB
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 17.10
Benchmark Scores Benchmarks aren't everything.
#4
Did you try reseating your CPU? Don't over-tighten the cooler either as too might force might prevent some pins from making good contact. Can you get the machine to start up with DIMMs in just one channel or the other?
 
Joined
Jan 11, 2014
Messages
56 (0.04/day)
Likes
3
#5
Tried reseating CPU, tried reseating RAM, tried RAM in another computer, tried RAM from another computer in this one. Last week, it started failing even more, detecting only 1 stick, then it won't boot anymore, stopping at error 55 (RAM not installed)

I just got a replacement mobo in today, installed, setup, and all 8GB was detected on the first try. So.... my older mobo was a lemon whose problem wasn't discovered for a couple years. :/ Probably bad trace or cracked solder or something but mobo repair isn't my forte. Worse, the motherboard is just a few months out of warranty.