1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Ati drivers on Nvidia Chipset ok?

Discussion in 'General Hardware' started by CDdude55, Jul 9, 2009.

  1. CDdude55

    CDdude55 Crazy 4 TPU!!!

    Joined:
    Jul 12, 2007
    Messages:
    8,178 (2.21/day)
    Thanks Received:
    1,277
    Location:
    Virginia
    Just want to make sure, i am thinking about going with maybe a HD 4890, but am kind of scared the ATI driers will mess with my Nvidia 680i chipset.

    But its fine using ATI drivers with a Nvidia chipset right?
     
    10 Year Member at TPU
  2. erocker

    erocker Senior Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    42,242 (10.42/day)
    Thanks Received:
    18,220
    Yes it's fine. Chipset drivers are for chipsets and video drivers are for video cards. They don't intermingle or screw each other. You're good.
     
    CDdude55 says thanks.
    10 Year Member at TPU
  3. boomstik360

    boomstik360

    Joined:
    Mar 19, 2009
    Messages:
    2,250 (0.73/day)
    Thanks Received:
    438
    :laugh:
     
  4. CDdude55

    CDdude55 Crazy 4 TPU!!!

    Joined:
    Jul 12, 2007
    Messages:
    8,178 (2.21/day)
    Thanks Received:
    1,277
    Location:
    Virginia
    lol, just making sure.
     
    10 Year Member at TPU
  5. hat

    hat Enthusiast

    Joined:
    Nov 20, 2006
    Messages:
    18,408 (4.68/day)
    Thanks Received:
    3,087
    Location:
    Ohio
    I had a x1800xl for a while with a 590SLI shipset.. worked fine (except for the graphics card being half-borked from the start)

    and overclock that damn cpu already.
     
    CDdude55 says thanks.
    10 Year Member at TPU
  6. BrooksyX

    BrooksyX

    Joined:
    Jan 7, 2008
    Messages:
    3,923 (1.12/day)
    Thanks Received:
    568
    Ive never had any problems running ati cards on a nvidia chipset or vice versa.

    As others have stated. You should be fine.
     
    CDdude55 says thanks.
  7. ASRockIQ

    ASRockIQ New Member

    Joined:
    Dec 9, 2008
    Messages:
    948 (0.30/day)
    Thanks Received:
    63
    Location:
    Daphne, AL
    i'm running a nVidia Card on my ATI Based MB << no issues here Bro.
     
    CDdude55 says thanks.
  8. n-ster

    Joined:
    Jan 11, 2009
    Messages:
    9,024 (2.87/day)
    Thanks Received:
    1,476
    Location:
    Montreal, Canada
    As everyone said, no problem at all :rolleyes: I guess it's better to make sure than to make a bad mistake :p
     
    CDdude55 says thanks.
  9. boomstik360

    boomstik360

    Joined:
    Mar 19, 2009
    Messages:
    2,250 (0.73/day)
    Thanks Received:
    438
    Very true
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)