• We've upgraded our forums. Please post any issues/requests in this thread.

bioshock problem with windows 7

Joined
May 27, 2008
Messages
3,577 (1.03/day)
Likes
533
Location
Huddersfield, uk
Processor E8200
Motherboard Asus P5KC
Cooling cooler master hyper tx3, 2x 120mm, 1x 80mm
Memory 4 GB DDR3 OCZ Black Edition
Video Card(s) Gigabyte HD 2600xt silent pipe II
Storage 500GB WD Sata / 60 GB Samsung IDE
Display(s) 20" samusng LCD, gaming at 1680 x 1050
Case some old amd thing
Audio Device(s) onboard
Power Supply 650W
Software Windows 8.1, with 'start is back' obviously
Benchmark Scores It boots whilst im still young so im pleased with that.
#1
theres no in game sound, you hear the movies but nothing in game or when you click buttons on the option menu. I tried the xp compatability and even vista and the ingame sounds work but then the game only fills the top quarter of my screen, when i try to enlarge the res or any graphics settings the game freezes, i worked out that if i go into task manager and select enlarge it'l work but at the smaller ress and will freez after a short period of time could anyone offer any help with this?
cheers ste
 

gdmsndmxr

New Member
Joined
Jan 9, 2010
Messages
1 (0.00/day)
Likes
0
#2
Bioshock working in Windows 7 64bit

Hi all,
First time posting. I got Bioshock (Non Steam version) to work by doing this. I installed it while running the installer in Windows XP SP2 compatibility. Whether that makes a difference, I am unsure.
Then to run the game, do this:
Start Menu
All Programs
Games
When you see Bioshock, right click and select Play - Direct X 9

The game worked like a charm. I had audio and the game never froze.
Good luck
:)