• We've upgraded our forums. Please post any issues/requests in this thread.

Cannot access USB external HDD in NTFS (not visible in Explorer nor in Comp Mgmt)

Joined
Apr 23, 2008
Messages
43 (0.01/day)
Likes
0
Processor Intel Core i5 2500K
Motherboard Asus P8P67 R3
Cooling NOCTUA NH-U9B-SE2
Memory Corsair Dominator 8 Go (Kit 4 x 2 Go) DDR3-SDRAM PC12800 CL8 - CMP4GX3M2A1600C8
Video Card(s) Sapphire Radeon HD 5870 - VaporX - 1024 Mo GDDR5 - PCI-Express 2.0
Storage SSD Intel Postville
Display(s) HP 2207h
Case CoolerMaster Cosmos 1000
Power Supply Seasonic X-760
Software W7 x64
#1
Hi All,

I recently reinstalled Win XP on a new SATA HDD.
Today I bought a Sitecom IDE-USB HDD case (http://www.sitecom.com/faq_result.php?groupid=15&subgroupid=46&productid=301) as I want to get some data back from the IDE disk. I've connected the IDE disk to Sitecom case and then plugged the USB in my Win XP PC.

Windows detects something (new drive detected), but the drive doesn't show up neither in Explorer, nor in Computer Management > Disk Management, nor in Removable Media snap-in.

I have a HDD and a CDROM drive also connected. When I removed the letter D: from the CDROM drive, I suddenly got again a detection balloon saying "Found new hardware" and then "Hardware installed successfully". But still the drive doesn't show up.

The IDE disk contains a NTFS bootable partition on which my old Win XP was installed.
Any idea why I can't access it with my USB case?
 
Joined
Nov 18, 2006
Messages
2,964 (0.73/day)
Likes
397
Location
your local vending machine
System Name HTPC||Lenovo IBM ThinkPad
Processor AMD Phenom II x4 965 stock 3.4GHz||Intel C2D T9300 @ 2.5GHz
Motherboard Zotac 890GX-ITX WiFi||Lenovo 8918CTO
Cooling Stock 3x 120's||Stock stuff
Memory 8GB (2x4GB) DDR3 6-6-6-15||3GB DDR2
Video Card(s) Asus 3870x2||nVidia Quadro NVS 140M
Storage 1TB Seagate Barracuda, 1x 2TB WD EARX ||Hitachi 160GB 7200RPM
Display(s) Samsung T260HD||
Case SilverStone Grandia GD05||
Audio Device(s) on-board||on-board
Power Supply Cooler Master 450W||6-cell
Software Windows 7 Pro x64||Windows 7 Pro x64/Linux Mint x64
#2
I know this sounds like the typical IT support...but is it plugged in and is it turned on? and make sure your cables are connected right and that it powers up
 
Joined
Apr 23, 2008
Messages
43 (0.01/day)
Likes
0
Processor Intel Core i5 2500K
Motherboard Asus P8P67 R3
Cooling NOCTUA NH-U9B-SE2
Memory Corsair Dominator 8 Go (Kit 4 x 2 Go) DDR3-SDRAM PC12800 CL8 - CMP4GX3M2A1600C8
Video Card(s) Sapphire Radeon HD 5870 - VaporX - 1024 Mo GDDR5 - PCI-Express 2.0
Storage SSD Intel Postville
Display(s) HP 2207h
Case CoolerMaster Cosmos 1000
Power Supply Seasonic X-760
Software W7 x64
#3
hi there,
yep don't worry, it's plugged in and everything is connected (as I said, Windows does detect something... The power cable for the HDD is correctly in as well as the IDE flat cable.
I've also tried with the HDD jumper on Master or CS, but it made no difference
 
Joined
Nov 18, 2006
Messages
2,964 (0.73/day)
Likes
397
Location
your local vending machine
System Name HTPC||Lenovo IBM ThinkPad
Processor AMD Phenom II x4 965 stock 3.4GHz||Intel C2D T9300 @ 2.5GHz
Motherboard Zotac 890GX-ITX WiFi||Lenovo 8918CTO
Cooling Stock 3x 120's||Stock stuff
Memory 8GB (2x4GB) DDR3 6-6-6-15||3GB DDR2
Video Card(s) Asus 3870x2||nVidia Quadro NVS 140M
Storage 1TB Seagate Barracuda, 1x 2TB WD EARX ||Hitachi 160GB 7200RPM
Display(s) Samsung T260HD||
Case SilverStone Grandia GD05||
Audio Device(s) on-board||on-board
Power Supply Cooler Master 450W||6-cell
Software Windows 7 Pro x64||Windows 7 Pro x64/Linux Mint x64
#4
Try to keep refreshing and see if that will bring it up...and when it says found new hardware, check to see if it comes up if you try to stop it to safely remove it
 
Joined
Apr 23, 2008
Messages
43 (0.01/day)
Likes
0
Processor Intel Core i5 2500K
Motherboard Asus P8P67 R3
Cooling NOCTUA NH-U9B-SE2
Memory Corsair Dominator 8 Go (Kit 4 x 2 Go) DDR3-SDRAM PC12800 CL8 - CMP4GX3M2A1600C8
Video Card(s) Sapphire Radeon HD 5870 - VaporX - 1024 Mo GDDR5 - PCI-Express 2.0
Storage SSD Intel Postville
Display(s) HP 2207h
Case CoolerMaster Cosmos 1000
Power Supply Seasonic X-760
Software W7 x64
#5
I left it connected and hit Refresh many times, as well as "Rescan" in the Disk Management Snap-in, not luck