• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

D620 ATI Radeon X1200 GPU/Memory Clock Issue


New Member
Mar 23, 2009
2 (0.00/day)
My friend recently installed Guild Wars to his eMachines D620. It has 1 GB, ~1.6-8ish GHz AMD X2 64 processor (not sure if it is dual core or not) of RAM an the integrated ATI Radeon X1200 video card (with 384 MB of shared RAM).

Trying to get everything out of his hardware, we used the ATI Catalyst Control Center to tweak some options. Asking for other ways to tweak the ATI cards (without overclocking) someone mentioned ATITool (which I had heard of before, but never tried). After installing the application, we realized it dealt with overclocking the GPU clocks, so we uninstalled it. We ended up sticking with the ATI tweaks using the CCC which ended up making the game run fairly smooth at the native resolution (1280x800).

However, when going to play the game again, it froze about 10 seconds into the log-in window and went to a black screen, with no text. After restarting, it did the same. We wondered if this could have been a result of the ATITool (I had seen similar happen to my Clevo D901C with RivaTuner, fixed only by a full format).

The Issue:
Without having touched a single option in ATITool (or any other application), the clocks are now messed up (using the newest version of GPU-Z to see the stats):

GPU Clock: 57 MHz (from default 400 MHz)
Memory Clock: 401 MHz (from default 200 MHz)

We uninstalled the drivers, then reinstalled them. Then we did a full format and reinstall of Windows XP Professional (32-bit), the issue remained. On the new format, I attempted using ATITool's sliders (out of desperation) to move the numbers to 400/200, but when I do they just revert to 57/401 MHz. GPU-Z shows 57/401 for clock speeds (and mentions the defaults of 400/200). I was not having the issue before installing ATItool and began having after running (yet not using) the program.

Possible Solution?
Resetting or reflashing the BIOS. I even called eMachines and they recommended a BIOS CMOS reset. I do not know how to do a BIOS CMOS reset on this specific computer as it did not come with a motherboard manual and I cannot find any listed online. Does anyone have the BIOS for this computer? The exact model is the eMachines D620-5177 (bought from Wal-Mart in Canada). It appears that all of the D620's all share common drivers.

I attempted resetting to default factory settings in the BIOS setup, but it did nothing. On eMachines support site, the V1.03 BIOS is listed and available for download, but when I run it in Windows XP, it does nothing (although it states it can be run in either a DOS or Windows OS. I looked through the code of the batch file and there seems to be some issue with a missing NAPA folder (only being the ATI one). When I run the phlash16 file directly, it gives me some issue with not being able to find a specific file. I have not tried to use WinPhlash by Phoenix Technologies. I did open it to look at it, and when I click on Advanced for the BIOS, it gives me an error.


Sorry for the wall of text, but any help would be appreciated. Thank you.
Feb 26, 2008
4,876 (0.83/day)
Joplin, Mo
System Name Ultrabeast GX2
Processor Intel Core 2 Duo E8500 @ 4.0GHZ 24/7
Motherboard Gigabit P35-DS3L
Cooling Rosewill RX24, Dual Slot Vid, Fan control
Memory 2x1gb 1066mhz@850MHZ DDR2
Video Card(s) 9800GX2 @ 690/1040
Storage 750/250/250/200 all WD 7200
Display(s) 24" DCLCD 2ms 1200p
Case Apevia
Audio Device(s) 7.1 Digital on-board, 5.1 digital hooked up
Power Supply 700W RAIDMAXXX SLI
Software winXP Pro
Benchmark Scores 17749 3DM06
what is the gaming performance like?


New Member
Mar 23, 2009
2 (0.00/day)
Gaming performance... when I open up Guild Wars, the main screen looks normal. About 5 seconds in, the background and mouse freeze. This is followed by a black screen (with no text or sounds). The only escape from this (as with other BSOD-type errors) is to restart the computer. Regular performance in Windows (DVD's/AVI's/web browsing) is fine, with the noted issues).


New Member
Nov 24, 2009
1 (0.00/day)
I know this thread is a few months old now and my answer is not even going to solve the original problem, but maybe it helps to stop the Radeon X1200 series owners' panicing from the low GPU clock they see in GPU-Z.

I have an Asus M2AVM mainboard with an integrated Radeon X1250 and GPU-Z reports the same for me. On this machine, I have never done any overclocking. I'm pretty sure GPU-Z just detects the GPU/MEM clocks wrong. For me it always shows 57 MHz for GPU no matter whether I'm on desktop or playing game. The card's performance is low, but nowhere near the level it would be if the GPU clock was 57 MHz :) The card can run Dragon Age or Oblivion at the lowest settings in 800x600, for instance.

Your problem was, obviously, somewhere else.