• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Flashing video bios onto rx470 8g (mining) card.

calicali

New Member
Joined
Oct 23, 2020
Messages
2 (0.06/day)
Hello,

I bought a second hand (mining) Radeon rx470 8g gddr5 pci-e dvi-d (uefi, quad firmware)) card, i mostly do simple (eagle) cad work but wanted to do some 3d stuff and this card was cheap enough to give it a try.
Seeing all those threads and warnings about flashing a new bios onto a grapphics card and the possibility of bricking the card made me cautious,
so i wanted to ask for some guidance here on the forum.

I think i have the following card:

For what its worth It does not say mining anywhere on the card, I have seen some pictures of other cards where it does say mining on the sticker.
Also i can use the singe dvi-d output as a second monitor on some of the bios switch settings (but not all!) but cannot do any rendering for instance.
(i am not that knowledgeable on computer-tech!).


As you can see on the sapphiretech site linked above there are 2 switches to select between 4 bioses.
I can post GPU-Z screengraps on any of the settings. This is most confusing for me, on which of these 4 possitions do i flash my video bios?

Looking at techpowerup there is only 1 bios avalible for my card.. at least there is no indication of it being a nitro(plus)+ card anywhere. It says NITRO on the fans and Radeon rx470 8g gddr5 pci-e dvi-d (uefi, quad firmware) on the sticker.


Is that the right one? What bios switch possition should i put the card before flashing? should i post some screenshots before doing any flashing?

Thank you in advance for reading, any guidance is much appreciated.
 

calicali

New Member
Joined
Oct 23, 2020
Messages
2 (0.06/day)
These are the bios switch modes avalible.

mode 1. ETH optimized mode

mode 2. ETH safe mode

mode 3. XMR/ZEC MODE

mode 4. AMD Default mode

It almost looks like mode 4 is the stock video bios. Still not shure if its save to flash a new bios to that bios switch location.

Now a strange thing has happend. Yesterday i was able to save one of the installed bioses with amdvbflash but today possibly after installing the nitro card drivers
and amd radeon software it lags a second or two and then freezes up my pc(or graphics) when i try to save the bios or load an image.
Should i uninstall amd radeon software and rx470 drivers in device manager before doing anything with amdvbflash?
 
Top