• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

FX AMD Radeon RX 580 2048SP BIOS ROM required ?? Please help me

krishan1987

New Member
Joined
May 26, 2024
Messages
6 (0.10/day)
Dear Mates,

I accidentally flashed unverified BIOS

I have the stock bios copy which before flashing.

But stock bios i save before flashing said Vbios not found error.

The BIOS got corrupted and can't amd drivers to work properly.

It would be of great help if anyone could share a copy of both BIOS so that I can reset to the original BIOS. I have attached a snapshot of TechGPUZ of my card below.


I have two GPU cards mentioned in the below link.

IF anyone has original bios for
1002 6FDF - 1043 0591 BIOS share them with me.

also added original bios I saved before flash.

highly appreciate

Please help..

1716727583839.png
1716728032057.png
1716728133417.png
 

Attachments

  • AMDcurrentbios.rom
    256 KB · Views: 22
Last edited:
Joined
Oct 22, 2014
Messages
13,611 (3.82/day)
Location
Sunshine Coast
System Name Lenovo ThinkCentre
Processor AMD 5650GE
Motherboard Lenovo
Memory 32 GB DDR4
Display(s) AOC 24" Freesync 1m.s. 75Hz
Mouse Lenovo
Keyboard Lenovo
Software W11 Pro 64 bit
Did you search in the Vbios collection?
 

krishan1987

New Member
Joined
May 26, 2024
Messages
6 (0.10/day)
Did you search in the Vbios collection?
Yes but verified collection sub id mismatched

any one has original bios please? because my stock backup file said no Vbios found
 
Joined
Oct 22, 2014
Messages
13,611 (3.82/day)
Location
Sunshine Coast
System Name Lenovo ThinkCentre
Processor AMD 5650GE
Motherboard Lenovo
Memory 32 GB DDR4
Display(s) AOC 24" Freesync 1m.s. 75Hz
Mouse Lenovo
Keyboard Lenovo
Software W11 Pro 64 bit
Unverified does not mean incorrect or unsafe.
There will only be a mismatch if you flashed the incorrect Vbios onto the GPU.
Try graphics driver 22.8.1 as later will cause issues.
 
Last edited:
Joined
Mar 20, 2008
Messages
1,570 (0.26/day)
System Name Ryzen5900X
Processor AMD Ryzen 5900X
Motherboard Gigabyte B550 AORUS PRO AC
Cooling NZXT Kraken X62
Memory 4x G.Skill F4-3600C17D-8GTZ
Video Card(s) AMD Radeon RX 6800XT Midnight Black
Yes but verified collection sub id mismatched

any one has original bios please? because my stock backup file said no Vbios found
Please remove cooler and make a clear picture of the whole PCB. I will try to locate the correct bios based on the information I find in the picture.
 

krishan1987

New Member
Joined
May 26, 2024
Messages
6 (0.10/day)
Unverified does not mean incorrect or unsafe.
There will only be a mismatch if you flashed the incorrect Vbios onto the GPU.
Try graphics driver 22.8.1 as later will cause isthank you
I flashed unverified bios and faced error code 43 after that patched error code 43 by using atikmdag-patcher.exe now everything ok. thank you, friend,

Please remove cooler and make a clear picture of the whole PCB. I will try to locate the correct bios based on the information I find in the picture.
I flashed unverified bios and faced error code 43 after that patched error code 43 by using atikmdag-patcher.exe now everything ok. thank you, friend, If any error occurs let you know with the image as you request

Thanks, everyone support me to solve the issue. and thanks again. Welcome all comments. love you, everyone.
 

Attachments

  • 1.png
    1.png
    244.8 KB · Views: 35
Joined
Mar 20, 2008
Messages
1,570 (0.26/day)
System Name Ryzen5900X
Processor AMD Ryzen 5900X
Motherboard Gigabyte B550 AORUS PRO AC
Cooling NZXT Kraken X62
Memory 4x G.Skill F4-3600C17D-8GTZ
Video Card(s) AMD Radeon RX 6800XT Midnight Black
I flashed unverified bios and faced error code 43 after that patched error code 43 by using atikmdag-patcher.exe now everything ok. thank you, friend, If any error occurs let you know with the image as you request
If you used atikmdag-patcher, your problem is not solved. You just worked around the problem. You are still using a wrong bios.
Remove the cooler and make a clear picture if you really want the correct bios.
 

krishan1987

New Member
Joined
May 26, 2024
Messages
6 (0.10/day)
If you used atikmdag-patcher, your problem is not solved. You just worked around the problem. You are still using a wrong bios.
Remove the cooler and make a clear picture if you really want the correct bios.
Yes facing matters friend i have attached images bellow. Thank for your kindness..
 

Attachments

  • 20240530_131140.jpg
    20240530_131140.jpg
    1.4 MB · Views: 35
  • 20240530_131242.jpg
    20240530_131242.jpg
    1.4 MB · Views: 34
  • 20240530_131234.jpg
    20240530_131234.jpg
    1.2 MB · Views: 28
  • 20240530_131248.jpg
    20240530_131248.jpg
    1.5 MB · Views: 30
  • 20240530_131252.jpg
    20240530_131252.jpg
    1.5 MB · Views: 30
  • 20240530_131121.jpg
    20240530_131121.jpg
    1.8 MB · Views: 29
Joined
Mar 20, 2008
Messages
1,570 (0.26/day)
System Name Ryzen5900X
Processor AMD Ryzen 5900X
Motherboard Gigabyte B550 AORUS PRO AC
Cooling NZXT Kraken X62
Memory 4x G.Skill F4-3600C17D-8GTZ
Video Card(s) AMD Radeon RX 6800XT Midnight Black
Yes facing matters friend i have attached images bellow. Thank for your kindness..
Can you make a photo of the backside of the PCB?

Likely the correct bioses for your card:
 

krishan1987

New Member
Joined
May 26, 2024
Messages
6 (0.10/day)

Attachments

  • 20240531_173807.jpg
    20240531_173807.jpg
    2.3 MB · Views: 35
  • 20240531_173652.jpg
    20240531_173652.jpg
    2.4 MB · Views: 33
  • 20240531_173635.jpg
    20240531_173635.jpg
    1.9 MB · Views: 30
Last edited:
Joined
Mar 20, 2008
Messages
1,570 (0.26/day)
System Name Ryzen5900X
Processor AMD Ryzen 5900X
Motherboard Gigabyte B550 AORUS PRO AC
Cooling NZXT Kraken X62
Memory 4x G.Skill F4-3600C17D-8GTZ
Video Card(s) AMD Radeon RX 6800XT Midnight Black
Top