• We've upgraded our forums. Please post any issues/requests in this thread.

HD 7850 openCL

Joined
Mar 6, 2012
Messages
13 (0.01/day)
Likes
3
#1
Hi,
I have an HD 7850 and I am trying to use it with Blender 2.63 and the opencl feature.

I cannont seem to get it to work so I was wondering if I have to enable opencl within CCC or install another driver.

Thanks for the help in advance.

-MrAwesome987
 
Joined
May 9, 2011
Messages
1,877 (0.78/day)
Likes
878
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Core(TM) i7 4820k @ 4.40 GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block and 360RAD H2o
Memory Gskill RipjawsZ 16Gb 9-10-9-28 3T @ 2021Mhz
Video Card(s) Zotac GTX 1080ti AMP EXTREME, EVGA GTX 980ti FTW
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 3200*1800]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 15063.13]
#2
Hi,
I have an HD 7850 and I am trying to use it with Blender 2.63 and the opencl feature.

I cannont seem to get it to work so I was wondering if I have to enable opencl within CCC or install another driver.

Thanks for the help in advance.

-MrAwesome987
Hi

make sure your setup meets System Requirements & Driver Compatibility

this - http://developer.amd.com/sdks/AMDAPPSDK/Pages/default.aspx

nb: you may need to use ATI Radeon HD ATI Catalyst 11.12 Driver Suite for this to function

hope this helps

atb (all the best)

Law-II
 
Last edited:
Joined
Apr 7, 2011
Messages
1,153 (0.47/day)
Likes
466
System Name Desktop
Processor Intel i7-3930k
Motherboard ASUS Sabertooth X79
Cooling Intel AIO
Memory 8x4GB 1866MHz
Video Card(s) EVGA GTX 970 SC
Storage Adaptec 2405 SAS controller> Hitachi SAS 15k 450GB|2xSeagate 2TB|WD Black 4 TB|HP Ultrium 1760 LTO4
Display(s) HP ZR24w
Case Fractal Define XL Black
Audio Device(s) Schiit Modi Uber>Schiit Asgard 2>Sennheiser HD600
Power Supply Corsair HX850
Software Windows 10 Pro x64
#3
Hi,
I have an HD 7850 and I am trying to use it with Blender 2.63 and the opencl feature.

I cannont seem to get it to work so I was wondering if I have to enable opencl within CCC or install another driver.

Thanks for the help in advance.

-MrAwesome987
Did you install the OpenCL driver when installing display drivers/CCC? I think it's called AMD APP, and you don't have to enable OpenCL anywhere when you have it installed.
Also, you can use GPU-Z to check if you already have it installed.
 
Joined
Mar 6, 2012
Messages
13 (0.01/day)
Likes
3
#4
Thank you both for the quick reply!

I checked and I do have AMD APP installed, and in GPU-Z it has the box at the bottom checked.

Law, I have and HD 7850, a Phenom II 1090t, and 8 Gb of ram.

I uninstalled, and reinstalled CCC, and tried it again, and Blender still crashes at about the same time everytime.

Thanks again!

-MrAwesome987
 
Joined
Apr 7, 2011
Messages
1,153 (0.47/day)
Likes
466
System Name Desktop
Processor Intel i7-3930k
Motherboard ASUS Sabertooth X79
Cooling Intel AIO
Memory 8x4GB 1866MHz
Video Card(s) EVGA GTX 970 SC
Storage Adaptec 2405 SAS controller> Hitachi SAS 15k 450GB|2xSeagate 2TB|WD Black 4 TB|HP Ultrium 1760 LTO4
Display(s) HP ZR24w
Case Fractal Define XL Black
Audio Device(s) Schiit Modi Uber>Schiit Asgard 2>Sennheiser HD600
Power Supply Corsair HX850
Software Windows 10 Pro x64
#5
It could be that AMD haven't properly implemented OpenCL for HD7xxx series yet...or it could be blender itself. I can't help you much more because I don't have as similar card to test it myself, your best bet is to find someone else to try and see if it also crashes.

My opinion on this is that drivers aren't still quite good, and it could be that blender itself needs some work (This is just my opinion).

EDIT: I found this comment on some other forum while searching for similar problem:
smallluxgpu crashes the 7970 driver (which worked almost as fast as the cycles interactive viewport on the 5870?

And I did try that benchmark scene you mention last week, but gpu-accelerated opencl in cycles on an amd card just does not work (yet?). When initializing it stops, throws a couple of errors, and that's it: black screen. Software (cpu) based cycles rendering works, though.

The early state of the drivers can be felt across the board - very much so in regards to opencl.
SmallLuxGPU is also an OpenCL based renderer, so I guess the cause is a buggy driver (for now...).
 
Joined
May 9, 2011
Messages
1,877 (0.78/day)
Likes
878
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Core(TM) i7 4820k @ 4.40 GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block and 360RAD H2o
Memory Gskill RipjawsZ 16Gb 9-10-9-28 3T @ 2021Mhz
Video Card(s) Zotac GTX 1080ti AMP EXTREME, EVGA GTX 980ti FTW
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 3200*1800]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 15063.13]
#6
It could be that AMD haven't properly implemented OpenCL for HD7xxx series yet...or it could be blender itself
Hi

+1 repman244

@MrAwesome987 if you get an opportunity it may be worth your while letting the AMD driver team know http://www.amdsurveys.com/se.ashx?s=5A1E27D27E29B0E3

nb: I did not see full implementation for the HD7xxx series under the heading System Requirements & Driver Compatibility only the V7800, V7750 & M7820 ATI FirePro Graphics at this time.

atb

Law-II
 
Last edited:

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
10,397 (4.85/day)
Likes
5,477
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.2Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Zalman CPNS9900MAX 130mm
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) MSI AMD Radeon R9 390 GAMING 8GB @ PCI-E 3.0
Storage 2x120Gb SATA3 Corsair Force GT Raid-0, 4x1Tb RAID-5, 1x500GB
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 17.10
Benchmark Scores Benchmarks aren't everything.
#7
OpenCL apps have run on my 6870s, I don't understand why it wouldn't work on 7000-series unless its a driver bug. How do other compute applications work that use OpenCL?
 
Joined
Apr 7, 2011
Messages
1,153 (0.47/day)
Likes
466
System Name Desktop
Processor Intel i7-3930k
Motherboard ASUS Sabertooth X79
Cooling Intel AIO
Memory 8x4GB 1866MHz
Video Card(s) EVGA GTX 970 SC
Storage Adaptec 2405 SAS controller> Hitachi SAS 15k 450GB|2xSeagate 2TB|WD Black 4 TB|HP Ultrium 1760 LTO4
Display(s) HP ZR24w
Case Fractal Define XL Black
Audio Device(s) Schiit Modi Uber>Schiit Asgard 2>Sennheiser HD600
Power Supply Corsair HX850
Software Windows 10 Pro x64
#9
OpenCL apps have run on my 6870s, I don't understand why it wouldn't work on 7000-series unless its a driver bug. How do other compute applications work that use OpenCL?
The problem is that the 7 series cards are totally different than 5 and 6 series, so it's not just tweaking the OpenCL driver to make it work. It's clear when you look at the fact that there are still no FirePro cards based on GCN, there is a lot of work to be done on OpenGL and OpenCL for those cards as well.
Of course, the other problem might be in the apps itself aren't recognizing the cards correctly.
 
Joined
May 9, 2011
Messages
1,877 (0.78/day)
Likes
878
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Core(TM) i7 4820k @ 4.40 GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block and 360RAD H2o
Memory Gskill RipjawsZ 16Gb 9-10-9-28 3T @ 2021Mhz
Video Card(s) Zotac GTX 1080ti AMP EXTREME, EVGA GTX 980ti FTW
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 3200*1800]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 15063.13]
#10
Last edited: