• We've upgraded our forums. Please post any issues/requests in this thread.

How to force CHKDSK fix index on NTFS drive?

Jan 3, 2007
454 (0.11/day)
System Name celer
Processor Pentium 4 650 3.4GHz 2MB L2
Motherboard MSI PM8M3-V
Cooling Thermalright SI-128 SE
Memory 2048MB OCZ 2-3-2-5 2T at 200Mhz
Video Card(s) Sapphire Radeon R9100
Storage 250G Samsung 850 PRO (MZ-7KE256BW) - 1024G WD Black (WD1003FZEX)
Display(s) 19' iiyama ProLite E1980SD 1280x1024 75Hz DVI
Case Eurocase moded
Audio Device(s) onboard
Power Supply Enermax 620W Liberty
Mouse Logitech MX510 red
Keyboard eTech PS/2 keyboard
Software Win XP SP3
Benchmark Scores http://hwbot.org/submission/2455634_
At first I made the mistake using Partition Magic v8.00 to setup a drive (2G FAT32 for OS, 184G NTFS for data). PM v8.00 is faulty and screw up the drive, mainly the NTFS partition. Usually the results are not as dramatic as I experience (mostly only windows is slow in powering off), however on VIA chipset, as this old machine use, it is hell. New files are corrupted and gone missing after reboot, etc. Bad.
(results of using PM 8.00 on VIA chipsets from Symatec page are not exaggerated at all)
In PM v8.02 or v8.05 it should be fixed, however even the v8.02 is not going to allow me to fix ANY error. It finding twice
Error 1611 bad system file name
...and about hundred times...
Error 1527 bad update sequence number
...and button FIX is still grayed out.

So I tried a workaround - used the recommended Acronis Partition Expert v8 and I downsized the D drive a bit and then get it back to former status and quess what - most of the errors and problems are gone now! No more bit table troubles with MFT, but the new file corruption and files gone missing behaviour sadly continue...

So the first thing one do is to run chkdsk, right? So I run it with parameters /x /f and it always says "Fixing error in index $I30 file 5. Checking of index finished." - that it should be translated to english... However when I run it imediatelly again, it report the very same thing!
So the error is NOT fixed.

So I get the idea that I just find the file no. 5 using MFT table and kill it. Using DiskEdit utility (from Win2k SP4 CD by M$ itself, grab it there: http://rapidshare.com/files/189278835/DiskEdit.zip ) I opened the NTFS D drive and - sadly instead of the path and file I saw only couple of empty boxes... I can check other files fine, so, what now? It is a system file or hidden something then...?

I tried threat that as it is a deleted file fragment or something like that. I tried the Recuva utility from Sysinternals, because it can safely erase the deleted files, based on the MFT infos... If you did not know, well, then MFT store and keep information about every files you ever had on your HDD, so... (MFT on my drive have 57MB currently) Recuva found like 16k of deleted files, so I check them all and say - delete them right away!
But things went wrong, as some of the files are "resident" in the MFT table, so, they are not deleted. Also Recuva cannot delete the infos MFT keep about files long time gone from HDD. So I tried the recovering utility Restoration v3.2.13, because it know not only erase files, but also erase the infos about them in MFT! Then in Recuva you see only 16k of empty lost file infos, hehe.
But that did not help me either.
Then I tried Winhex v15.1, witch offer fantastic things, and among others - erasing the unnecessary MFT infos. However it again only erase the missing files infos, not remove them from MFT - it probably did not know how to rebuild the MFT then... So, no improve in the chkdsk error and HDD behaviour done...

Hence - anyone have any ideas how to fix this index problem? Chkdsk /x /d /r D: run way too long and at the end, no change at all.

Also I tried chkdsk from the Windows repair console, however no difference. It says that he find something, but then again - it did not fix it. And only report that find and fixed errors the first time I run it. Each next run it make there pauses (hence 3 errors, I presume) but not report them anymore!
Much less to fix them...

So when I get back in win, it way agaion like that:

Program CHKDSK ověřuje soubory (fáze 1 z 3)...
Ověření souboru dokončeno.
Program CHKDSK ověřuje rejstříky (fáze 2 z 3)...
Probíhá oprava chyby v rejstříku $I30 souboru 5.
Ověření rejstříku dokončeno.
Program CHKDSK ověřuje popisovače zabezpečení (fáze 3 z 3)...
Ověření popisovače zabezpečení bylo dokončeno.

193253884 kB místa na disku celkem.
190638064 kB v 37513 souborech uživatele.
14644 kB v 1583 rejstřících.
0 kB v chybných sektorech.
78740 kB používá systém.
16384 kB zabírá soubor s protokolem.
2522436 kB na disku je volných.

4096 bajtů v každé alokační jednotce
48313471 alokačních jednotek na disku celkem.
630609 volných alokačních jednotek

So, anyone get any idea about chkdsk replacement that works? Or thanks to PM, I have to backup my entire drive on DVDs and format it and then copy all the data back or what?!

It is VERY annoying to lose data in new files and I of course run diagnostic tests on the drive and then SpinRite v6 and the drive is perfectly okay. A not so old 200G Seagate PATA one :)

PM reporting WAY less errors after the trick I made with Acronis Partition Expert, but still... they are there. Help?