• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I can’t boot into windows

Thegtx1660gamer

New Member
Joined
Jun 19, 2021
Messages
2 (0.05/day)
I keep get a message when I boot my pc"please power down and connect your pcie cables"even though the cable is plugged in properly

specs

Cpu:i5-9400f
Gpu:Gtx 1660 ventus oc 6g
Motherboard:gigabyte b360m ds3h
Ram:16g can’t remember the name
Hdd:1tb can’t remember the name either
Ssd:256g can’t remember the name too
Power supply:evga 550w supernova ga gold edition

your help would be greatly appreciated
 
Last edited:
Joined
Nov 8, 2020
Messages
214 (0.82/day)
System Name Dusty
Processor 8700k - delid - 5Ghz
Motherboard ASUS Maximus X Hero
Cooling Noctua NH-D15
Memory Corsair Vengence LPX 32GB
Video Card(s) MSI RTX 3070 Gaming X
Storage yes
Case Fractal Design Define R6
Power Supply EVGA SuperNOVA 750w
VR HMD Oculus CV1
add your PC specs and double check the cables as it says, unplug and replug them, make sure there isnt arnt dirt or dust in any of the connections, as well as re-seat the GPU in the PCIe slot and check for dust there as well.
Does your PSU have additional PCIe power cables? If so, try the other pair.
 

Thegtx1660gamer

New Member
Joined
Jun 19, 2021
Messages
2 (0.05/day)
add your PC specs and double check the cables as it says, unplug and replug them, make sure there isnt arnt dirt or dust in any of the connections, as well as re-seat the GPU in the PCIe slot and check for dust there as well.
Does your PSU have additional PCIe power cables? If so, try the other pair.
Yeah I tried a different pcie cable still no avail I updated the thread by the way so refresh the page I put my specs

I’m thinking about flashing my gpu
 
Last edited:
Top