• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

i7-9750H isn't using Turbo anymore

Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
Hi together,
playing around with TrottleStop to undervolt my CPU (Razer Blade 15 Advanced Mid 19, i7-9750H with 2080 Max-Q) to get better temperatures.

Everything undervolting worked fine, but I switched the Non Turbo Ratio and now it's saying locked.
Now when i run the Benchmark the Power Consumption never is about 30W (because no Turbo and Mutiplier never higher than 26).
I simply can't unlock it and the CPU isn't going into Turbo anymore - can somebody help me?

EDIT 02:00 pm: Seems to be a ThrottleStop Problem - reboot and trying XTU show max power drain (60 W Package TDP @ 4.0 GHz, then constant 45W)
 

Attachments

Last edited:

Empecial

New Member
Joined
May 24, 2020
Messages
16 (0.21/day)
hm weird. dont have alot of experience with this but i once locked an option and couldn't edit it later so i deleted the throttlestop.ini and restarted the laptop and the settings had gone back and it was unlocked again. i dont know if restarting is necessary
 
Joined
May 10, 2020
Messages
82 (0.90/day)
Processor Ryzen 9 3900X
Motherboard Asus ROG Strix B550-F Gaming
Cooling Be Quiet! Dark Rock 4
Memory 16 Gb G.Skill TridentZ RGB 3600CL16
Video Card(s) Gigabyte RTX2070 Super Windforce 3X OC
Storage 512 Gb Intel P660 NVMe + 1 Tb WD Blue
Display(s) MSi Optix MAG241C + Samsung C24RG50
Case Corsair Carbide SPEC-06
Power Supply Corsair CV650
Mouse Razer Basilisk
Keyboard Razer Ornata Chroma
Benchmark Scores 3dMark TimeSpy - 10314 (CPU 11953 - GPU 10071) Cinebench R20 - 7229
Why speed shift is not active on your laptop ?
 
Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
Why speed shift is not active on your laptop ?
It is just disabled to see if it is causing the issue. Wasn't the case.

hm weird. dont have alot of experience with this but i once locked an option and couldn't edit it later so i deleted the throttlestop.ini and restarted the laptop and the settings had gone back and it was unlocked again. i dont know if restarting is necessary
I tried that, it's still happening..
 
Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
To make it more interesting - currently using XTU which seems to work, but something strange is happening:
Gaming is rising the power up to 45W constant, and 60W turbo. But 80W turbo boost ist not working any more.
And during benchmark (Cinebench R20 e.g.) ist just constantly at 45W....
 
Joined
May 10, 2020
Messages
82 (0.90/day)
Processor Ryzen 9 3900X
Motherboard Asus ROG Strix B550-F Gaming
Cooling Be Quiet! Dark Rock 4
Memory 16 Gb G.Skill TridentZ RGB 3600CL16
Video Card(s) Gigabyte RTX2070 Super Windforce 3X OC
Storage 512 Gb Intel P660 NVMe + 1 Tb WD Blue
Display(s) MSi Optix MAG241C + Samsung C24RG50
Case Corsair Carbide SPEC-06
Power Supply Corsair CV650
Mouse Razer Basilisk
Keyboard Razer Ornata Chroma
Benchmark Scores 3dMark TimeSpy - 10314 (CPU 11953 - GPU 10071) Cinebench R20 - 7229
To make it more interesting - currently using XTU which seems to work, but something strange is happening:
Gaming is rising the power up to 45W constant, and 60W turbo. But 80W turbo boost ist not working any more.
And during benchmark (Cinebench R20 e.g.) ist just constantly at 45W....
it would be better if you post a TPL screenshot of your system from Throttlestop, to understand how PL1 and PL2 are set on your computer.
 
Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
Here you go!
I figured out, that I need to enable a max perfomance thing in Razer Software to allow the turbo to work over 45W...

But it is still limiting at 70W.
 

Attachments

Joined
May 10, 2020
Messages
82 (0.90/day)
Processor Ryzen 9 3900X
Motherboard Asus ROG Strix B550-F Gaming
Cooling Be Quiet! Dark Rock 4
Memory 16 Gb G.Skill TridentZ RGB 3600CL16
Video Card(s) Gigabyte RTX2070 Super Windforce 3X OC
Storage 512 Gb Intel P660 NVMe + 1 Tb WD Blue
Display(s) MSi Optix MAG241C + Samsung C24RG50
Case Corsair Carbide SPEC-06
Power Supply Corsair CV650
Mouse Razer Basilisk
Keyboard Razer Ornata Chroma
Benchmark Scores 3dMark TimeSpy - 10314 (CPU 11953 - GPU 10071) Cinebench R20 - 7229
Here you go!
I figured out, that I need to enable a max perfomance thing in Razer Software to allow the turbo to work over 45W...

But it is still limiting at 70W.
According to the TPL tab, your system is correctly configured for a shot term (28 sec) Power Limit of 80W and a sustained Power Limit of 60W. That's perfectly fine for a gaming notebook.
What I can't understand is the "45W limited.PNG" screenshot above :confused:
With your settings you shouldn't see PL1 and PL2 in red when the system hits 45W :kookoo:

Was that picture taken with a limited performance mode activated ?
 
Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
Both screenshots are from the same benchmark run.

Attached you find the screenshot of a log (OpenHardwareMonitor). I was running the 1024M TS Bench twice in a row, without changing anything.

At the beginning there is a short boost up to 70W (should be 80W), after that the CPU is running constantly in that 45W with the PL1 and PL2 on..
The designed TDP from Intel is 45W, could it be that it simply just can't run fulltime at 60W?
 

Attachments

Joined
May 10, 2020
Messages
82 (0.90/day)
Processor Ryzen 9 3900X
Motherboard Asus ROG Strix B550-F Gaming
Cooling Be Quiet! Dark Rock 4
Memory 16 Gb G.Skill TridentZ RGB 3600CL16
Video Card(s) Gigabyte RTX2070 Super Windforce 3X OC
Storage 512 Gb Intel P660 NVMe + 1 Tb WD Blue
Display(s) MSi Optix MAG241C + Samsung C24RG50
Case Corsair Carbide SPEC-06
Power Supply Corsair CV650
Mouse Razer Basilisk
Keyboard Razer Ornata Chroma
Benchmark Scores 3dMark TimeSpy - 10314 (CPU 11953 - GPU 10071) Cinebench R20 - 7229
Both screenshots are from the same benchmark run.

Attached you find the screenshot of a log (OpenHardwareMonitor). I was running the 1024M TS Bench twice in a row, without changing anything.

At the beginning there is a short boost up to 70W (should be 80W), after that the CPU is running constantly in that 45W with the PL1 and PL2 on..
The designed TDP from Intel is 45W, could it be that it simply just can't run fulltime at 60W?
quite strange.
Intel designed TDP of 45W is just an indication: it is not enforced in the CPU.
BIOS (or software) is in charge for that, so it seems that in your notebook the PL2 is set to 70W and PL1 is set to 45W, no matter what ThrottleStop is reading.

Temperatures are quite low, but that's because your CPU is throttled down by PL1.
To be honest, the Razer Blade is a quite thin gaming notebook, so I think 70W/45W is not a wrong choice ad should provide good performance even while gaming. Benchmarks tends to be more demanding than games, so even if you see power consumption at 60W during a benchmark, it will usually stay below 45W during a game.
 
Last edited:
Joined
May 28, 2020
Messages
7 (0.10/day)
Location
Germany
System Name Razer Blade 15 Advanced Mid-2019
Processor Intel i7-9750H
Motherboard CH350?
Cooling Thermal Grizzly Kryonaut
Memory Ballistix Sport LT 32GB DDR4-2666
Video Card(s) NVIDIA GeForce RTX 2080 Max-Q
Storage Samsung SSD 970 EVO Plus 2 TB M.2
Display(s) BenQ XL2420Z
Audio Device(s) Razer Kraken 7.1 Chroma
Power Supply 230W
Mouse Razer Mamba Wireless
Keyboard Razer BlackWidow Ultimate
It's exactly as you said. Google showed some users have similiar thoughts than me, these are resulting in flashing a modified BIOS to unlock some options.
At the moment I'm fine, when the GPU is running while gaming the CPU temp is raising up to the 90° C, so TL would kick in anyways..

So than the thread can be closed, everything is clear now! Thank you very much @Max(IT) !
 
Top