• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Is there a way to test if a USB device is causing my USB ports to fail?


New Member
Feb 9, 2014
3 (0.00/day)
Board: D945GCCR
Processor: Intel Celeron D 420
OS: Windows XP Professional 32bit
USB Ports Gone Bad: All at the same time. Devices plugged in to ports are not detected in the BIOS, or Windows.

Hello, this is my first post here, my friend frequents here and I figured I would try here for some help.

After a few days of Googling around using various terms pertaining to what I am trying to figure out, I've come across no solution and no definitive answer.

What I'm trying to do is figure out if a USB device has fried our USB ports/controllers on 2 motherboards.

The events are as follows:
I get notified that a printer or card reader is not working, I check device manager there is nothing shown under USB device except for the Root Hubs and Intel(R) USB Universal Host Controllers (There are 5 Host controllers and 5 Root Hubs) (There are normally 5 devices connected to the USB ports, 2 Card readers that run off of USB to Serial adapters, 1 Epson Printer that is also a check scanner, and a pin/signature pad. We also have a second computer running this exact same setup and it hasn't had the same issue or anything similar -knock on wood-)

I restart the system, nothing is detected still, and devices still do not work, I unplug all devices and restart the system again and try plugging one device in at a time to see if that helps which it does not. I unplug the devices and remove the drivers for both the Root Hubs and Universal host controllers and let windows re detect them, windows finds all of the universal host controllers and root hubs but devices I plug back in are still not detected.

At this point I replaced the motherboard the first time, then a week later the same issue occurred with the same exact symptoms, used the same troubleshooting to no avail, I tested the PSU and voltages are normal on my meter as well as in the BIOS. I tried changing the power supply anyway but the issue still occurs on both motherboards.

One thing we did notice is before this happened everything would operate fine, but after the issue had manifested itself, itwould take around 5 minutes to boot up when previously it would take about a minute, in task manager System will show CPU usage at 99 percent.

The reason we think it might be a USB device is we have a second computer set up the exact same way that is not experiencing this issue and has never previously -knock on wood-.

Is there any way to easily tell what is going on and why this issue is happening?

If there's anything I'm leaving out that can be helpful to helping me troubleshoot this issue, I'd be more than willing to post it, I've covered everything I can think of off the top of my head.