• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

linux resulution please help

Joined
Feb 27, 2022
Messages
34 (0.10/day)
just finished building my new pc and installed pop os i downloaded the iso with the nvidia drivers included but i am having some wierd issues my resulution is stuck at 1028 x 763 (4:3) and i cant change it i am using a gtx 460 1 GB i have done all the updates in the pop shop exept for the nvidia-driver-390 and i get an error message whenever i try to download it
please help
thanks in advance
 

Frick

Fishfaced Nincompoop
Joined
Feb 27, 2006
Messages
17,850 (2.89/day)
Location
Piteå
System Name Black MC in Tokyo
Processor Ryzen 5 2600x
Motherboard Asrock B450M-HDV
Cooling Be Quiet! Pure Rock 2
Memory 2 x 8GB G-skill Aegis 3000 or somesuch
Video Card(s) Gainward RTX 3060ti Ghost OC
Storage Kingston A400 240GB | WD Black SN750 2TB |WD Blue 1TB x 2 | Toshiba P300 2TB | Seagate Expansion 8TB
Display(s) Samsung U32J590U 4K + BenQ GL2450HT 1080p
Case Fractal Design Define R4
Audio Device(s) Line6 UX1 + some headphones
Power Supply Seasonic Core GC500
Mouse Logitech G602
Keyboard Dell Sk3205
VR HMD Acer Mixed Reality Headset
Software Windows 10 Pro
Benchmark Scores Rimworld 4K ready!
What does the error messege say?

When it comes to specific Linux distros the best best is usually support forums, if such a thing exists for it. A quick google say it's a common problem.
 
Joined
Feb 27, 2022
Messages
34 (0.10/day)
What does the error messege say?

When it comes to specific Linux distros the best best is usually support forums, if such a thing exists for it. A quick google say it's a common problem.
Error while installing package: installed nvidia-dkms-390 package post-installation script subprocess returned error exit status 10

Have you tried downloading and installing the driver manually?
on the nvidia website? like on windows?
 
Last edited:
Joined
Feb 28, 2022
Messages
263 (0.77/day)
Joined
Feb 27, 2022
Messages
34 (0.10/day)
Yes, though you will need to manually install using terminal, found this after a quick search https://www.addictivetips.com/ubuntu-linux-tips/nvidia-graphics-drivers-pop_os/ there will be lots of other guides out there as Pop OS is based on Ubuntu

NV drivers for Linux for GTX 460 https://www.nvidia.co.uk/Download/driverResults.aspx/184616/en-uk
i tried through the pop shop and that did not work and i tried through the command line and it says:
"No drivers found for installation." i am also pretty sure i downloaded the NVIDIA iso

Yes, though you will need to manually install using terminal, found this after a quick search https://www.addictivetips.com/ubuntu-linux-tips/nvidia-graphics-drivers-pop_os/ there will be lots of other guides out there as Pop OS is based on Ubuntu

NV drivers for Linux for GTX 460 https://www.nvidia.co.uk/Download/driverResults.aspx/184616/en-uk
do i download the drivers form the website or just use the terminal?
 
Joined
Feb 28, 2022
Messages
263 (0.77/day)
i tried through the pop shop and that did not work and i tried through the command line and it says:
"No drivers found for installation." i am also pretty sure i downloaded the NVIDIA iso


do i download the drivers form the website or just use the terminal?
So you used "ubuntu-drivers list" and "sudo ubuntu-drivers install nvidia-driver-***" commands in the terminal?

i tried through the pop shop and that did not work and i tried through the command line and it says:
"No drivers found for installation." i am also pretty sure i downloaded the NVIDIA iso


do i download the drivers form the website or just use the terminal?
You can try both, if trying the manual driver download and install, NV instructions say: "Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86_64-390.147.run"
 
Joined
Feb 27, 2022
Messages
34 (0.10/day)
So you used "ubuntu-drivers list" and "sudo ubuntu-drivers install nvidia-driver-***" commands in the terminal?


You can try both, if trying the manual driver download and install, NV instructions say: "Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86_64-390.147.run"
i tried the "sudo ubuntu-drivers install nvidia-driver-390" and that doesn't work how do i do the second method?

i looked it up and when i typed nvidia-smi it just says "
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

"
i also tried "sudo apt upgrade" and it just says"
Errors were encountered while processing:
nvidia-dkms-390
nvidia-driver-390
E: Sub-process /usr/bin/dpkg returned an error code (1)

"
 

bug

Joined
May 22, 2015
Messages
11,218 (3.99/day)
Processor Intel i5-12600k
Motherboard Asus H670 TUF
Cooling Arctic Freezer 34
Memory 2x16GB DDR4 3600 G.Skill Ripjaws V
Video Card(s) EVGA GTX 1060 SC
Storage 500GB Samsung 970 EVO, 500GB Samsung 850 EVO, 1TB Crucial MX300 and 2TB Crucial MX500
Display(s) Dell U3219Q + HP ZR24w
Case Raijintek Thetis
Audio Device(s) Audioquest Dragonfly Red :D
Power Supply Seasonic 620W M12
Mouse Logitech G502 Proteus Core
Keyboard G.Skill KM780R
Software Arch Linux + Win10
Do not install drivers by hand, it's not necessary. Ubuntu has a dedicated tool for installing proprietary drivers (which PopOs inherits).

Look for help on PopOs or Ubuntu forums, people there know know about that error code.

Fwiw, there's nothing wrong with installing drivers by hand. But the process is more involved/error prone. And if successful, it leaves you with a driver that won't update ever. You'll need to keep going to Nvidia's website, check for new versions, retrieve and install them yourself.

Also remember a proper update in Ubuntu/PopOs is done by sudo apt update && sudo apt dist-upgrade.
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Hi,
Have you tried a different distro ?
 

bug

Joined
May 22, 2015
Messages
11,218 (3.99/day)
Processor Intel i5-12600k
Motherboard Asus H670 TUF
Cooling Arctic Freezer 34
Memory 2x16GB DDR4 3600 G.Skill Ripjaws V
Video Card(s) EVGA GTX 1060 SC
Storage 500GB Samsung 970 EVO, 500GB Samsung 850 EVO, 1TB Crucial MX300 and 2TB Crucial MX500
Display(s) Dell U3219Q + HP ZR24w
Case Raijintek Thetis
Audio Device(s) Audioquest Dragonfly Red :D
Power Supply Seasonic 620W M12
Mouse Logitech G502 Proteus Core
Keyboard G.Skill KM780R
Software Arch Linux + Win10
Hi,
Have you tried a different distro ?
Ubuntu/PopOs is as user friendly s they get. If the OP can't work with those, it's not wise to direct him to something else.
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Hi,
I just tried to install mint cinnamon 20.2 on my z490 rig with a titan Xp on it
It didn't go very well graphic's wise looked like vmem issues display was all messed up

I ended up putting the ssd in my x299 rig with 1080ti and it booted right to 20.2 and looked normal :eek:
So I installed the recommended nvidia driver and put it back into the z490 rig and all was well so go figure

I had 20.1 through 20.3 on z490 already installed with 1080ti, 20.3 was buggy and messed up obs studio and I just wanted to reinstall 20.2 and this crap happened.
So default nvidia driver is hit or miss is my point.

Op might try to install the popos in a different machine and reinstall the driver that way.
 
Joined
Feb 27, 2022
Messages
34 (0.10/day)
my mouse stopped working i can't right of left click in programs i can only open apps from the menu bar is it worth reinstalling the operating system?
 

bug

Joined
May 22, 2015
Messages
11,218 (3.99/day)
Processor Intel i5-12600k
Motherboard Asus H670 TUF
Cooling Arctic Freezer 34
Memory 2x16GB DDR4 3600 G.Skill Ripjaws V
Video Card(s) EVGA GTX 1060 SC
Storage 500GB Samsung 970 EVO, 500GB Samsung 850 EVO, 1TB Crucial MX300 and 2TB Crucial MX500
Display(s) Dell U3219Q + HP ZR24w
Case Raijintek Thetis
Audio Device(s) Audioquest Dragonfly Red :D
Power Supply Seasonic 620W M12
Mouse Logitech G502 Proteus Core
Keyboard G.Skill KM780R
Software Arch Linux + Win10
my mouse stopped working i can't right of left click in programs i can only open apps from the menu bar is it worth reinstalling the operating system?
Not if the mouse buttons are physically dead. Otherwise, yeah, clean everything up.
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Hi,
Might try a different download site.
 
Joined
Feb 27, 2022
Messages
34 (0.10/day)
before i reinstall should i go for the latest version or the lts version?
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Hi,
Latest usually is a better choice.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
12,896 (3.20/day)
Location
Concord, NH, USA
System Name Apollo
Processor Intel Core i9 9880H
Motherboard Some proprietary Apple thing.
Memory 64GB DDR4-2667
Video Card(s) AMD Radeon Pro 5600M, 8GB HBM2
Storage 1TB Apple NVMe, 4TB External
Display(s) Laptop @ 3072x1920 + 2x LG 5k Ultrafine TB3 displays
Case MacBook Pro (16", 2019)
Audio Device(s) AirPods Pro, Sennheiser HD 380s w/ FIIO Alpen 2, or Logitech 2.1 Speakers
Power Supply 96w Power Adapter
Mouse Logitech MX Master 3
Keyboard Logitech G915, GL Clicky
Software MacOS 12.1
Unless you're using a System76 machine, I would suggest just using Ubuntu. Installing nVidia drivers in Ubuntu should be braindead easy since you can do it through the OS. it should just be a matter of installing the restricted driver for nVidia GPUs within the OS. If you're having other issues as well, who knows what's happened in the interim. I would reinstall, start with Ubuntu, and go from there. I tend to use the latest LTS with the current HWE stack, but that's up to you.
 
  • Like
Reactions: bug

Mindweaver

Moderato®™
Staff member
Joined
Apr 16, 2009
Messages
8,062 (1.60/day)
Location
Charleston, SC
System Name Tower of Power / Sechs
Processor i7 12700K / i7 5820k @ 4.5ghz
Motherboard ASUS ROG Strix Z690-A Gaming WiFi D4 / X99S GAMING 7
Cooling CM MasterLiquid ML360 Mirror ARGB Close-Loop AIO / CORSAIR Hydro Series H100i Extreme
Memory CORSAIR Vengeance LPX 32GB (2 x 16GB) DDR4 3600 / G.Skill DDR4 2800 16GB 4x4GB
Video Card(s) ASUS TUF Gaming GeForce RTX 3070 V2 OC Edition / PNY Quadro K2000
Storage 3x Samsung 980 Pro 1TB M.2, 2x Crucial 1TB SSD / Samsung 870 PRO 500GB M.2
Display(s) Samsung 32" Odyssy G5 Gaming 144hz 1440p, ViewSonic 32" 72hz 1440p / 2x ViewSonic 32" 72hz 1440p
Case Phantek "400A" / Phanteks “Enthoo Pro series”
Audio Device(s) Realtek ALC4080 / Azalia Realtek ALC1150
Power Supply Corsair RM Series RM750 / Corsair CXM CX600M
Mouse Glorious Gaming Model D Wireless / Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma / Razer BlackWidow Ultimate
VR HMD Quest 2 + Rift S + HTC Vive + DK1
Software Windows 11 Pro x64 / Windows 10 Pro x64
Benchmark Scores Yes
Just curious are you using a monitor or tv?
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Damn weird.
 
Joined
Feb 27, 2022
Messages
34 (0.10/day)
reinstalled the resolution is still the same tried to install drivers via the pop shop got the same error then i tried to do other updates like one called gnome settings but i got this error "Error while installing package: installed nvidia-dkms-390 package post-installation script subprocess returned error exit status 10"
tried the nvidia one again got the same error "Error while installing package: installed nvidia-dkms-390 package post-installation script subprocess returned error exit status 10"

tried "sudo apt update && sudo apt dist-upgrade" and i got "
Errors were encountered while processing:
nvidia-dkms-390
nvidia-driver-390
E: Sub-process /usr/bin/dpkg returned an error code (1)

"
 
Joined
Feb 20, 2020
Messages
6,786 (6.29/day)
Location
Texas
System Name Ghetto Rigs x299 & z490 & x99
Processor 9940x w/Optimus Foundation & 10900k w/Black Noctua D15 & 5930k w/Reg-Noctua D15
Motherboard X299 Rampage VI Apex & z490 Maximus XII Apex & x99 Sabertooth
Cooling D5 combo/280 GTX/ VRM copper water block/280 GTX/ Optimus Foundation/ 1080ti FTW3
Memory Trident-Z 3600C16 4x8gb & Trident-Z Royal 4000c16 2x16gb & Trident-Z 3200c14 4x8gb
Video Card(s) 1080ti FTW3-On Loop & Titan Xp-w/ Only GPU loop & evga 980ti gaming-w/ air
Storage 970 evo plus 500gb & 970 evo 500gb many sammy 2.5" ssd's and WD BLK hdd's
Display(s) 1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
Case D450 second floor for 2nd rad x2/ Cherry Entertainment center on Test bench
Audio Device(s) Built in Realtek x2 with 2-Insignia 2.0 sound bars & 1-LG sound bar
Power Supply EVGA 1200P2 & 1000P2 with APC AX1500 & 850P2 with CyberPower-GX1325U & 750P2
Mouse Redragon Perdition x3
Keyboard G710+x3
Software Win-7 pro x3 and Linux Cinnamon 20.2x2 & win-10 & 11pro x3
Benchmark Scores Are in the benchmark section
Hi,
What happens with a windows install ?
 
Top