• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Making Audio Enhancers Work on Windows

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,886 (2.16/day)
Location
Rochester area
System Name RPC MK2
Processor Intel Core i5 9600K@ 4.8Ghz 1.32V
Motherboard Asrock z390 phantom gaming 4
Cooling Enermax ets-t50
Memory CMK16GX4M2B3000C15 16GB DDR4-3000
Video Card(s) EVGA GeForce RTX 2060 XC ULTRA GAMING
Storage 512GB Intel 545s ssd 500GB ADATA SU800 ssd 1TB WD blue
Display(s) Cheap VA panel
Case Phanteks P300
Audio Device(s) onboard
Power Supply HX 750i
Mouse M65 Pro RGB
Keyboard K70 RGB
Software Windows 10 +startisback
how about viper4windows+equalizer APO

thats what I use getting it working can be .... painful

usually requires multiple reinstalls to get them both to play nice

I been pondering writing a simple menu driven tool that lets user stack and load APO's without tedious registry editing or loading preset files
just a simple uncheck/check to enable and a tree hierarchy for stacking effects
 
Joined
Jan 30, 2018
Messages
407 (0.51/day)
Thank for your help.
The only KGA necessary for unlock Cinmea 5 is CTLPS4HTX2.kga
The old GenKGA don't work.
I have upload your complied GenKGA on Audio Enhancer download page.
I name the new GenKGA - "GenKGA3 v2"

how about viper4windows+equalizer APO

thats what I use getting it working can be .... painful

usually requires multiple reinstalls to get them both to play nice

I been pondering writing a simple menu driven tool that lets user stack and load APO's without tedious registry editing or loading preset files
just a simple uncheck/check to enable and a tree hierarchy for stacking effects
You can reference to apo analyzer from realtek
http://www.mediafire.com/file/53tqlzol62b5yb4

Another reference apo tool
http://www.mediafire.com/file/q0a2bs2il3sz6f5

ini config Viper4Windows + Equalizer APO (on the post attachment)

=====================================================

Sound Blaster Recon3Di + Sound Blaster ZxRi Control Panel
Remove Hardware Check on msi file, but still cannot detect hardware
http://www.mediafire.com/file/x741qhdz2338grc

Speech Platform Toolchain v4
http://www.mediafire.com/file/hwiciw5999wd1lo

AudioDeviceGraphDump
http://www.mediafire.com/file/jf0msxltzjy35h5

idk what is these tool can do, but Audio Device Graph Dump show currently active render APO pipelines in the Windows Audio Service and there is a tool
AudioToolbox.

圖片 1.png圖片 2.png圖片 4.png
 

Attachments

Last edited:
Joined
Feb 19, 2018
Messages
30 (0.04/day)
Thank for your help.
The only KGA necessary for unlock Cinmea 5 is CTLPS4HTX2.kga
The old GenKGA don't work.
I have upload your complied GenKGA on Audio Enhancer download page.
I name the new GenKGA - "GenKGA3 v2"



You can reference to apo analyzer from realtek
http://www.mediafire.com/file/53tqlzol62b5yb4

Another reference apo tool
http://www.mediafire.com/file/q0a2bs2il3sz6f5

ini config Viper4Windows + Equalizer APO (on the post attachment)

=====================================================

Sound Blaster Recon3Di + Sound Blaster ZxRi Control Panel
Remove Hardware Check on msi file, but still cannot detect hardware
http://www.mediafire.com/file/x741qhdz2338grc

Speech Platform Toolchain v4
http://www.mediafire.com/file/hwiciw5999wd1lo

AudioDeviceGraphDump
http://www.mediafire.com/file/jf0msxltzjy35h5

idk what is these tool can do, but Audio Device Graph Dump show currently active render APO pipelines in the Windows Audio Service and there is a tool
AudioToolbox.

View attachment 102998View attachment 102999View attachment 103000
t

It Unlocks sound blaster cinema 5 without any bugs!! but no effect....!! any solution??
 
Joined
Jan 3, 2018
Messages
135 (0.16/day)
Thank for your help.
The only KGA necessary for unlock Cinmea 5 is CTLPS4HTX2.kga
The old GenKGA don't work.
I have upload your complied GenKGA on Audio Enhancer download page.
I name the new GenKGA - "GenKGA3 v2"



You can reference to apo analyzer from realtek
http://www.mediafire.com/file/53tqlzol62b5yb4

Another reference apo tool
http://www.mediafire.com/file/q0a2bs2il3sz6f5

ini config Viper4Windows + Equalizer APO (on the post attachment)

=====================================================

Sound Blaster Recon3Di + Sound Blaster ZxRi Control Panel
Remove Hardware Check on msi file, but still cannot detect hardware
http://www.mediafire.com/file/x741qhdz2338grc

Speech Platform Toolchain v4
http://www.mediafire.com/file/hwiciw5999wd1lo

AudioDeviceGraphDump
http://www.mediafire.com/file/jf0msxltzjy35h5

idk what is these tool can do, but Audio Device Graph Dump show currently active render APO pipelines in the Windows Audio Service and there is a tool
AudioToolbox.

View attachment 102998View attachment 102999View attachment 103000
Where`s the link to Audio Enhancer download page ?, if uploaded the file, then share the link @alanfox2000 . :)
 
Joined
Jan 30, 2018
Messages
407 (0.51/day)
I`ve downloaded the next 3 Consoles of Creative (The monday i will test the 3); i`ve actualized all the packs w/ the latest versions od the software of creative that belongs to the X-Fi Go Pro console.

The Consoles are these:

mb_driver_audio_Recon3Di&ZxRi_1.03.24

Sound Blaster Acoustic Engine Pro v.1.02.06

Sound Blaster X-Fi Go Pro v.Win10.1.02.0082. This, i`ve downloaded from the official page of Creative, and in the page says is just for Windows 10; but i have my doubts (maybe works on other windows too). I`ve changed the "Support.cab" into the subfolder Setup, in Audio folder. I did this, because
the version of support.cab that owned the original for Windows 10; when looking inside with 7z; I have noticed that the file called "CTComp.dat" brings the following information added in the file.

[Hardware.Map10]
;; Pelican 2 THX
ID = 041E30DD
CompanyName = Creative
ProductName = Sound Blaster X-Fi Go! Pro
ProductVersion = 1.0
DefAppPath = \ Creative \ Sound Blaster X-Fi Go Pro
BillBoardType = 00
UninstallIcon = \ Bitmaps \ SBXFi.ico
FeatureSet = NIL
Readme = NIL
SpeakerPref =
DigitalOutput = NIL
CustomRDF = NIL
Manual = MANUAL_MAP_00
InstallQFE =
InstQFEB4Drvs =

[Hardware.Map11]
;; Pelican 2 SBX
ID = 041E3233
CompanyName = Creative
ProductName = Sound Blaster X-Fi Go! Pro
ProductVersion = 1.0
DefAppPath = \ Creative \ Sound Blaster X-Fi Go Pro
BillBoardType = 00
UninstallIcon = \ Bitmaps \ SBXFi.ico
FeatureSet = NIL
Readme = NIL
SpeakerPref =
DigitalOutput = NIL
CustomRDF = NIL
Manual = MANUAL_MAP_01
InstallQFE =
InstQFEB4Drvs =

[FeatureSet1]

[MANUAL_MAP_00]
manual1.chm = Sound Blaster X-Fi Go! Pro

[MANUAL_MAP_01]
manual2.chm = Sound Blaster X-Fi Go! Pro

[SPEAKERPREF_MAP_00]

[QFE_MAP_00]

[QFE_MAP_01]

---------------------------------------------------------------------------------------------------

Then, it happens that when starting the setup.exe (inside the subfolder "Setup", inside the Audio folder); the installer starts, but when you next give it "it does not recognize the X-Fi Go Pro card as connected and sends a message as it will not install the card software.

Plus, I own the original CD of this card, (in fact I had this portable / handheld USB card in my computer), and I did the following.

Change the "support.cab" that comes with my CD and change it to the one with the Windows 10 version of the X-Fi Go Pro; and now when you run the setup.exe it no longer sends the message (even if it does not detect the connected card in the computer) and it seems that if you are going to let the software install the Go Pro.

Here I leave the info that brings the "support.cab" in your file called "CTComp.dat", and that I replaced by the one that had the version for Windows 10; as you will see, the info changes and can be the key for you to choose the option to install the Go Pro.

[Hardware.Map10]
ID = 00000000
CompanyName = Creative
ProductName = Sound Blaster X-Fi Go! Pro
ProductVersion = 1.0
DefAppPath = \ Creative \ Sound Blaster X-Fi Go Pro
BillBoardType = 00
UninstallIcon = \ Bitmaps \ SBXFi.ico
FeatureSet = NIL
Readme = NIL
SpeakerPref =
DigitalOutput = NIL
CustomRDF = NIL
Manual = MANUAL_MAP_00
InstallQFE =
InstQFEB4Drvs =

[FeatureSet1]

[MANUAL_MAP_00]
manual.chm = Sound Blaster X-Fi Go! Pro

[SPEAKERPREF_MAP_00]

[QFE_MAP_00]

[QFE_MAP_01]

Apart from this, this installer gives the option to choose what you want to install from the X-Fi or Pro software; It is not like others that only have the option "Full installation".

SetupTypes = FULL, CUSTOM, DRIVERS_ONLY
MaintTypes = ADD, REMOVE, REPAIR, REMOVE_ALL

This is a point in favor, because we can choose what to install at the time.

Now, I'm going to upload this version to my mediafire, and I want you to take a look at it; If you think you can remove something that you will not need, or any improvement that you see fit and is favorable to enhance the software of this card ........ You will always be welcome, and apart you will benefit us. What do you think @alanfox2000 ?.

Note: This console is a latest version of the console included in the Gamespirit MODS, just change the name of the folder (EntCon), and the name of the main executable; called "EntC.exe; the version is this:

SoftwareSubPath = Entertainment Console
SoftwareID = ENTERTAINMENT_CONSOLE
SoftwareVersion = 3.01.02
SoftwareFriendlyName = Creative Entertainment Console

And the used in the Gamespirit Mods was 2.56, if I remember correctly.

I wait your answer.

Here`s the link to the X-Fi Go Pro in my Mediafire:

http://www.mediafire.com/file/glvhc0v0q9jszl3/Sound_Blaster_X-Fi_Go_Pro_v.Win10.1.02.0082.7z/file
ENTERTAINMENT_CONSOLE do not want me to get installed.
It give EntCon\setup.inx error during install

Where`s the link to Audio Enhancer download page ?, if uploaded the file, then share the link @alanfox2000 . :)
puresoftapps Audio/Sound Enhancers page, Sound Blaster Connect UWP app -> Installation

Many Sound Blaster Control Panel....

x7f.png Acoustic-Engine-Screen-Shot.png
wHmM2LJ.pngsoftware-2.jpg
controlpanel.png 23.jpg
 
Joined
May 12, 2015
Messages
76 (0.04/day)
Location
N/A
I am working on a Tutorial video for installing/getting different APOs to work, but I think the latest APO Driver 2.0.6 broke compatibility with older Creative Suites, like Creative X-Fi MB5.

@alanfox2000 any thoughts on this?
 
Last edited:
Joined
May 12, 2015
Messages
76 (0.04/day)
Location
N/A
You need to select generic driver, do not select uwp driver
That is what I have done. With the APO Driver 2.0.1 Creative X-Fi MB5, Cinema 3 worked. With the latest APO Driver 2.0.6, it doesn't. Please, check for yourself.
 
Joined
Jan 3, 2018
Messages
135 (0.16/day)
Great job, does sbc5 require only single kga file ?
Yep!, the only KGA necessary for unlock Cinmea 5 is CTLPS4HTX2.kga. Install the new "GenKGA3 v2", and then leave alone this kga (erase the rest of .kga files in the folder) in the SoftwareLock folder. Then execute the SBC5 to test if works @OMER . Enjoy!.
 
Joined
May 22, 2018
Messages
375 (0.55/day)
Yep!, the only KGA necessary for unlock Cinmea 5 is CTLPS4HTX2.kga. Install the new "GenKGA3 v2", and then leave alone this kga (erase the rest of .kga files in the folder) in the SoftwareLock folder. Then execute the SBC5 to test if works @OMER . Enjoy!.
Sound Blaster Cinema 5, Works Perfectly Fine, look at attached image

Ton of appreciation for prettyclaire82, yo did an amazing job

SBC5 Unlocked, I still can't believe it

Sound Blaster Cinema 5.PNG
 
Last edited:
Joined
May 22, 2018
Messages
375 (0.55/day)
It should appear below Speakers as a Voice tab in the UWP
I think Voice tab is disabled in my SBC5, look at image nothing below speakers tab, tell me what exactly u did to activate voice tab

SBC 5.PNG


You need to select generic driver, do not select uwp driver
Can anyone tell how to change background image of Sound Blaster Cinema 5

I know how to change in SBX 720 Desktop & UWP, But not sbc5
 
Last edited:
Joined
Jan 30, 2018
Messages
407 (0.51/day)
Orignal Realtek UAD Driver with Creative UWP app support
https://www12.zippyshare.com/v/vhydYmfq/file.html

It seem to fail to detect hardware after I modify the inf install.
May be UAD Driver install mbfilt64.sys case detect fail?!


According to this post:
https://www.vogons.org/viewtopic.php?f=9&t=39499&start=280#p611968
you need to force install INF file containing MBfilt64.sys driver from Realtek drivers, then install XFi MB3 software, and then if not work out of the box you need to use GenKGA to generate kga files. GenKGA source code
New GenKGA not complied under MBfilt64.sys installed (APO Driver don't include MBfilt64.sys).

So GenKGA fail to unlock Sound Blaster X720/X360/Cinema 5 if MBfilt64.sys is installed.


pic.png
 
Last edited:
Joined
May 22, 2018
Messages
375 (0.55/day)
It's easy, unlike other complex installation of audio enhancers

I'am Sharing My Sound Blaster Cinema 5 Installation on Mediafire

Follow proper instructions

If still sbc5 does not activates, I recommended do a fresh installation of windows 10, as I did

Install through APO Driver v2.0.6

http://www.mediafire.com/file/k6tbsj3kag4yw3j/Sound_Blaster_Cinema_5_%28Windows_10_or_Higher%29.zip/file

Orignal Realtek UAD Driver with Creative UWP app support

It is for MSI with it's only supported Hardware ID'S, I tried many UAD Creative drivers from Realtek FTP Server, it never helped me

Adding our pc's Hardware ID in HDXMSI.inf, doesn't work at all, I tried it before many times with different methods
 
Last edited:
Joined
Jan 30, 2018
Messages
407 (0.51/day)
To Test if the Voice Panel Show using official Creative inf Extension :

This is the official Creative inf Extension for Creative UWP app which include mbfilt64.sys
https://www36.zippyshare.com/v/KWfCdA7E/file.html
To install
1. Disable Driver Signature Enforcement
2. Add your hardware id on CreativeExtension.inf
3. Use DriverStoreExplorer to install CreativeExtension.inf (similar to install Realtek UAD Driver)

This is the screenshot with mbfilt64.sys installed, I don't have microphone, try plug in microphone if the voice panel show
pic3.png
 
Top