• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Making Audio Enhancers Work on Windows

bertie123

New Member
Joined
May 15, 2019
Messages
1 (0.00/day)
To Fix the EXE & MSI Signature Mismatch you can just go to C:\Users\(your username)\AppData\Roaming\PureSoftApps\APO Driver 2.4.8\install\40843AC and run the .msi directly there but after that i am unable to reinstall the FX Configurator after because i get the same error

nvm went back to 2.4.7 and that worked
 
Last edited:
Joined
Apr 14, 2018
Messages
116 (0.10/day)
Location
Almada
System Name Diogo Silva
Processor Intel Core i5 9600KF Processor (6core @4.80Ghz)
Motherboard TUF B360-Pro Gaming
Cooling Cooler Master Hyper TX3i
Memory 2x8 Kingston HyperX KHX2400C12D4
Video Card(s) Asus TUF RTX2060 Gaming 6G
Storage WD WDS500G2B0B Blue 3D SATA M.2 500GB + Toshiba HDD 2Tb
Display(s) Samsung Curved Monitor 27 Pol.
Case Cooler Master N300
Audio Device(s) Realtek ALC887 with Sound BlasterX 720 and Dolby Atmos OUTPUTTING to Yamaha RV-X 361
Power Supply Seasonic Core GC 500W 80PLUS Gold
Mouse Asus ROG Pugio II Wireless Gaming Mouse
Keyboard Asus Cerberus
Software Windows 10 Home Single Language (PT-PT) x64
Hello @alanfox2000, when a next version of HDA Audio comes out?
Version 6.0.87XX?
 
Joined
Jun 20, 2017
Messages
614 (0.41/day)
New APO Driver update 16/05/2019
APO Driver 2.4.9

- Fix EXE and MSI file signature mismatch
 
Joined
Apr 30, 2017
Messages
213 (0.14/day)
@CityCultivator
I will test in the next week normally an APO Driver (I had to that time unsucsessful) and I may ask you that can I pairing Dolby DS1 and DTS Connect and whom? :)
I wait for your reply.
Thank you. :)
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
@CityCultivator
I will test in the next week normally an APO Driver (I had to that time unsucsessful) and I may ask you that can I pairing Dolby DS1 and DTS Connect and whom? :)
I wait for your reply.
Thank you. :)
You want DS1 with DTS connect, exact?
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Yes, I want both.

P.S: I have an Asus mobo with ALC892, Windows 10 RS4
Code:
[LFX]
{01BBFA6B-B2EC-4D2A-9F48-665CC5D091BA}
[GFX]
{A515262A-68B3-441a-A310-0D145362EE87}
[ProcessingLFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
[ProcessingGFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
Insert in notepad, save the file with .ini extension and load in fxconfigurator.
Report if it works.
Or just load DTS connect ini file and replace Local FX APO with {01BBFA6B-B2EC-4D2A-9F48-665CC5D091BA}
 
Joined
Apr 30, 2017
Messages
213 (0.14/day)
Code:
[LFX]
{01BBFA6B-B2EC-4D2A-9F48-665CC5D091BA}
[GFX]
{A515262A-68B3-441a-A310-0D145362EE87}
[ProcessingLFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
[ProcessingGFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
Insert in notepad, save the file with .ini extension and load in fxconfigurator.
Report if it works.
Or just load DTS connect ini file and replace Local FX APO with {01BBFA6B-B2EC-4D2A-9F48-665CC5D091BA}
Only DTS Interactive was present, none of DS1.
 

Attachments

  • DTS.jpg
    DTS.jpg
    61.9 KB · Views: 444
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)

hahagu

New Member
Joined
Apr 15, 2019
Messages
11 (0.01/day)
Has anyone gotten sound radar working using the Dolby Atmos for Gaming UWP app with Dolby Atmos Speaker System for Gaming xml 3.3.0 preset?
I can't get mine to work, or show up in any of my game screens.

Also, I figured out how to make the built-in subwoofer to work.
First, you have to apply 'Realtek System Effects - UAD' from the product config tool and save that using the 'Save Current Config' button.
After doing that, using the product config tool again, choose the enhancer of your choice and do the same.
Now, open both .ini files that you saved and combine them.

For example, if you have
Code:
[CompositeSFX]
{DA2C9ECE-7418-4906-B4FA-0A00B3EB88AA}
{1B917FE2-47D1-425D-A26E-AFCDBDA7A2E8}
{670173E1-78CF-11E5-A837-0800200C9A66}
[CompositeEFX]
{A29EB043-6CE2-4ee2-B38C-F58719E0D88F}
{D9916F9C-99F7-11E7-BF21-6C0B849889E1}
and
Code:
[CompositeSFX]
{D9916F9F-99F7-11E7-BF21-6C0B849889E1}
[CompositeEFX]
{93520346-FA48-4F56-8CB0-D92CC1775E37}
combine them so they look like
Code:
[CompositeSFX]
{DA2C9ECE-7418-4906-B4FA-0A00B3EB88AA}
{1B917FE2-47D1-425D-A26E-AFCDBDA7A2E8}
{670173E1-78CF-11E5-A837-0800200C9A66}
{D9916F9F-99F7-11E7-BF21-6C0B849889E1}
[CompositeEFX]
{A29EB043-6CE2-4ee2-B38C-F58719E0D88F}
{D9916F9C-99F7-11E7-BF21-6C0B849889E1}
{93520346-FA48-4F56-8CB0-D92CC1775E37}

Import that combined .ini file by pressing the 'Load External Config' button and choosing the .ini file.
Finally, apply the settings by pressing the 'Apply Effect and Processing Modes Configurations' button.

Doing this will combine Realtek System Effects with the enhancer of your choice, which will enable the integrated subwoofer.
(Also, this method will work for combining multiple enhancers too!)
 
Last edited:
Joined
Jan 30, 2018
Messages
420 (0.33/day)
Windows 10, version 1903 and Windows Server, version 1903 known issue
Audio not working with Dolby Atmos headphones and home theater
After updating to Windows 10, version 1903, you may experience loss of audio with Dolby Atmos for home theater (free extension) or Dolby Atmos for headphones (paid extension) acquired through the Microsoft Store due to a licensing configuration error.

This occurs due to an issue with a Microsoft Store licensing component, where license holders are not able to connect to the Dolby Access app and enable Dolby Atmos extensions.

To safeguard your update experience, we have applied protective hold on devices from being offered Windows 10, version 1903 until this issue is resolved. This configuration error will not result in loss of access for the acquired license once the problem is resolved.

Affected platforms:
  • Client: Windows 10, version 1903
Next steps: We are working on a resolution for Microsoft Store and estimate a solution will be available in mid-June.
Note We recommend you do not attempt to manually update using the Update now button or the Media Creation Tool until this issue has been resolved.

Source: https://docs.microsoft.com/en-us/windows/release-information/status-windows-10-1903
 
Last edited:

amenbreak

New Member
Joined
Feb 27, 2019
Messages
3 (0.00/day)
Dolby service is not starting for me. Tried reinstalling APO Driver, Realtek drivers. Anyone with same problem?
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Dolby service is not starting for me. Tried reinstalling APO Driver, Realtek drivers. Anyone with same problem?
Uninstall APO driver again and then delete these folders:
C:\Windows\System32\dolbyaposvc
C:\Program Files\Common Files\Dolby\DAX3
Then reinstall again. It might then work. If not, you might need to reset Windows.
 

hahagu

New Member
Joined
Apr 15, 2019
Messages
11 (0.01/day)
Uninstall APO driver again and then delete these folders:
C:\Windows\System32\dolbyaposvc
C:\Program Files\Common Files\Dolby\DAX3
Then reinstall again. It might then work. If not, you might need to reset Windows.

Or use a restore point

Just sayin'
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)

amenbreak

New Member
Joined
Feb 27, 2019
Messages
3 (0.00/day)
Uninstall APO driver again and then delete these folders:
C:\Windows\System32\dolbyaposvc
C:\Program Files\Common Files\Dolby\DAX3
Then reinstall again. It might then work. If not, you might need to reset Windows.

Deleting the second folder helped, thanks.
 

Devilwrath

New Member
Joined
Mar 19, 2018
Messages
7 (0.01/day)
Hi, I tried installing APO driver + Atmos Speaker System (without Radar) i`m getting error on installing DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx:

App installation failed with error message: Deployment Add operation with target volume C: on Package DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220 from: (DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx) failed with error 0x80040154. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. (0x80040154)

Help.
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Hi, I tried installing APO driver + Atmos Speaker System (without Radar) i`m getting error on installing DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx:

App installation failed with error message: Deployment Add operation with target volume C: on Package DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220 from: (DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx) failed with error 0x80040154. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. (0x80040154)

Help.
Windows version?
 

Devilwrath

New Member
Joined
Mar 19, 2018
Messages
7 (0.01/day)
Hi, I tried installing APO driver + Atmos Speaker System (without Radar) i`m getting error on installing DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx:

App installation failed with error message: Deployment Add operation with target volume C: on Package DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220 from: (DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx) failed with error 0x80040154. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. (0x80040154)

Help.

Windows version?
Windows 10 1809 17763.288
I deinstalled everything related to audio (I used DJ Urko mod before).
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Hi, I tried installing APO driver + Atmos Speaker System (without Radar) i`m getting error on installing DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx:

App installation failed with error message: Deployment Add operation with target volume C: on Package DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220 from: (DolbyLaboratories.DolbyAtmosSpeakerSystem_3.20402.409.0_x64__rz1tebttyb220.Appx) failed with error 0x80040154. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. (0x80040154)

Help.


Windows 10 1809 17763.288
I deinstalled everything related to audio (I used DJ Urko mod before).
Check whether you had enabled sideloading in update & security --> For developers.
Redownload the appx file and try again.
 

Devilwrath

New Member
Joined
Mar 19, 2018
Messages
7 (0.01/day)
I enabled sideload (I had developer mode on before), redownloaded APO 2.5.0 and DolbyLaboratories.DolbyAtmosforGaming_3.20402.409.0_x64__rz1tebttyb220 this time, after installing APO, still get same error when I try to install Dolby atmos for gaming.
 
Joined
Aug 24, 2018
Messages
761 (0.71/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
I enabled sideload (I had developer mode on before), redownloaded APO 2.5.0 and DolbyLaboratories.DolbyAtmosforGaming_3.20402.409.0_x64__rz1tebttyb220 this time, after installing APO, still get same error when I try to install Dolby atmos for gaming.
Developer mode is better.
You have a weird issue. I think that you need to refresh Windows.
 
Top