• We've upgraded our forums. Please post any issues/requests in this thread.

MSI GX630 Laptop screen problems!

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#1
Basically i was on my Laptop yesterday and the battery ran out, now i tried turning it back on whilst using the AC Adapter when it finishes loading the MSI screen it moves onto the windows log in screen this i know. The thing is after the MSI Logo the screen just stays black. The Lights are on and the screen is lit but it just doesn't show the log on screen.

Any help please.

P.S. I tried to do a System Restore but before the application gets to load i get Blue screened and told to press F8 for Safe Mode. I tried this too and Safe Mode doesn't load it stays on a file loading please wait for ages.
 
Last edited:
Joined
Dec 5, 2007
Messages
5,050 (1.38/day)
Likes
1,784
System Name Addison Clark
Processor I7 7700k @ 5GHZ 1.35v
Motherboard Asus Z270 ITX
Cooling Corsair H100
Memory Corsair 16GB DDR4-3600
Video Card(s) Zotac 1080 TI F.E.
Storage Plextor M8Pe 1TB M.2
Display(s) Asus 28" 4K
Case Corsair 380T
Audio Device(s) Creative Omni USB
Power Supply EVGA G3 Supernova 1KW
Mouse G.Skill 780
Keyboard MS Sidewinder x4
Software Win 10 Pro
#2
I would recommend grabbing UBCD and running a test on your hardware. By chance does it sit @ CRCDisk when trying safe mode?
 

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#3
I would recommend grabbing UBCD and running a test on your hardware. By chance does it sit @ CRCDisk when trying safe mode?
Yes that's exactly what it does.:toast:
 
Joined
Dec 5, 2007
Messages
5,050 (1.38/day)
Likes
1,784
System Name Addison Clark
Processor I7 7700k @ 5GHZ 1.35v
Motherboard Asus Z270 ITX
Cooling Corsair H100
Memory Corsair 16GB DDR4-3600
Video Card(s) Zotac 1080 TI F.E.
Storage Plextor M8Pe 1TB M.2
Display(s) Asus 28" 4K
Case Corsair 380T
Audio Device(s) Creative Omni USB
Power Supply EVGA G3 Supernova 1KW
Mouse G.Skill 780
Keyboard MS Sidewinder x4
Software Win 10 Pro
#4
It could possible be just the AHCI/RAID driver causing the issue but unfortunately most of the time it is caused by a bad hard drive. I would grab that UBCD I posted earlier and test your hard drive and memory. It will point you in the right direction.
 

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#5
It could possible be just the AHCI/RAID driver causing the issue but unfortunately most of the time it is caused by a bad hard drive. I would grab that UBCD I posted earlier and test your hard drive and memory. It will point you in the right direction.
OK thank you i willl try the UBCD ISO once i figure out how to use it lol. As for it possibly being the AHCI/RAID driver how would i go about fixing that?
 
Joined
Dec 5, 2007
Messages
5,050 (1.38/day)
Likes
1,784
System Name Addison Clark
Processor I7 7700k @ 5GHZ 1.35v
Motherboard Asus Z270 ITX
Cooling Corsair H100
Memory Corsair 16GB DDR4-3600
Video Card(s) Zotac 1080 TI F.E.
Storage Plextor M8Pe 1TB M.2
Display(s) Asus 28" 4K
Case Corsair 380T
Audio Device(s) Creative Omni USB
Power Supply EVGA G3 Supernova 1KW
Mouse G.Skill 780
Keyboard MS Sidewinder x4
Software Win 10 Pro
#6
Besides running the Recovery Partition(System recovery back to factory settings) you can try installing from a Windows CD but you might be prompted for the AHCI/RAID driver which you should have no problems picking up on MSI's site.
 

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#7
OK a bit late i know lol but i have the UBCD and need to know how to test my HDD.
 

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#8
Revival because i need to know how to use UBCD. What do i use on the list of features to fix my laptop?

Also Vista is pre-installed with the code sticker on the bottom of the laptop and if i take it to a repair shop will they see all my porn?

I used the recovery ISO also and it didn't even work half the time and when it did it just said there were no error found?

Still can't use Safe mode due to it hanging on crcdisk.
 
Last edited:

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#9
I'd also like to add that all of this happened after i was playing M.U.G.E.N and my laptop battery ran out so i plugged the adapter in and i couldn't load up the login screen. I just get crcdisk hang on safe mode or a blue screen unmountable boot volume stop 0x000000ed vista error when trying to use system repair in the bios.
 

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#10
I used the recovery console to do a dskchk and it finds no problems. Also there are no restore points or back ups of vista apparantly. The start up repair doesn't come up with anything either.

Is my Laptop completely broke?

It might be the MSI sleep mode problem and i am currently conducting an EC reset.
 
Last edited:

hooj

New Member
Joined
Jan 4, 2008
Messages
398 (0.11/day)
Likes
18
Location
Londinius
System Name First and last Custom build cus it was just too tedious.
Processor i5 2500k
Motherboard ASUS P8Z68-V LX
Cooling Stock
Memory G.Skill RipJaw X 2x 2GB
Video Card(s) Inno3D 9600GT 512MB
Storage Seagate Momentus XT 320GB
Display(s) 17" Proview LCD/ 19.5" Viewsonic Optiquest/ 19" LG Flatron LCD TV with the Red bit on it
Case NZXT Source 220
Audio Device(s) None
Power Supply Corsair TX750 V2
Software Windows XP Professional
Benchmark Scores N/A
#11
OH MY WORD I FIXED IT YES!

Turns out all i had to do was change from AHCI back to IDE!

Haha!!