• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

MSI RX 6600 causing pc to restart after shut down

Joined
Aug 19, 2021
Messages
6 (0.02/day)
Processor i5 11600k
Motherboard Gigabyte Z590 ud ac
Cooling Arctic Freezer Esports Duo
Memory Crucial Ballistix 16 GB 3200Mhz
Video Card(s) Sapphire Nitro+ RX 6600 XT 8GB
Storage Samsung 980 M.2 NVMe + Kingston KC600 SSD + Samsung 850 EVO SSD + 2TB HDD
Display(s) Alienware AW2521HFLA 240hz IPS
Case Coolermaster Storm Trooper
Audio Device(s) Edifier R1280T 2.0 + Asus Strix Wireless 7.1
Power Supply Seasonic Focus GX 650W
Mouse Steelseries Rival 310
Keyboard Logitech G610
Software Win 10 Pro
Hello everyone.
So today I upgraded gpu from gigabyte gtx 1060 to msi rx 6600 mech x2 8gb. The problem is when I want to shut down pc it immediately turns back on after 3-4 secs. If I put back old gpu it works normally. I came across internet to similar topics from people owning same gpu (msi mech x2, xt or non xt) and same mobo manufacturer, gigabyte. So far nobody found a solution, at least didnt post it in threads. It's pretty weird, seems like some incompatibility between that specific gpu and gigabyte motherboards.
So far I have updated bios to newest version and cleared cmos. Also freshly installed newest drivers after that. I used DDU in safe mode to clear system from nvidia drivers. Also did some tweaks in windows like turning off fast startup and changing some registry values, nothing did the thing.
I'm about to ask seller for gpu replacement for other brand but before that if anyone has any input on this it's very appreciated.
specs:
11600k
gigabyte Z590 ud ac
16gb ddr4
msi rx 6600 mech x2 8gb
psu seasonic 650w focus gx
ssd samsung 980 nvme 500gb
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
What is the condition the gpu is in when you bought it?

Whats your ram?

And Yes Gigabyte and MSI are laughable in quality today.

Try the card in a totally different system and get back to us, if it works there then it's a problem with your motherboard and that particular gpu.

Hello everyone.
So today I upgraded gpu from gigabyte gtx 1060 to msi rx 6600 mech x2 8gb. The problem is when I want to shut down pc it immediately turns back on after 3-4 secs. If I put back old gpu it works normally. I came across internet to similar topics from people owning same gpu (msi mech x2, xt or non xt) and same mobo manufacturer, gigabyte. So far nobody found a solution, at least didnt post it in threads. It's pretty weird, seems like some incompatibility between that specific gpu and gigabyte motherboards.
So far I have updated bios to newest version and cleared cmos. Also freshly installed newest drivers after that. I used DDU in safe mode to clear system from nvidia drivers. Also did some tweaks in windows like turning off fast startup and changing some registry values, nothing did the thing.
I'm about to ask seller for gpu replacement for other brand but before that if anyone has any input on this it's very appreciated.
specs:
11600k
gigabyte Z590 ud ac
16gb ddr4
msi rx 6600 mech x2 8gb
psu seasonic 650w focus gx
ssd samsung 980 nvme 500gb
 
Joined
Aug 19, 2021
Messages
6 (0.02/day)
Processor i5 11600k
Motherboard Gigabyte Z590 ud ac
Cooling Arctic Freezer Esports Duo
Memory Crucial Ballistix 16 GB 3200Mhz
Video Card(s) Sapphire Nitro+ RX 6600 XT 8GB
Storage Samsung 980 M.2 NVMe + Kingston KC600 SSD + Samsung 850 EVO SSD + 2TB HDD
Display(s) Alienware AW2521HFLA 240hz IPS
Case Coolermaster Storm Trooper
Audio Device(s) Edifier R1280T 2.0 + Asus Strix Wireless 7.1
Power Supply Seasonic Focus GX 650W
Mouse Steelseries Rival 310
Keyboard Logitech G610
Software Win 10 Pro
What is the condition the gpu is in when you bought it?

Whats your ram?

And Yes Gigabyte and MSI are laughable in quality today.

Try the card in a totally different system and get back to us, if it works there then it's a problem with your motherboard and that particular gpu.

Thanks for reply.
It was brand new gpu. RAM is Crucial Ballistics 2x8gb, working at 3000mhz although the factory clock is 3600mhz.
Ok so i'll look up to try it in different pc. Anyway I would rather rma gpu if its possible or sell it than keep it and change motherboard, so to avoid the whole process of reassembling everything.
 

mrvizierr

New Member
Joined
May 18, 2022
Messages
2 (0.02/day)
Hello everyone.
So today I upgraded gpu from gigabyte gtx 1060 to msi rx 6600 mech x2 8gb. The problem is when I want to shut down pc it immediately turns back on after 3-4 secs. If I put back old gpu it works normally. I came across internet to similar topics from people owning same gpu (msi mech x2, xt or non xt) and same mobo manufacturer, gigabyte. So far nobody found a solution, at least didnt post it in threads. It's pretty weird, seems like some incompatibility between that specific gpu and gigabyte motherboards.
So far I have updated bios to newest version and cleared cmos. Also freshly installed newest drivers after that. I used DDU in safe mode to clear system from nvidia drivers. Also did some tweaks in windows like turning off fast startup and changing some registry values, nothing did the thing.
I'm about to ask seller for gpu replacement for other brand but before that if anyone has any input on this it's very appreciated.
specs:
11600k
gigabyte Z590 ud ac
16gb ddr4
msi rx 6600 mech x2 8gb
psu seasonic 650w focus gx
ssd samsung 980 nvme 500gb
This is starting to get ridiculous. I have the same gigabyte z590 ud ac motherboard, 11600k and MSI rx6600 Mech 8gb graphics card. I also did some of what you said (except Bios update and CMOS cleaning) I couldn't get a solution either. I can't send it back because I ordered from abroad. I wrote to Gigabyte esupport 3 days ago and I haven't received a reply yet. I'm waiting. I suggest you write too. The problem is in the motherboard. Those who changed the motherboard can shut down the computer without any problems.
 
Joined
Dec 11, 2019
Messages
286 (0.29/day)
Processor Xeon E-2124
Motherboard Fujitsu D3644-B1
Cooling Akasa AK-959CU
Memory 32GB Kingston DDR4 (4x KSM26ES8/8ME)
Video Card(s) Sapphire Pulse 550 2G 64-bit
Storage Samsung 870 Evo, Samsung 980
Display(s) Fujitsu B22-8 TS Pro
Case Akasa Raptor
Power Supply Antec HCG-620
Mouse Logitech MX500
This is starting to get ridiculous. I have the same gigabyte z590 ud ac motherboard, 11600k and MSI rx6600 Mech 8gb graphics card. I also did some of what you said (except Bios update and CMOS cleaning) I couldn't get a solution either. I can't send it back because I ordered from abroad. I wrote to Gigabyte esupport 3 days ago and I haven't received a reply yet. I'm waiting. I suggest you write too. The problem is in the motherboard. Those who changed the motherboard can shut down the computer without any problems.

Apologies if I'm repeating things people have already tried in those threads, but have you tried turning off everything in the bios that is capable of starting a pc back up, regardless if it seems related? (wake-on)

If there's an option for what to do when power is lost: set to always off.

Also make sure Windows is actually programmed to turn off and not sleep when shut down.
 
Joined
Jun 2, 2017
Messages
4,427 (2.33/day)
System Name Best AMD Computer
Processor AMD 5950X
Motherboard MSI X570S ACE Max
Cooling In Win SR36
Memory ADATA D60 3600MHZ 32 GB
Video Card(s) MSI 6800XT Gaming Trio X
Storage Seagate 530 2Tb, Adata SX8200 2TBx2, Kingston 2 TBx2, Micron 8 TB
Display(s) GIGABYTE 32QC
Case PHANTEKS ENTHOO PRO 2
Audio Device(s) Corsair Void Pro, Logitch Z523 5.1
Power Supply Corsair HX1200!
Mouse Logitech g7 gaming mouse
Keyboard Logitech G510
Software Windows 10 Pro 64 Steam. GOG, Uplay, Origin
Benchmark Scores Firestrike: 24955 Time Spy: 13500
Hello everyone.
So today I upgraded gpu from gigabyte gtx 1060 to msi rx 6600 mech x2 8gb. The problem is when I want to shut down pc it immediately turns back on after 3-4 secs. If I put back old gpu it works normally. I came across internet to similar topics from people owning same gpu (msi mech x2, xt or non xt) and same mobo manufacturer, gigabyte. So far nobody found a solution, at least didnt post it in threads. It's pretty weird, seems like some incompatibility between that specific gpu and gigabyte motherboards.
So far I have updated bios to newest version and cleared cmos. Also freshly installed newest drivers after that. I used DDU in safe mode to clear system from nvidia drivers. Also did some tweaks in windows like turning off fast startup and changing some registry values, nothing did the thing.
I'm about to ask seller for gpu replacement for other brand but before that if anyone has any input on this it's very appreciated.
specs:
11600k
gigabyte Z590 ud ac
16gb ddr4
msi rx 6600 mech x2 8gb
psu seasonic 650w focus gx
ssd samsung 980 nvme 500gb
My pick is the board. I have found that Gigabyte boards can exhibit absolutely weird Gremlins after changing hardware. Try taking out the battery and then re-inserting it. See if that fixes the issue.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Thanks for reply.
It was brand new gpu. RAM is Crucial Ballistics 2x8gb, working at 3000mhz although the factory clock is 3600mhz.
Ok so i'll look up to try it in different pc. Anyway I would rather rma gpu if its possible or sell it than keep it and change motherboard, so to avoid the whole process of reassembling everything.

Put card in another system if problem stops then your motherboard is sketchy, and Id suggest returning the mobo and get another. (not Gigabyte)
 
Joined
Jun 2, 2017
Messages
4,427 (2.33/day)
System Name Best AMD Computer
Processor AMD 5950X
Motherboard MSI X570S ACE Max
Cooling In Win SR36
Memory ADATA D60 3600MHZ 32 GB
Video Card(s) MSI 6800XT Gaming Trio X
Storage Seagate 530 2Tb, Adata SX8200 2TBx2, Kingston 2 TBx2, Micron 8 TB
Display(s) GIGABYTE 32QC
Case PHANTEKS ENTHOO PRO 2
Audio Device(s) Corsair Void Pro, Logitch Z523 5.1
Power Supply Corsair HX1200!
Mouse Logitech g7 gaming mouse
Keyboard Logitech G510
Software Windows 10 Pro 64 Steam. GOG, Uplay, Origin
Benchmark Scores Firestrike: 24955 Time Spy: 13500
Put card in another system if problem stops then your motherboard is sketchy, and Id suggest returning the mobo and get another. (not Gigabyte)
Even MSI boards are flaky these days.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64

mrvizierr

New Member
Joined
May 18, 2022
Messages
2 (0.02/day)
Apologies if I'm repeating things people have already tried in those threads, but have you tried turning off everything in the bios that is capable of starting a pc back up, regardless if it seems related? (wake-on)

If there's an option for what to do when power is lost: set to always off.

Also make sure Windows is actually programmed to turn off and not sleep when shut down.
Thank you for answer. Honestly, I didn't make any changes because nobody on the net told to change the bios. I once broke a motherboard because of bios changes. That's why I didn't change anything. I looked in the bios I think it had something to do with the power settings. I'll look after work.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Thank you for answer. Honestly, I didn't make any changes because nobody on the net told to change the bios. I once broke a motherboard because of bios changes. That's why I didn't change anything. I looked in the bios I think it had something to do with the power settings. I'll look after work.
Ok and?
 
Joined
Aug 19, 2021
Messages
6 (0.02/day)
Processor i5 11600k
Motherboard Gigabyte Z590 ud ac
Cooling Arctic Freezer Esports Duo
Memory Crucial Ballistix 16 GB 3200Mhz
Video Card(s) Sapphire Nitro+ RX 6600 XT 8GB
Storage Samsung 980 M.2 NVMe + Kingston KC600 SSD + Samsung 850 EVO SSD + 2TB HDD
Display(s) Alienware AW2521HFLA 240hz IPS
Case Coolermaster Storm Trooper
Audio Device(s) Edifier R1280T 2.0 + Asus Strix Wireless 7.1
Power Supply Seasonic Focus GX 650W
Mouse Steelseries Rival 310
Keyboard Logitech G610
Software Win 10 Pro
I noticed in this gpu specs that it has 4.0 x8 interface. However, mbo is 4.0 x16. I know it should work normally so only 8 lanes will be used, but it crossed my mind if this could be the cause in any way?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Mar 20, 2022
Messages
167 (1.14/day)
Processor Ryzen 5 5600X
Motherboard Asus B550-F Gaming WiFi
Cooling Be Quiet! Dark Rock Pro 4
Memory 64GB G.Skill Ripjaws V 3600 CL18
Video Card(s) Gigabyte RX 6600 Eagle (de-shrouded)
Storage Samsung 970 Evo 1TB M.2
Display(s) 2 x Asus 1080p 60Hz IPS
Case Antec P101 Silent
Audio Device(s) Ifi Zen DAC V2
Power Supply Be Quiet! Straight Power 11 650W Platinum
Mouse JSCO JNL-101k
Keyboard Akko 3108 V2 (Akko Pink linears)
I noticed in this gpu specs that it has 4.0 x8 interface. However, mbo is 4.0 x16. I know it should work normally so only 8 lanes will be used, but it crossed my mind if this could be the cause in any way?

Nah, could always try manually setting the PCI-E slot to 4.0 though.

I recommend using Hibernate mode and also Sleep mode to see if the behavior is any different. Might help gives some clues to what the root cause is.
 
Joined
Aug 19, 2021
Messages
6 (0.02/day)
Processor i5 11600k
Motherboard Gigabyte Z590 ud ac
Cooling Arctic Freezer Esports Duo
Memory Crucial Ballistix 16 GB 3200Mhz
Video Card(s) Sapphire Nitro+ RX 6600 XT 8GB
Storage Samsung 980 M.2 NVMe + Kingston KC600 SSD + Samsung 850 EVO SSD + 2TB HDD
Display(s) Alienware AW2521HFLA 240hz IPS
Case Coolermaster Storm Trooper
Audio Device(s) Edifier R1280T 2.0 + Asus Strix Wireless 7.1
Power Supply Seasonic Focus GX 650W
Mouse Steelseries Rival 310
Keyboard Logitech G610
Software Win 10 Pro
Update:
I replaced gpu for Sapphire Nitro+ RX 6600 XT and the problem is gone.
My advice if you have Gigabyte mbo, just don't touch MSI MECH.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,345 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Update:
I replaced gpu for Sapphire Nitro+ RX 6600 XT and the problem is gone.
My advice if you have Gigabyte mbo, just don't touch MSI MECH.
Simple, don't use either Gigabyte or MSI. Glad it works though.
 
Top