• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

my rx 570 randomly crash

GalipoteRx570

New Member
Joined
May 11, 2024
Messages
2 (0.05/day)
two weeks ago, i bought a Sapphire NITRO+ RX 570 8 GB used, and the guy said he update it and start giving problems, so i thoung was vbios, and yes it was, cause it was installed a wrong vbios so i fix it, and the problem still, i dont know what more to do, i even bought a CH341 and flash it fisically, an nothing, i dont know if are the memories cause sometimesafter crashing display some weird pattern. pls help me, i dont know what more to do my discord:eek:megapapadelabachata
 

Attachments

  • imagen_2024-05-11_153800910.png
    imagen_2024-05-11_153800910.png
    39.6 KB · Views: 37
  • Imagen de WhatsApp 2024-05-11 a las 15.43.20_8ac23f37.jpg
    Imagen de WhatsApp 2024-05-11 a las 15.43.20_8ac23f37.jpg
    175.1 KB · Views: 39
Joined
May 20, 2020
Messages
1,315 (0.88/day)
Wow, looks like memory is malfunctioning, must have been used as a mining card... I don't think there's much you can do - try and down-clock memory through msi afterburner first to see if it still does the checkerboard artifacts and try the core too.
 
Joined
Jan 22, 2020
Messages
316 (0.20/day)
System Name myPC
Processor i5-11600k @ stock
Motherboard Asus TUF Z590 Gaming Plus
Cooling Thermalright Peerless Assassin 120 SE
Memory Corsair Vengeance LPX 2x8GB DDR4 3200
Video Card(s) Asus Dual RTX 3060 ti
Storage Boot: WD Black SN770 1TB - Game Storage: WD Black SN770 2TB - Other Storage: 4TB
Display(s) Samsung Odyssey G5 curved 27" 1440p 144hz
Case Thermaltake v100 perforated
Audio Device(s) Some headphones and some speakers
Power Supply Gigabyte UD750GM
Mouse Logitech G203
Keyboard Redragon K509
Software W11 Pro
Did you try the other bios? That card has dual bios with a switch to change them. That aside, it does look like failing vram.
 

GalipoteRx570

New Member
Joined
May 11, 2024
Messages
2 (0.05/day)
Did you try the other bios? That card has dual bios with a switch to change them. That aside, it does look like failing vram.
yes, i fix the bouth vbios, one said that was a rx590 and the another said that was a rx 580, that was so confuising but the white paper never fail

Wow, looks like memory is malfunctioning, must have been used as a mining card... I don't think there's much you can do - try and down-clock memory through msi afterburner first to see if it still does the checkerboard artifacts and try the core too.
you trying to say that one of all the memories in my ghraphic card is malfunctioning? how can i know witch is?

two weeks ago, i bought a Sapphire NITRO+ RX 570 8 GB used, and the guy said he update it and start giving problems, so i thoung was vbios, and yes it was, cause it was installed a wrong vbios so i fix it, and the problem still, i dont know what more to do, i even bought a CH341 and flash it fisically, an nothing, i dont know if are the memories cause sometimesafter crashing display some weird pattern. pls help me, i dont know what more to do my discord:eek:megapapadelabachata
was (omegapapadelabachata)
 
Joined
Mar 20, 2008
Messages
1,515 (0.26/day)
System Name Ryzen5900X
Processor AMD Ryzen 5900X
Motherboard Gigabyte B550 AORUS PRO AC
Cooling NZXT Kraken X62
Memory 4x G.Skill F4-3600C17D-8GTZ
Video Card(s) AMD Radeon RX 6800XT Midnight Black
two weeks ago, i bought a Sapphire NITRO+ RX 570 8 GB used, and the guy said he update it and start giving problems, so i thoung was vbios, and yes it was, cause it was installed a wrong vbios so i fix it, and the problem still, i dont know what more to do, i even bought a CH341 and flash it fisically, an nothing, i dont know if are the memories cause sometimesafter crashing display some weird pattern. pls help me, i dont know what more to do my discord:eek:megapapadelabachata
Can you remove the cooler and make a clear picture of the PCB of both sides. Also a picture of the part number on the cooler will be handy.
 
Top