1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

NEED BIOS HELP: Mobility Radeon HD 3650

Discussion in 'AMD / ATI' started by rburch05, Feb 10, 2012.

  1. rburch05 New Member

    Joined:
    Jan 15, 2012
    Messages:
    3 (0.00/day)
    Thanks Received:
    0
    A while back I posted here describing troubles I started having with my laptop's 256MB PCIe 3650. As of Catalyst 11.2 (and also 12.1) I can't drive external monitors any longer.

    Turns out I am fairly certain something happened to the BIOS (Powerplay probably), and now it has incorrect timings for core bus (450MHz) and memory (500MHz).

    I'm looking for help with:
    1. Where can I find a clean BIOS image for this device? This site seems to only have 512MB version.
    2. Does anyone know why atiflash can't seem to copy BIOS from this device? It reports no errors but creates a 0 byte file (see detail in above link.)

    Help, or any other pointers, are appreciated. My laptop's LCD is nice, but I miss my external monitor.
     
  2. Sound_Card New Member

    Joined:
    Aug 3, 2006
    Messages:
    63 (0.02/day)
    Thanks Received:
    6
    Location:
    San Antonio, TX
    I'm going to ask an obvious question. Have you tried under "creating and arranging desktops" in "CCC", and click detect displays?
     
    10 Year Member at TPU
  3. rburch05 New Member

    Joined:
    Jan 15, 2012
    Messages:
    3 (0.00/day)
    Thanks Received:
    0
    First off, thanks. I do appreciate the response.

    I don't have a "CCC" at all sadly. I have an "amdcccle" instead, for you see, I am on "the linux."

    When I run amdcccle there is no "creating and arranging desktops" option, but under the "Display Manager" tree all screens are detected and present. If you look at my original post linked in the post above, you'll see that the problem is that external monitors never sync properly. There is horrible vertical flicker and blanking at all resolutions and sync rates.

    Even if I roll back to previous catalyst versions the problem persists. I really suspect Powerplay boned my memory timings because 11.12 was my first exposure to it, and I'm thinking its linux implementation might need some work at least on 3650. I suspect it tweaked some power saving configuration in my BIOS, and I have no means to tweak things back.

    That's why I am looking for a clean BIOS. Do you think I should be looking at something else?
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)