• We've upgraded our forums. Please post any issues/requests in this thread.

OCZ Agility 3 hanging

anoobarak

New Member
Joined
Jul 13, 2011
Messages
102 (0.04/day)
Likes
13
Location
Euroland
Processor AMD Phenom II 1090T BE @ 4030MHz
Motherboard Gigabyte GA-990XA-UD3
Cooling Noctua NH-D14
Memory Samsung Green 8GB @ 1896MHz
Video Card(s) MSI GTX 660Ti Power Edition 2 GB
Storage OCZ Agility 3 60GB; 1TB Samsung 2.5"
Display(s) LG Flatron E2241 21.5" LED
Case Thermaltake Commander MS-I Snow Edition
Audio Device(s) Creative Sound Blaster Audigy
Power Supply OCZ ModXStream Pro 600W
Software Windows 7 Ultimate 64-bit
#1
Hey guys, I've searched the internet for a solution to this problem and I failed :( so I'm seeking help here.
I have an ocz agility 3 60GB and it sometimes (too often really, 5 times a day maybe) hangs the whole system for about a minute. This wasn't always the case: when the drive was new, no hanging occurred. Can this be a faulty drive? My drive has the latest firmware (2.15). What can I do to make this go away?
 

erocker

Senior Moderator
Staff member
Joined
Jul 19, 2006
Messages
42,369 (10.18/day)
Likes
18,018
Processor Intel i7 8700k
Motherboard Gigabyte z370 AORUS Gaming 7
Cooling Water
Memory 16gb G.Skill 4000 MHz DDR4
Video Card(s) Evga GTX 1080
Storage 3 x Samsung Evo 850 500GB, 1 x 250GB, 2 x 2TB HDD
Display(s) Nixeus EDG27
Case Thermaltake X5
Power Supply Corsair HX1000i
Mouse Zowie EC1-B
Software Windows 10

anoobarak

New Member
Joined
Jul 13, 2011
Messages
102 (0.04/day)
Likes
13
Location
Euroland
Processor AMD Phenom II 1090T BE @ 4030MHz
Motherboard Gigabyte GA-990XA-UD3
Cooling Noctua NH-D14
Memory Samsung Green 8GB @ 1896MHz
Video Card(s) MSI GTX 660Ti Power Edition 2 GB
Storage OCZ Agility 3 60GB; 1TB Samsung 2.5"
Display(s) LG Flatron E2241 21.5" LED
Case Thermaltake Commander MS-I Snow Edition
Audio Device(s) Creative Sound Blaster Audigy
Power Supply OCZ ModXStream Pro 600W
Software Windows 7 Ultimate 64-bit
#3
Well I applied the tweaks that program offered. Gonna use pc as usual and see if that helped or not.
 

erocker

Senior Moderator
Staff member
Joined
Jul 19, 2006
Messages
42,369 (10.18/day)
Likes
18,018
Processor Intel i7 8700k
Motherboard Gigabyte z370 AORUS Gaming 7
Cooling Water
Memory 16gb G.Skill 4000 MHz DDR4
Video Card(s) Evga GTX 1080
Storage 3 x Samsung Evo 850 500GB, 1 x 250GB, 2 x 2TB HDD
Display(s) Nixeus EDG27
Case Thermaltake X5
Power Supply Corsair HX1000i
Mouse Zowie EC1-B
Software Windows 10
#4
Best of luck! Also, make sure that your motherboard chipset and SATA drivers are all up to date. :)
 

anoobarak

New Member
Joined
Jul 13, 2011
Messages
102 (0.04/day)
Likes
13
Location
Euroland
Processor AMD Phenom II 1090T BE @ 4030MHz
Motherboard Gigabyte GA-990XA-UD3
Cooling Noctua NH-D14
Memory Samsung Green 8GB @ 1896MHz
Video Card(s) MSI GTX 660Ti Power Edition 2 GB
Storage OCZ Agility 3 60GB; 1TB Samsung 2.5"
Display(s) LG Flatron E2241 21.5" LED
Case Thermaltake Commander MS-I Snow Edition
Audio Device(s) Creative Sound Blaster Audigy
Power Supply OCZ ModXStream Pro 600W
Software Windows 7 Ultimate 64-bit
#5
A minute ago I had another hang. Got anything else?
 
Joined
Aug 5, 2008
Messages
497 (0.15/day)
Likes
117
Location
Hampshire, UK
System Name If you name your systems, get a girlfriend...
Processor i7 4770k
Motherboard Asus Maximus VI Formula
Cooling Custom waterloop around Black Ice GTX 360
Memory 16GB DDR3
Video Card(s) R9 290
Storage Samsung 850 Pro 1TB
Case HAF 932
Audio Device(s) Onboard
Power Supply Corsair HX750
Software Windows 10 x64
#6
I had exactly the same issue.
Many people did, and some reported that latest firmware helped them (2.15).

In my case, only DISABLING TRIM solved the problem permanently.
Don't worry. Sandforce SSDs work quite well without TRIM anyway.

How to Disable TRIM Command:

In the Elevated command Prompt windows, type the following:
fsutil behavior set disabledeletenotify 1
 
Joined
Apr 3, 2010
Messages
351 (0.12/day)
Likes
149
System Name Desktop [Custom] / Laptop [Acer Aspire TimelineX 4830T]
Processor Intel Core i5 6600K [3.5GHz/3.9GHz Turbo][4C/4T] / Core i3 2370M [2.4GHz][2C/4T]
Motherboard Gigabyte GA-Z170X-Gaming 7 [Z170][F22i] / Acer JM40-HR [HM65]
Cooling CPU: CM Hyper 212 Evo 2x120mm Case Fans: Front-120mm, Rear-120mm, Side-120mm Blue LED
Memory Kingston HyperX DDR4 2400 16GB [1x16GB][15-15-15-35] / DDR3 1333 8GB [2x4GB][9-9-9-24@1.5V]
Video Card(s) (Gigabyte) NVIDIA GeForce GTX 1070 8GB FE [Driver: 385.69] / Intel HD 3000 [128MB]
Storage OCZ Vertex 3 120GB [FW: 2.22][OS] / Agility 3 120GB [FW: 2.22][OS]
Display(s) DELL 27" S2740L [1920x1080@60Hz][IPS][LED] / InnoLux 14" [1366x768@60Hz][LED]
Case COOLER MASTER Storm Scout (SGC-2000-KKN1-GP)
Audio Device(s) Creative Sound Core 3D / Conexant HD Audio
Power Supply Corsair CMPSU-750TX 750W [+12V@ 60A 720W][Typical Efficiency: 83.92%]
Mouse Logitech M570 Trackball
Keyboard Logitech Access Keyboard 600
Software Microsoft Windows 7 Professional [64-bit][SP1] / Windows 10 Pro [1709][64-bit]
#7
A minute ago I had another hang. Got anything else?
You could try disabling "Hard disk - Turn off hard disk after" in "Power Options" and/or try switching from "Balanced" to "High Performance".

Also check your SATA cable and make sure your BIOS is setup properly.
 

anoobarak

New Member
Joined
Jul 13, 2011
Messages
102 (0.04/day)
Likes
13
Location
Euroland
Processor AMD Phenom II 1090T BE @ 4030MHz
Motherboard Gigabyte GA-990XA-UD3
Cooling Noctua NH-D14
Memory Samsung Green 8GB @ 1896MHz
Video Card(s) MSI GTX 660Ti Power Edition 2 GB
Storage OCZ Agility 3 60GB; 1TB Samsung 2.5"
Display(s) LG Flatron E2241 21.5" LED
Case Thermaltake Commander MS-I Snow Edition
Audio Device(s) Creative Sound Blaster Audigy
Power Supply OCZ ModXStream Pro 600W
Software Windows 7 Ultimate 64-bit
#8
I don't think it's the turn down hard disk option (still applied performance mode though) in power options because the hangs occur both during use and idle (except music playing, but the files are on hdd so it continues playing).
I'll be posting next time when another hang occurs. Don't wanna spam the forum.
 
Joined
Apr 3, 2010
Messages
351 (0.12/day)
Likes
149
System Name Desktop [Custom] / Laptop [Acer Aspire TimelineX 4830T]
Processor Intel Core i5 6600K [3.5GHz/3.9GHz Turbo][4C/4T] / Core i3 2370M [2.4GHz][2C/4T]
Motherboard Gigabyte GA-Z170X-Gaming 7 [Z170][F22i] / Acer JM40-HR [HM65]
Cooling CPU: CM Hyper 212 Evo 2x120mm Case Fans: Front-120mm, Rear-120mm, Side-120mm Blue LED
Memory Kingston HyperX DDR4 2400 16GB [1x16GB][15-15-15-35] / DDR3 1333 8GB [2x4GB][9-9-9-24@1.5V]
Video Card(s) (Gigabyte) NVIDIA GeForce GTX 1070 8GB FE [Driver: 385.69] / Intel HD 3000 [128MB]
Storage OCZ Vertex 3 120GB [FW: 2.22][OS] / Agility 3 120GB [FW: 2.22][OS]
Display(s) DELL 27" S2740L [1920x1080@60Hz][IPS][LED] / InnoLux 14" [1366x768@60Hz][LED]
Case COOLER MASTER Storm Scout (SGC-2000-KKN1-GP)
Audio Device(s) Creative Sound Core 3D / Conexant HD Audio
Power Supply Corsair CMPSU-750TX 750W [+12V@ 60A 720W][Typical Efficiency: 83.92%]
Mouse Logitech M570 Trackball
Keyboard Logitech Access Keyboard 600
Software Microsoft Windows 7 Professional [64-bit][SP1] / Windows 10 Pro [1709][64-bit]
#9
I don't think it's the turn down hard disk option (still applied performance mode though) in power options because the hangs occur both during use and idle (except music playing, but the files are on hdd so it continues playing).
I'll be posting next time when another hang occurs. Don't wanna spam the forum.
Hopefully that will fix it, but some have found that just disabling the "Hard disk turn off" option helps with freezing and stutters. SSD's in general can be very temperamental when it comes to power management, as was displayed this summer with the SF-2281 drives.

Good luck with it.
 

anoobarak

New Member
Joined
Jul 13, 2011
Messages
102 (0.04/day)
Likes
13
Location
Euroland
Processor AMD Phenom II 1090T BE @ 4030MHz
Motherboard Gigabyte GA-990XA-UD3
Cooling Noctua NH-D14
Memory Samsung Green 8GB @ 1896MHz
Video Card(s) MSI GTX 660Ti Power Edition 2 GB
Storage OCZ Agility 3 60GB; 1TB Samsung 2.5"
Display(s) LG Flatron E2241 21.5" LED
Case Thermaltake Commander MS-I Snow Edition
Audio Device(s) Creative Sound Blaster Audigy
Power Supply OCZ ModXStream Pro 600W
Software Windows 7 Ultimate 64-bit
#10
Seems the problem went away. Thank you TheOne, you saved me a lot of time fiddling with settings to fix this glitch