• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Power down and connect PCIe Power Cable error on NVIDIA GPUs: hardware or not?

Joined
May 14, 2021
Messages
19 (0.14/day)
Location
Philippines
System Name RYZENPC69420
Processor AMD Ryzen 3 2200G
Motherboard MSI A320M PRO-M2
Cooling AMD Stock Cooler
Memory 8x1 Ballistix Sport LT DDR4-2666
Video Card(s) Sapphire NITRO RX 470 OC
Storage KINGSTON A400 120GB SSD, SEAGATE BARRACUDA 1TB HDD
Display(s) some TV i found lying around house
Case Inplay Meteor 01
Audio Device(s) Motherboard Audio, KZ DQ6
Power Supply Seasonic FOCUS GX-750
Mouse Logitech G304 LIGHTSPEED (a.k.a. G305)
Keyboard Gigaware K550
Hi.
I have been given a GTX 1070 that the former owner said had an error that said: Please power down and connect PCIe power cable for this graphics card. I can't test it on my PC just yet since it was given quite recently and the owner will ship it sometime next week, but I want to know if it is a kind of red flag that indicates a dead GPU, or if I just need to put in 2 PCIe cables.
Thanks in advance!
 
Joined
Oct 18, 2013
Messages
2,905 (1.00/day)
Location
Left @Booneys Ave, go 22.96 miles then right 2 mi.
System Name The Big RED One
Processor i9-9900k, oc'd to 5.2 ghz
Motherboard Asus ROG Maximus Hero Wifi Z390
Cooling Corsair H115i pro AIO 560mm push/pull, 11x Corsair 140mm ML RGB Fans, 5 in a modded rack config
Memory 64GB Corsair Vengance RBG pro DDR4-3200 (4x 16GB) in XMP2
Video Card(s) Evga RTX 3080 w/15% O/C
Storage 2x WD Black SN750 1TB m.2 + 4TB Crucial SSD + WD 12TB external HDD
Display(s) 2x Samsung 43" LCD's @4k-1440p
Case Thermaltake TT900 Supertower
Audio Device(s) On-board Intel AC9260 wireless, JBL Studio Pro Bluetooth Speakers
Power Supply EVGA G2 SuperNova 850W Modular
Mouse Logitech MX Master 2
Keyboard Logitech G613 mechanical wireless
Software Windows 10 pro 64 bit, with all the unnecessary background shitzu turned OFF !
Benchmark Scores Quicker than flies on a dung pile
Just guessing here, but it sounds like the former owner was attempting to use the card without any power connections to the PSU.....or perhaps his connectors were not fully engaged, or the cables were flakey/defective, or even the sockets on his psu were kaput...

Virtually any modern GPU needz some juice to work propely, in addition to what they get from the pcie slots...even though the 1070 series cards aren't giant power hogs but still...

So if thats the case, you should be able to run it normally once connected correctly, assuming nothing (else) is actually wrong with it....

Good luck :)
 
Joined
May 14, 2021
Messages
19 (0.14/day)
Location
Philippines
System Name RYZENPC69420
Processor AMD Ryzen 3 2200G
Motherboard MSI A320M PRO-M2
Cooling AMD Stock Cooler
Memory 8x1 Ballistix Sport LT DDR4-2666
Video Card(s) Sapphire NITRO RX 470 OC
Storage KINGSTON A400 120GB SSD, SEAGATE BARRACUDA 1TB HDD
Display(s) some TV i found lying around house
Case Inplay Meteor 01
Audio Device(s) Motherboard Audio, KZ DQ6
Power Supply Seasonic FOCUS GX-750
Mouse Logitech G304 LIGHTSPEED (a.k.a. G305)
Keyboard Gigaware K550
Just guessing here, but it sounds like the former owner was attempting to use the card without any power connections to the PSU.....or perhaps his connectors were not fully engaged, or the cables were flakey/defective, or even the sockets on his psu were kaput...

Virtually any modern GPU needz some juice to work propely, in addition to what they get from the pcie slots...even though the 1070 series cards aren't giant power hogs but still...

So if thats the case, you should be able to run it normally once connected correctly, assuming nothing (else) is actually wrong with it....

Good luck :)
That's what I was guessing. I currently am asking what power supply was used to test the GPU, just so I would know if it's not enough juice that was the problem. I searched more, and I think the only thing I should watch out for is that the power connectors themselves might be dead, but with the GPU with display, I don't think that's the case.
Thanks for the answer!
 
Joined
Oct 18, 2013
Messages
2,905 (1.00/day)
Location
Left @Booneys Ave, go 22.96 miles then right 2 mi.
System Name The Big RED One
Processor i9-9900k, oc'd to 5.2 ghz
Motherboard Asus ROG Maximus Hero Wifi Z390
Cooling Corsair H115i pro AIO 560mm push/pull, 11x Corsair 140mm ML RGB Fans, 5 in a modded rack config
Memory 64GB Corsair Vengance RBG pro DDR4-3200 (4x 16GB) in XMP2
Video Card(s) Evga RTX 3080 w/15% O/C
Storage 2x WD Black SN750 1TB m.2 + 4TB Crucial SSD + WD 12TB external HDD
Display(s) 2x Samsung 43" LCD's @4k-1440p
Case Thermaltake TT900 Supertower
Audio Device(s) On-board Intel AC9260 wireless, JBL Studio Pro Bluetooth Speakers
Power Supply EVGA G2 SuperNova 850W Modular
Mouse Logitech MX Master 2
Keyboard Logitech G613 mechanical wireless
Software Windows 10 pro 64 bit, with all the unnecessary background shitzu turned OFF !
Benchmark Scores Quicker than flies on a dung pile
no problem, glad to help....

Just to add though, if the card was functional enough to know that it needed moar powa, then it is most likely ok, unless the former owner ran it for a long time with the cables being connected, or used it under heavy loads for an extended time :D
 
Joined
May 14, 2021
Messages
19 (0.14/day)
Location
Philippines
System Name RYZENPC69420
Processor AMD Ryzen 3 2200G
Motherboard MSI A320M PRO-M2
Cooling AMD Stock Cooler
Memory 8x1 Ballistix Sport LT DDR4-2666
Video Card(s) Sapphire NITRO RX 470 OC
Storage KINGSTON A400 120GB SSD, SEAGATE BARRACUDA 1TB HDD
Display(s) some TV i found lying around house
Case Inplay Meteor 01
Audio Device(s) Motherboard Audio, KZ DQ6
Power Supply Seasonic FOCUS GX-750
Mouse Logitech G304 LIGHTSPEED (a.k.a. G305)
Keyboard Gigaware K550
Talked to the former owner. Said he used a modular power supply with the card, and that the connectors were defective.
no problem, glad to help....

Just to add though, if the card was functional enough to know that it needed moar powa, then it is most likely ok, unless the former owner ran it for a long time with the cables being connected, or used it under heavy loads for an extended time :D
So it means that I might get a straight dead GPU (~3/10 dead gpu), unless I make soldering magic and work the 12V connector? I'm feeling kinda doubtful with the GPU now, but I wish the card good luck.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,253 (6.20/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Hi.
I have been given a GTX 1070 that the former owner said had an error that said: Please power down and connect PCIe power cable for this graphics card. I can't test it on my PC just yet since it was given quite recently and the owner will ship it sometime next week, but I want to know if it is a kind of red flag that indicates a dead GPU, or if I just need to put in 2 PCIe cables.
Thanks in advance!
Yes vreg is dead, do not
Buy it
 
Joined
May 14, 2021
Messages
19 (0.14/day)
Location
Philippines
System Name RYZENPC69420
Processor AMD Ryzen 3 2200G
Motherboard MSI A320M PRO-M2
Cooling AMD Stock Cooler
Memory 8x1 Ballistix Sport LT DDR4-2666
Video Card(s) Sapphire NITRO RX 470 OC
Storage KINGSTON A400 120GB SSD, SEAGATE BARRACUDA 1TB HDD
Display(s) some TV i found lying around house
Case Inplay Meteor 01
Audio Device(s) Motherboard Audio, KZ DQ6
Power Supply Seasonic FOCUS GX-750
Mouse Logitech G304 LIGHTSPEED (a.k.a. G305)
Keyboard Gigaware K550
Yes vreg is dead, do not
Buy it
Hi, sorry for the really late reply. I didn't take it since there was someone else who wanted to buy it from him. Thank you for that, though.
By any chance, can you care to explain what the issue might be, if I were to take it?
Thank you!
 
Top