• We've upgraded our forums. Please post any issues/requests in this thread.

R9 290 after bios flash screen goes black after driver install

Cel00

New Member
Joined
Oct 29, 2017
Messages
1 (0.02/day)
Likes
0
#1
Hey
got an Powercolor R9 290 PCS+ from eBay a month or so ago. Sadly the Card got the quite common black screen problem like many of the units have, so after some reading I could reduce it with lowering the memory clock speed and forcing constant voltage in MSI Afterburner. It lowers the black screen problem in games, but did not fix it completely so some guys said that they fixed it with flashing a different BIOS version (preferred the tri x bios http://www.tomshardware.co.uk/answers/id-2033153/explain-works-290-black-screen-fix.html) but at first I just tried to update mine 015.045.000.009.0.... With Hynix memory (there are like 3 different brands they used for memory because, like I said the r9 290 series had some problems)
So i went to https://www.techpowerup.com/vgabios...el=R9+290&interface=&memType=&memSize=&since=
and had the choice between
https://www.techpowerup.com/vgabios/162939/powercolor-r9290-4096-140814
https://www.techpowerup.com/vgabios/168095/powercolor-r9290-4096-150104
However the new version says Memory Support
4096 MB, GDDR5, Samsung K4G20325FD
while the other version says
Memory Support
4096 MB, GDDR5, Autodetect
4096 MB, GDDR5, Hynix H5GQ2H24AFR
4096 MB, GDDR5, Elpida EDW2032BBBG
So I tried the version with Hynix listed and later the newer one only with Samsung listed, but on both tries my screen went black when I try to install AMD Drivers, the Card works perfectly fine but as soon I install the drivers the screens goes black and never comes back. Same when I restart I see the Mobo Logo and the Windows boot screen but after that just black screen. I went into safe mode and uninstalled the drivers with DDU and flashed the old bios again, but still I would like to know why the newer BIOS versions don't work.