• We've upgraded our forums. Please post any issues/requests in this thread.

Sapphire 7950 bios request

Joined
Jun 28, 2011
Messages
16 (0.01/day)
Likes
0
Location
Ireland
#1
My BIOS was 810mhz core all the faster bios's from sapphire on the collection here seemed to brick it including the 810.

I got it going with the amd 925mhz.

Can someone gpu-z the bios for me and put it up here or email it to me for backup. :toast:

PN: 299-1E207-100SA
 
Last edited:

Phusius

New Member
Joined
Mar 23, 2012
Messages
1,316 (0.63/day)
Likes
369
Processor i5-2500k @ 4.5
Motherboard Asus Z68 Deluxe
Cooling Noctua NH-D14
Memory 16GB DDR3 1600
Video Card(s) Sapphire 7950 @ 1200/1475 @ 1175v
Display(s) Dell 23" 2ms
Case Carbide 500r
Audio Device(s) Asus Xonar DG
#2
What's your email, my Sapphire BIOS on my 7950 I just got last week I can email you. just PM me
 
Joined
Jun 28, 2011
Messages
16 (0.01/day)
Likes
0
Location
Ireland
#3
What's your email, my Sapphire BIOS on my 7950 I just got last week I can email you. just PM me

Hi mate thanks,

Funnily enough i have got it working fully recognized with the amd 925 on bios 1, it works on bios 2 also but seems to be stripped down and not fully recognized perhaps this is normal.

I am about to do a 3d mark vantage to see is it stable will post back here in a short while to confirm it is.

:rockout:
 
Joined
Jun 28, 2011
Messages
16 (0.01/day)
Likes
0
Location
Ireland
#4
Success with the amd 925mhz bios on 1 the sapphire got a perfectly stable GPU score of;

28143

So if you were like me :banghead: and read this slap that bios on.

I did make the mistake of not properly backing up original. Thanks again to Phusius.