• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[SOLVED] I think I flashed the wrong vbios and it never comes back. (MSI GP73 8RE GTX 1060)

sighpie

New Member
Joined
Mar 31, 2020
Messages
4 (0.07/day)
640175961_1585575721(1).png.3a6e35ff3fcd4d4031ff2ef768c57b8b.png
(At that time, I thought that the device ID part was personal information similar to IP, so I kept it hidden.
So I'm not sure if the device ID that I can see now has changed or remains the same.)

2114385440_2020-03-30223943.png.d53f33fcb45d6984ec049af37345c2f4.png
I purchased the Oculus Rift S,
connected the cable to the Mini-DP and USB 3.1 port,
and the Oculus app also showed a green check that it was connected normally.

There was a problem with the HMD showing nothing.

I searched the internet all day and tried everything I could find.

-USB firmware update, BIOS update, graphics card driver update
-I searched for a graphic card BIOS update and applied the latest one with nvflash, but output 'Nothing changed!'
-Turn your computer off and on
-Remove it, plug in the USB, wait 10 seconds for the HMD small light to turn white, then plug in the miniDP
-Unplug the HMD cable and wait 10 seconds before plugging it in
-Turn the Oculus app off and on -Windows update
-Disable the built-in graphic card
-Downgrade graphic card's firmware
-Finally, VBIOS update using nvflash of this version https://www.techpowerup.com/download/nvidia-nvflash-with-board-id-mismatch-disabled/ (Maybe it was when I applied the wrong rom file...)

Still, the screen of the Oculus Rift S was not visible.

And I got a new problem with the graphics card (GTX 1060) not being displayed on task manager.

881722913_2020-03-31003805.png.502fa9ea2cf454d241da4a6a26ae2ff8.png 757095958_2020-03-31003136.png.d770937c2ba5f64da57a1e32bb4f4633.png822648224_2020-03-31140051.png.3ca7196474901b79cbdce1303e5d6d3a.png

I tried to contact MSI to get the official rom file and nvflash file and try to apply it, but it still gives an error.

Microsoft Windows [Version 10.0.18363.752]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>cd C:\Users\opty2\Downloads\asdf

C:\Users\opty2\Downloads\asdf>fvbios

C:\Users\opty2\Downloads\asdf>nvflash -6 600042.rom
NVIDIA Firmware Update Utility (Version 5.545.0)
Copyright (C) 1993-2018, NVIDIA Corporation. All rights reserved.


Checking for matches between display adapter(s) and image(s)...

Adapter: GeForce GTX 1060 (10DE,1C60,1462,1215) H:--:NRM S:00,B:01,D:00,F:00


EEPROM ID (C2,2534) : MX MX25U8033E-MX25U8035F 1.65-2.0V 8192Kx1S, page

WARNING: None of the firmware image compatible PCI Device ID's
match the PCI Device ID of the adapter.
Adapter PCI Device ID: 1C60
Firmware image PCI Device ID: 1C20
WARNING: Firmware image PCI Subsystem ID (1462.0000)
does not match adapter PCI Subsystem ID (1462.1215).

NOTE: Exception caught.
Nothing changed!



ERROR: GPU mismatch


How can I solve it?
 
Last edited:
Joined
Oct 22, 2014
Messages
7,921 (3.88/day)
Location
Sunshine Coast
System Name Black Box
Processor AMD 3200G
Motherboard MSI X470 Gaming Plus
Cooling Stock
Memory Adata 8Gb 2133Mhz DDR4
Storage Kingston A2000 512Gb NVME
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit

sighpie

New Member
Joined
Mar 31, 2020
Messages
4 (0.07/day)
Same issue here: https://forum-en.msi.com/index.php?topic=319304.0
I suggest contact MSI for the laptop GPU BIOS.
That's a good solution.
But after MSI has provided official nvflash and rom files, there is no effective answer yet. (The provided nvflash is only outputting errors. -6, --protectoff, other rom files...)
Now I am waiting after asking additional questions. Because running nvflash does not create any other situation in current.
And I also had the same ending as the author of that article.
The status of gpu-z display is very similar to my graphics card.
 
Last edited:

sighpie

New Member
Joined
Mar 31, 2020
Messages
4 (0.07/day)
OH

주석 2020-03-31 210957.png


Finally! It seems to have returned to the normal Device ID.

I'm not sure what exactly happened,
but I ran this link's rom file with the -6 flag on the nvflash 5.540.0 and rebooted the computer and Device ID returned to 10DE 1C20 again.

In the info of the rom file, it says 1C60 ... Maybe it is a reverse action similar to the error that my graphic card changed from 1C20 to 1C60.

nvflash 5.540.0 file was provided by MSI. I leave it as an attachment here for who have incount same problem later.

 

Attachments

Last edited:

sighpie

New Member
Joined
Mar 31, 2020
Messages
4 (0.07/day)
And lastly... Apply the rom file provided by MSI to that version of nvflash ... the GPU is back!
주석 2020-03-31 212624.png
 
Top