• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Soundblaster Z crackling sound

speedy77

New Member
Joined
Aug 30, 2018
Messages
11 (0.01/day)
Anybody have any luck with the latest insider builds? This is my next step when I get enough energy to try another build tomorrow

Installed the latest insider version with no luck, but also did a clean install of 1703 and had the same problem. Going to try 1607 now but it’s not looking spectacular. Hopefully it’s not some strange MOBO compatibility problem
 
Joined
Jan 31, 2010
Messages
4,935 (1.07/day)
Location
Gougeland (NZ)
System Name Cumquat 2021
Processor AMD RyZen R7 5800X @4750MHz 1.298V
Motherboard Asus Strix x570-F Gaming
Cooling Cryorig R1 Universal + CM MasterGel Pro TP
Memory 16GB GSkill Ripjaws V Black 4000 MTs (2x8GB) @3866MT's
Video Card(s) Sapphire Nitro+ OC RX6800 16GB DDR6 2270Cclk / 2010Mclk
Storage 1x Adata SX8200PRO NVMe gen3 x4 1X Samsung 860 EVO 500GB, 12TB of HDD Storage
Display(s) AOC 24G2 IPS 144Hz FreeSync Premium 1920x1080p
Case SilverStone Raven RV02B-W + 3x SS AP181 + USB3.0 front panel upgrade
Audio Device(s) RX6800 via HDMI + Pioneer VSX-531 amp Technics 100W 5.1 Speaker set
Power Supply Enermax RevolutionXT II 750W 80+ Gold
Mouse Logitech G502 Proteus Core
Keyboard Logitech G815
Software Windows 11 X64 PRO (build 22H2)
Benchmark Scores it sucks even more less now ;)
Joined
Jan 29, 2012
Messages
5,781 (1.48/day)
Location
Florida
System Name natr0n-PC
Processor Ryzen 5950x - smt off
Motherboard Aorus B450M
Cooling EK AIO - 6 fan action
Memory TEAM VULCAN 32GB DDR4 4000 @ 3667
Video Card(s) EVGA 3070ti ftw
Storage Various
Display(s) PIXIO IPS 240Hz
Case Thermaltake Level 20 VT
Audio Device(s) LOXJIE D10 + Kinter Amp
Power Supply Super Flower Leadex III ARGB 80+ Gold 650W
Software XP/7/8.1/10
Benchmark Scores http://valid.x86.fr/79kuh6

FreedomEclipse

~Technological Technocrat~
Joined
Apr 20, 2007
Messages
22,575 (4.00/day)
Location
London,UK
System Name Codename: Icarus Mk.V
Processor Intel 8600k@Stock -- pending tuning
Motherboard Asus ROG Strixx Z370-F
Cooling CPU: BeQuiet! Dark Rock Pro 4 {1xCorsair ML120 Pro|5xML140 Pro}
Memory 32GB XPG Gammix D10 {2x16GB}
Video Card(s) ASUS Dual Radeon™ RX 6700 XT OC Edition
Storage Samsung 970Evo 512GB SSD (Boot)|WD Blue 1TB SSD|2x 3TB Toshiba DT01ACA300
Display(s) LG GP850-B
Case Corsair 760T (White)
Audio Device(s) Yamaha RX-V573|Speakers: JBL Control One|Auna 300-CN|Wharfedale Diamond SW150
Power Supply Corsair AX760
Mouse Logitech G900/G502
Keyboard Duckyshine Dead LED(s) III
Software Windows 10 Pro
Benchmark Scores (ノಠ益ಠ)ノ彡┻━┻
Same here as well. I've experienced anything like this problem. As long as the proper drivers were properly installed, things have been smooth sailing.

Same here. Not had any issues since migrating to windows 10
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
7,572 (1.16/day)
Location
Canuck in Norway
System Name Hellbox 5.0 (same case new guts)
Processor Ryzen 7 5800X3D
Motherboard MSI X570S MAG Torpedo Max
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua EK Quantum DDC Pump/Res
Memory 2x16GB Gskill Trident Neo Z 3600 CL16
Video Card(s) Sapphire 6700XT Nitro+
Storage 970 Evo Plus 500GB 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue Corsair MP600 Core 2TB
Display(s) Samsung Odyssey G5 34” 3440x1440 165hz
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic TX~’850 Platinum
Mouse G502 Proteus Spectrum
Keyboard G19s
VR HMD Oculus Quest 2
Software Win 10 Pro x64
Joined
Feb 10, 2007
Messages
2,507 (0.44/day)
Location
Oulu, Finland
System Name Enslaver :)
Processor Intel i7 8700k
Motherboard Asus Strix Z370-F Gaming
Cooling CPU: Noctua NH-D14, Case: mix of different fans
Memory 2x8GB Corsair Vengeance LPX 3200MHz + 2x4GB Corsair Vengeance LPX 3000MHz (running all 3200MHz)
Video Card(s) ASUS GTX 1080 A8G Strix
Storage 500GB Samsung Evo 850 SSD, internal WD Red 4TB for storage
Display(s) LG 55SJ810V 4K IPS TV, HDR
Case Corsair 800D
Audio Device(s) Sound Blaster Z. DTS sound over SPDIF
Power Supply Corsair RM850x
Mouse ROG Gladius
Keyboard ASUS Strix Tactic Pro
Software Windows 10 Pro x64
So yesterday while streaming with an VPN and having so having a slower connection i got this crackling again every time the connection was not perfect. It seems like my soundcard in DTS mode amplifies streaming connection inperfections and is crackling this way. Without VPN, streaming youtube and such have not done the same.
 
Joined
Jul 5, 2013
Messages
20,699 (6.12/day)
Location
USA
but does he even do a set for the “Z” range?
No that I have seen. Just goes up as high as the X-Fi range.
So yesterday while streaming with an VPN and having so having a slower connection i got this crackling again every time the connection was not perfect. It seems like my soundcard in DTS mode amplifies streaming connection inperfections and is crackling this way. Without VPN, streaming youtube and such have not done the same.
This seems more like a codec issue than that of a driver/hardware issue or even VPN problem. Have you tried something other than DTS?
 
Joined
Feb 10, 2007
Messages
2,507 (0.44/day)
Location
Oulu, Finland
System Name Enslaver :)
Processor Intel i7 8700k
Motherboard Asus Strix Z370-F Gaming
Cooling CPU: Noctua NH-D14, Case: mix of different fans
Memory 2x8GB Corsair Vengeance LPX 3200MHz + 2x4GB Corsair Vengeance LPX 3000MHz (running all 3200MHz)
Video Card(s) ASUS GTX 1080 A8G Strix
Storage 500GB Samsung Evo 850 SSD, internal WD Red 4TB for storage
Display(s) LG 55SJ810V 4K IPS TV, HDR
Case Corsair 800D
Audio Device(s) Sound Blaster Z. DTS sound over SPDIF
Power Supply Corsair RM850x
Mouse ROG Gladius
Keyboard ASUS Strix Tactic Pro
Software Windows 10 Pro x64
No that I have seen. Just goes up as high as the X-Fi range.

This seems more like a codec issue than that of a driver/hardware issue or even VPN problem. Have you tried something other than DTS?

Tried 2.1 sound too and with that the connection errors were sounding normal and not as over the top crackling like with DTS on
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
7,572 (1.16/day)
Location
Canuck in Norway
System Name Hellbox 5.0 (same case new guts)
Processor Ryzen 7 5800X3D
Motherboard MSI X570S MAG Torpedo Max
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua EK Quantum DDC Pump/Res
Memory 2x16GB Gskill Trident Neo Z 3600 CL16
Video Card(s) Sapphire 6700XT Nitro+
Storage 970 Evo Plus 500GB 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue Corsair MP600 Core 2TB
Display(s) Samsung Odyssey G5 34” 3440x1440 165hz
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic TX~’850 Platinum
Mouse G502 Proteus Spectrum
Keyboard G19s
VR HMD Oculus Quest 2
Software Win 10 Pro x64

FreedomEclipse

~Technological Technocrat~
Joined
Apr 20, 2007
Messages
22,575 (4.00/day)
Location
London,UK
System Name Codename: Icarus Mk.V
Processor Intel 8600k@Stock -- pending tuning
Motherboard Asus ROG Strixx Z370-F
Cooling CPU: BeQuiet! Dark Rock Pro 4 {1xCorsair ML120 Pro|5xML140 Pro}
Memory 32GB XPG Gammix D10 {2x16GB}
Video Card(s) ASUS Dual Radeon™ RX 6700 XT OC Edition
Storage Samsung 970Evo 512GB SSD (Boot)|WD Blue 1TB SSD|2x 3TB Toshiba DT01ACA300
Display(s) LG GP850-B
Case Corsair 760T (White)
Audio Device(s) Yamaha RX-V573|Speakers: JBL Control One|Auna 300-CN|Wharfedale Diamond SW150
Power Supply Corsair AX760
Mouse Logitech G900/G502
Keyboard Duckyshine Dead LED(s) III
Software Windows 10 Pro
Benchmark Scores (ノಠ益ಠ)ノ彡┻━┻
Actually, I haven't had any serious Soundblaster driver issues since the early Windows XP days.

Last time i had issues was when a XFi Titanium was dying. apart from that, everything was fine. I found Asus Xonar cards to be a lot more buggy when it came to games.
 
Joined
Nov 18, 2010
Messages
6,135 (1.41/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor AMD RYZEN 9 5950X
Motherboard ASUS Strix X570-E
Cooling Custom Loop. Two 360ies + 280 rad. 8x Nidec Servo Gentle Typhoons. EK-Quantum Momentum monoblock.
Memory 4x8GB G.SKILL Trident Z RGB F4-4133C19D-16GTZR 14-16-12-30-44
Video Card(s) ASUS 1080 Ti SLI + water blocks
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB+ 1TB 980PRO
Display(s) Philips PHL BDM3270 + Acer XV242Y
Case Lian Li O11 Dynamic EVO
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer BlackWidow V3 - Yellow Switch
Software Windows 11 insider
Crackling sound is HW issue in 90% cases with sound cards. Since I kinda collect and dissect them a lot. I had most of them. Crackling is latency issues due to some fault, mostly HW or HW conflict. If you don't hear it doesn't mean it is not there. The budget time is exceeded on some processes, or the driver is not compatible with latest WIN10 builds. Mostly none of them are.

Microsoft does humongous audio stack changes, and the time has ended for certain hardware to patch it through, as it needs new HW, it cannot be patched even. Software codec doesn't care.

Lately the only robust way of getting audio from PC is using HDMI. Then you can split of the data as you wish. I2S or DSD. Keep in mind that folks. USB also isn't the savior due to the same BAD driver reason and the fundamental architecture how it even works. Video signal with Audio is highest priority thread and it should go hand in hand like bullets, patching other ways through... nada Microsoft doesn't want it even really. The integrated sound does have direct HDA audio bus coming straight from the South Bridge, you cannot hook up your creative or xonar there, actually if you could, it would solve a shitload of driver problems.
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
21,606 (3.73/day)
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i7 2600k 4.4GHz :: i5 10400
Motherboard ASUS P8P67 Pro :: ASUS Prime H570-Plus
Cooling Cryorig M9 :: Stock
Memory 4x4GB DDR3 2133 :: 2x8GB DDR4 2400
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Crucial MX500 1TB, 2x1TB Seagate RAID 0 :: Mushkin Enhanced 60GB SSD, 3x4TB Seagate HDD RAID5
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) Creative X-Fi Titanium Fatal1ty Pro - Bose Companion 2 Series III :: None
Power Supply FSP Hydro GE 550w :: EVGA Supernova 550
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
How you gonna get HDMI audio without home theater equipment? Don't you need a receiver (which is also compatible with whatever resolution/refresh rate your monitor is)?
 

rtwjunkie

PC Gaming Enthusiast
Supporter
Joined
Jul 25, 2008
Messages
13,909 (2.68/day)
Location
Louisiana -Laissez les bons temps rouler!
System Name Bayou Phantom
Processor Core i7-8700k 4.4Ghz @ 1.18v
Motherboard ASRock Z390 Phantom Gaming 6
Cooling All air: 2x140mm Fractal exhaust; 3x 140mm Cougar Intake; Enermax T40F Black CPU cooler
Memory 2x 16GB Mushkin Redline DDR-4 3200
Video Card(s) EVGA RTX 2080 Ti Xc
Storage 1x 500 MX500 SSD; 2x 6TB WD Black; 1x 4TB WD Black; 1x400GB VelRptr; 1x 4TB WD Blue storage (eSATA)
Display(s) HP 27q 27" IPS @ 2560 x 1440
Case Fractal Design Define R4 Black w/Titanium front -windowed
Audio Device(s) Soundblaster Z
Power Supply Seasonic X-850
Mouse Coolermaster Sentinel III (large palm grip!)
Keyboard Logitech G610 Orion mechanical (Cherry Brown switches)
Software Windows 10 Pro 64-bit (Start10 & Fences 3.0 installed)
How you gonna get HDMI audio without home theater equipment? Don't you need a receiver (which is also compatible with whatever resolution/refresh rate your monitor is)?
Simply run an hdmi cable from htpc to tv is how I get my hdmi audio.
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
21,606 (3.73/day)
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i7 2600k 4.4GHz :: i5 10400
Motherboard ASUS P8P67 Pro :: ASUS Prime H570-Plus
Cooling Cryorig M9 :: Stock
Memory 4x4GB DDR3 2133 :: 2x8GB DDR4 2400
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Crucial MX500 1TB, 2x1TB Seagate RAID 0 :: Mushkin Enhanced 60GB SSD, 3x4TB Seagate HDD RAID5
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) Creative X-Fi Titanium Fatal1ty Pro - Bose Companion 2 Series III :: None
Power Supply FSP Hydro GE 550w :: EVGA Supernova 550
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
That works, if you're either okay with using the usually crappy TV speakers or if your TV has an optical out or something... but it's certainly an obstacle for any gaming computer. You still need a receiver that plays nice with your monitor (if you have >1080p60, you're eternally waiting on expensive receivers that support what you want) and then hook up whatever speakers you want to your receiver. My problem with this is having to find and purchase a specific (and expensive) receiver that meets or is superior to your monitor's resolution and refresh rate. Analog was easy. I once happened across a cd/cassette player (with AM/FM radio) that looked like it probably came from the late 80s. It had a single auxiliary stereo input which I connected to my PC. Worked great until the broken speaker I repaired broke again and I decided it was no longer worth messing around with...
 
Joined
Nov 18, 2010
Messages
6,135 (1.41/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor AMD RYZEN 9 5950X
Motherboard ASUS Strix X570-E
Cooling Custom Loop. Two 360ies + 280 rad. 8x Nidec Servo Gentle Typhoons. EK-Quantum Momentum monoblock.
Memory 4x8GB G.SKILL Trident Z RGB F4-4133C19D-16GTZR 14-16-12-30-44
Video Card(s) ASUS 1080 Ti SLI + water blocks
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB+ 1TB 980PRO
Display(s) Philips PHL BDM3270 + Acer XV242Y
Case Lian Li O11 Dynamic EVO
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer BlackWidow V3 - Yellow Switch
Software Windows 11 insider
There are splitter devices as I said to I2s of DSD or even DACs accepting HDMI...
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
21,606 (3.73/day)
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i7 2600k 4.4GHz :: i5 10400
Motherboard ASUS P8P67 Pro :: ASUS Prime H570-Plus
Cooling Cryorig M9 :: Stock
Memory 4x4GB DDR3 2133 :: 2x8GB DDR4 2400
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Crucial MX500 1TB, 2x1TB Seagate RAID 0 :: Mushkin Enhanced 60GB SSD, 3x4TB Seagate HDD RAID5
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) Creative X-Fi Titanium Fatal1ty Pro - Bose Companion 2 Series III :: None
Power Supply FSP Hydro GE 550w :: EVGA Supernova 550
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
What/where are these devices you speak of? This is the first I've heard of it. Sounds like it would be great for HDMI audio.
 
Joined
Nov 18, 2010
Messages
6,135 (1.41/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor AMD RYZEN 9 5950X
Motherboard ASUS Strix X570-E
Cooling Custom Loop. Two 360ies + 280 rad. 8x Nidec Servo Gentle Typhoons. EK-Quantum Momentum monoblock.
Memory 4x8GB G.SKILL Trident Z RGB F4-4133C19D-16GTZR 14-16-12-30-44
Video Card(s) ASUS 1080 Ti SLI + water blocks
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB+ 1TB 980PRO
Display(s) Philips PHL BDM3270 + Acer XV242Y
Case Lian Li O11 Dynamic EVO
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer BlackWidow V3 - Yellow Switch
Software Windows 11 insider
What/where are these devices you speak of? This is the first I've heard of it. Sounds like it would be great for HDMI audio.

NAD M51 for example as a consumer device. It is old thou, there are already XMOS based modules that does HDMI input.
 
Joined
Jul 5, 2013
Messages
20,699 (6.12/day)
Location
USA
How you gonna get HDMI audio without home theater equipment? Don't you need a receiver (which is also compatible with whatever resolution/refresh rate your monitor is)?
Most TV's/Displays have an audio out that can be hooked up to your speakers of choice. Basically the display acts as an audio pass-through.
 
Joined
Jun 10, 2005
Messages
1,775 (0.28/day)
Location
Singapore
System Name Half-fucked overclockedd
Processor Intel Core i7 2600k 3.40Ghz @ 4.20Ghz
Motherboard Gigabyte P67 UD7 B3
Cooling Antec Kuhler H2O 920
Memory G.Skill RipjawsX DDR3 8GB X2 1866Mhz (Model F3-2133C9D-16GXH)
Video Card(s) Gigabyte AORUS 1080Ti Extreme Edition
Storage Samsung 840 Pro 256GB / Western Digital Black Cavier 2TB X2
Display(s) Dell U2715H 2560X1440
Case NZXT Phantom
Audio Device(s) Creative Sound Blaster Recon3D Fatal1ty Professional
Power Supply Cooler Master Silent Pro Gold 1000W
Mouse Logitech G510
Keyboard Tesoro Excalibur Spectrum
Software Microsoft Windows 10 Professional
It seems you are not the only one with the same issue. I am currently running a Z370 Gigabyte Aorus Gaming 7 which comes with an Onboard x-fi card. I seem to have occasional crackling sound appearing. And it is definitely not my speaker issue cause i re-ran the same music twice and the crackling sounds appeared at two different timings.

One thing that worked temporarily for me was when i re-installed the driver and ran my computer for the first time. Subsequently after shutting down and then switching it on again, the same issue repeats.

On doing google search i can hardly find any solutions.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,418 (6.71/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Actually, I haven't had any serious Soundblaster driver issues since the early Windows XP days.

Windows 98SE

It seems you are not the only one with the same issue. I am currently running a Z370 Gigabyte Aorus Gaming 7 which comes with an Onboard x-fi card. I seem to have occasional crackling sound appearing. And it is definitely not my speaker issue cause i re-ran the same music twice and the crackling sounds appeared at two different timings.

One thing that worked temporarily for me was when i re-installed the driver and ran my computer for the first time. Subsequently after shutting down and then switching it on again, the same issue repeats.

On doing google search i can hardly find any solutions.

Try the card in another machine, if problem stops your motherboard or PSU, speakers could be defective.
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
21,606 (3.73/day)
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i7 2600k 4.4GHz :: i5 10400
Motherboard ASUS P8P67 Pro :: ASUS Prime H570-Plus
Cooling Cryorig M9 :: Stock
Memory 4x4GB DDR3 2133 :: 2x8GB DDR4 2400
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Crucial MX500 1TB, 2x1TB Seagate RAID 0 :: Mushkin Enhanced 60GB SSD, 3x4TB Seagate HDD RAID5
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) Creative X-Fi Titanium Fatal1ty Pro - Bose Companion 2 Series III :: None
Power Supply FSP Hydro GE 550w :: EVGA Supernova 550
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
He said it has onboard x-fi... good luck taking that "card" to another machine :laugh:
 
Joined
May 4, 2011
Messages
633 (0.15/day)
System Name Smooth-Operator
Processor AMD Ryzen 7 3800x
Motherboard Asrock x570 Taichi
Cooling AMD Wraith Prism
Memory 2x16GB 3200MHz CL16@CL14 DDR4
Video Card(s) Sapphire Radeon RX 580 8GB NITRO+
Storage 2x4TB WD HGST 7K6 7200RPM 256MB
Display(s) Samsung S24E370DL 24" IPS Freesync 75Hz
Case Fractal Design Focus G Window Blue
Audio Device(s) Creative X-Fi Titanium PCIe x1
Power Supply Corsair HX850 80+ Platinum
Mouse Gigabyte Aorus M3
Keyboard Zalman ZM-K300M
Software Windows 10 x64 Enterprise/Ubuntu Budgie amd64
I have to repeat it: in case of windows 10 problem is caused by latest build: 1803, if this is what you have installed then you have temporarily to roll back to 1709. That's what i did and sound distortion stopped. I'm curious how next build will perform with x-fi soundcards.
 
Joined
Oct 1, 2010
Messages
2,325 (0.53/day)
Location
Marlow, ENGLAND
System Name Chachamaru-IV | Retro Battlestation
Processor AMD Ryzen 9 5900X | Intel Pentium II 450MHz
Motherboard ASUS ROG STRIX X570-F Gaming | MSI MS-6116 (Intel 440BX chipset)
Cooling Noctua NH-D15 SE-AM4
Memory 32GB Corsair DDR4-3000 (16-20-20-38)| 512MB PC133 SDRAM
Video Card(s) MSI GeForce 1070 Gaming Z | 3dfx Voodoo3 3000
Storage 1TB WD_Black SN850 NVME SSD (OS), Toshiba 3TB (Storage), Toshiba 3TB (Steam)
Display(s) Samsung Odyssey G5 27" @ 1440p144 & Dell P2312H @ 1080p60
Case SilverStone Seta A1 | Beige box
Audio Device(s) Creative Sound Blaster Z (Speakers), Logitech G935 7.1 headset | Sound Blaster AWE64
Power Supply EVGA Supernova 750 G2 | 250W ASETEC
Mouse Razer DeathAdder V2 Pro | Microsoft Serial Mouse v2.0A
Keyboard Vortex Race3 | Dell AT102W
Software Microsoft Windows 11 Pro | Microsoft Windows 98SE
I've had problems similar to this with my last three Sound Blaster cards. X-Fi, Audigy Rx, Z. The only way I found to fix it was to clean out the drivers and reinstall them from scratch. That would stop any issues for several months, but they'd always come back again. Creative's drivers really suck.
 
Top