• We've upgraded our forums. Please post any issues/requests in this thread.

Steam reinstalling to HDD that isn't there, fails everytime.

Joined
Jan 6, 2009
Messages
469 (0.14/day)
Likes
68
Location
Victoria, Australia
System Name Haswell Ranger
Processor Intel i5 4690K 4.2GHz
Motherboard ASUS Maximus VII Ranger
Cooling Corsair H80 Hydro Series Cooler
Memory 16GB DDR3 @ 1333MHz
Video Card(s) ASUS RX480 Strix 8GB @1350MHz
Storage OCZ Trion 100 240GB(OS) + 4TB HDD(s)
Display(s) Samsung SE790C 34" Ultra-wide/Curved 3440x1440p 60hz
Case Corsair 750D Obsidian
Audio Device(s) Onboard - Logitech Z-5500 Digital 5.1 Speaker System/Roccat Kave XTD 5.1 Headphones
Power Supply Corsair HX850i Modular
Mouse Logitech G700
Keyboard Logitech G510s
Software Windows 10 Pro 64bit
#1
Okay, on the weekend, my PC decided to off itself. Windows bootup sequence was corrupted, and my Steam drive fried itself. I managed to repair Windows with a Windows disc, but now every time I try to install Steam it keeps trying to install it onto the drive that died, and fails due to there no longer being that certain drive.

I've gone through with 'regedt32.exe' and deleted as many Steam related files I could find, hoping to kick it out of the "install only on this drive" state of mind. To no success.

So any help would be great, had a crap enough weekend with this happening, then my ISP blocking my net for 48hrs for DLing the new Stargate -.-'' only just got it back..

I am aware that formatting Windows would probably solve the issue, but I'd rather leave that for a 'worst case scenario' thing.

Also not much chance of getting a new HDD any time soon and simply naming that S: (name of previous drive) and hoping it all works out, though I might consider doing that since I need more space now and I only recently formatted, so I don't want to do it again >_>
 
Joined
Dec 27, 2007
Messages
8,506 (2.34/day)
Likes
2,072
Location
Kansas City
System Name The Dove Box Rev 2.0
Processor I7 5930k
Motherboard Asus X99
Cooling Custom water loop
Memory 4 x 4GB 3000 MHz DDR4
Video Card(s) 2x MSI 780 Ti's in SLI
Storage 500GB Samsung 850 PCIe SSD, 2x1TB WD Blacks, 1.2TB NAS
Display(s) 27" Asus 144Hz
Case Enermax Fulmo GT
Audio Device(s) ON BOARD FTW
Power Supply Thermaltake Toughpower 850W
Keyboard Logitech G510
Software Win 10 64x
#2
Dude thats crazy, have you tried posting Steam Forums? I have no idea what it might take to recover your games.

Harsh reality might just be to reformat and re-download it all. :(
 
Joined
Jan 6, 2009
Messages
469 (0.14/day)
Likes
68
Location
Victoria, Australia
System Name Haswell Ranger
Processor Intel i5 4690K 4.2GHz
Motherboard ASUS Maximus VII Ranger
Cooling Corsair H80 Hydro Series Cooler
Memory 16GB DDR3 @ 1333MHz
Video Card(s) ASUS RX480 Strix 8GB @1350MHz
Storage OCZ Trion 100 240GB(OS) + 4TB HDD(s)
Display(s) Samsung SE790C 34" Ultra-wide/Curved 3440x1440p 60hz
Case Corsair 750D Obsidian
Audio Device(s) Onboard - Logitech Z-5500 Digital 5.1 Speaker System/Roccat Kave XTD 5.1 Headphones
Power Supply Corsair HX850i Modular
Mouse Logitech G700
Keyboard Logitech G510s
Software Windows 10 Pro 64bit
#3
Dude thats crazy, have you tried posting Steam Forums? I have no idea what it might take to recover your games.

Harsh reality might just be to reformat and re-download it all. :(
Yeah I've posted there with a similar post, no response yet and knowing the Steam forums I'll probably never get one, or anything that's even remotely helpful.

Idm about having to re-DL all my games(I've got partial backup's on my Laptop), it's just trying to get Steam installed in the first place. And yeah, I'm prepared to format if required, I'd just rather not since I did only about a month ago.
 
Joined
Jan 6, 2009
Messages
469 (0.14/day)
Likes
68
Location
Victoria, Australia
System Name Haswell Ranger
Processor Intel i5 4690K 4.2GHz
Motherboard ASUS Maximus VII Ranger
Cooling Corsair H80 Hydro Series Cooler
Memory 16GB DDR3 @ 1333MHz
Video Card(s) ASUS RX480 Strix 8GB @1350MHz
Storage OCZ Trion 100 240GB(OS) + 4TB HDD(s)
Display(s) Samsung SE790C 34" Ultra-wide/Curved 3440x1440p 60hz
Case Corsair 750D Obsidian
Audio Device(s) Onboard - Logitech Z-5500 Digital 5.1 Speaker System/Roccat Kave XTD 5.1 Headphones
Power Supply Corsair HX850i Modular
Mouse Logitech G700
Keyboard Logitech G510s
Software Windows 10 Pro 64bit
#4
Joined
Dec 27, 2007
Messages
8,506 (2.34/day)
Likes
2,072
Location
Kansas City
System Name The Dove Box Rev 2.0
Processor I7 5930k
Motherboard Asus X99
Cooling Custom water loop
Memory 4 x 4GB 3000 MHz DDR4
Video Card(s) 2x MSI 780 Ti's in SLI
Storage 500GB Samsung 850 PCIe SSD, 2x1TB WD Blacks, 1.2TB NAS
Display(s) 27" Asus 144Hz
Case Enermax Fulmo GT
Audio Device(s) ON BOARD FTW
Power Supply Thermaltake Toughpower 850W
Keyboard Logitech G510
Software Win 10 64x
#5
See my suggestion worked like a charm :D //kidding

Sorry I couldn't help, but I'm glad it worked for you. I had a weird prob w/steam a while back. It would open, but no characters would appear for letters. I had to re-install fonts from Steam by copying and pasting and it worked out just fine.