• We've upgraded our forums. Please post any issues/requests in this thread.

Steam Won't Connect.

Joined
Jun 17, 2007
Messages
7,325 (1.91/day)
Likes
995
Location
C:\Program Files (x86)\Aphexdreamer\
System Name Unknown
Processor AMD Bulldozer FX8320 @ 4.4Ghz
Motherboard Asus Crosshair V
Cooling XSPC Raystorm 750 EX240 for CPU
Memory 8 GB CORSAIR Vengeance Red DDR3 RAM 1922mhz (10-11-9-27)
Video Card(s) XFX R9 290
Storage Samsung SSD 254GB and Western Digital Caviar Black 1TB 64MB Cache SATA 6.0Gb/s
Display(s) AOC 23" @ 1920x1080 + Asus 27" 1440p
Case HAF X
Audio Device(s) X Fi Titanium 5.1 Surround Sound
Power Supply 750 Watt PP&C Silencer Black
Software Windows 8.1 Pro 64-bit
#1
Was just downloading the Mafia II Demo in steam when I close my F@H GPU Client and my PC Freezes so I do a hard reboot.

Once my PC restarts and I go to launch Steam I get Steam cannot connect.

So I delete client registry.blob and it redownloads still same thing. I delete a few other things same thing. So I download steam installer.msi and run it to repair steam but it won't repair because it too comes up with a network issue.

Anyone have a clue?


 

Perseid

New Member
Joined
Jul 4, 2010
Messages
154 (0.06/day)
Likes
34
Location
Wisconsin, USA
Processor i7-870
Motherboard ASUS P7P55D-E Pro
Cooling Coolermaster Hyper 212
Memory 2x OCZ Special Ops 2GB DDR3 1600 (PC3 12800) 8-8-8-24
Video Card(s) Palit GTX 470
Storage Numerous 1.5 and 2 TB
Display(s) HP w2338h
Case NZXT Lexa S
Power Supply CORSAIR TX Series 950W
Software Windows 7
#2
Check to make sure Steam didn't get blocked by a firewall somewhere. Try to uninstall Steam first, then reinstall it.
 
Joined
Jun 17, 2007
Messages
7,325 (1.91/day)
Likes
995
Location
C:\Program Files (x86)\Aphexdreamer\
System Name Unknown
Processor AMD Bulldozer FX8320 @ 4.4Ghz
Motherboard Asus Crosshair V
Cooling XSPC Raystorm 750 EX240 for CPU
Memory 8 GB CORSAIR Vengeance Red DDR3 RAM 1922mhz (10-11-9-27)
Video Card(s) XFX R9 290
Storage Samsung SSD 254GB and Western Digital Caviar Black 1TB 64MB Cache SATA 6.0Gb/s
Display(s) AOC 23" @ 1920x1080 + Asus 27" 1440p
Case HAF X
Audio Device(s) X Fi Titanium 5.1 Surround Sound
Power Supply 750 Watt PP&C Silencer Black
Software Windows 8.1 Pro 64-bit
#3
Check to make sure Steam didn't get blocked by a firewall somewhere. Try to uninstall Steam first, then reinstall it.
Thanks. I backed up my steamapps and uninstalled and reinstalled steam and copied it back and it works now. Gave me a scare..