• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Subtle micro-stutter, input lag, floaty mouse feel

fatehasfans

New Member
Joined
Sep 29, 2020
Messages
15 (0.04/day)
I've had a problem with my newly built PC for about 2 years+ now. The computer just feels 'off', as though there is some kind of very subtle bottlenecking occurring. Also, I'm getting input lag on mouse and keyboard (i.e. there will be the occasional no click registration on mouse or keyboard but there may also be double clicks or keypresses and the mouse feels very off - like floaty/heavy/inconsistent). Everything else on the computer is fine, the machine loads up quickly, I can play games and watch films (though I notice a bit of stuttering on the films) but I will get very subtle stuttering in all games (and desktop) but apart from that no issues, audio is fine as is the running of normal programs. I mean if you weren't a gamer and didn't know any different you'd think there was nothing wrong but once you start playing games it becomes quite noticeable - hard to aim (with floaty mouse --> mouse feels like I'm dragging it across glass, fluctuating constantly between heavy to light movements, so it feels more heavy and sluggish than it should be - not light, crisp and responsive like normal along with bouts of micro-stuttering (esp when panning camera) and the occasional micro-spastication of animations (particularly in sport games) etc.

My specs:
- PSU = Corsair 1200
- Mobo = MSI Z390 A Pro
- 16GB DDR4 3000mhz (Corsair Vengeance)
- GFX = MSI GTX 1080Ti
- HDD = Samsung SSD
- Water cooled
- Monitor AOC 27G2 27 144hz using display port




I've listed some of what I've tried below..

- Reinstalled windows
- Deleted mouse files
- Tested new hardware (tested everything one by one) - except Ram (though I did buy 2x16GB sticks of same ram and nothing changed so I sent them back but I haven't tried different speed ram)
- Went through everything in bios - including flash etc etc
- Updated all drivers and even tried rolling back to previous drivers and older
- Mouse accel input code etc (accel 0/1 nonsense) + removed mouse drivers
- Tried new wall sockets + grounding
- Tested all Nvidia GFX settings - screen res, fixed Frame rate etc ..you name it I tried it
- Hpet timing and all that other fluff
- New keyboard and mouse (though that sort of falls under hardware)
- Windows optimization
- Checked performance, load, monitoring, heat, latency -- everything checks out fine

Problem still persists.

Now the thing is, trying the above things, particularly the bios and nvidia settings, do change the feel of the computer and the feel how games play (limiting frame-rates, v-sync, g-sync, reduce input lag option, etc etc) but the problem is it's only masking the issue because although the game changes slightly in some way the main problem is still underneath which is frustrating because you can achieve smoother outcomes but the input lag (keyboard and mouse and floaty mouse feel) the subtle stuttering/bottlenecking will still very much be there.


If anyone knows a solution or anything that helped please let me know because I want to take a hammer to my PC and I'm extremely depressed after spending a lot of money on creating this monster setup and its not even playable. Oh I also tried installing windows 7, same problem.


P.S. What makes it more frustrating is that to the naked eye everything appears fine, when my friend comes over he thinks nothing is wrong, but he's not a gamer. I also took it to get looked at by a computer shop but again they weren't gamers and they told me everything was fine, and that's the thing everything does seem fine (applications open as they should, videos play, music plays, everything works as normal) but when you move the mouse quickly and try to be precise it feels floaty and in games there feels like a micro-bottlenecking happening somewhere. Losing my mind here :'(


Any help would be greatly appreciated.
 
Last edited by a moderator:
Low quality post by Caring1
Joined
Oct 22, 2014
Messages
12,543 (4.95/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Contact the relevant Moderator and request your previous thread to be reopened.
There is no need to start another.
 
Top