• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

The Ultimate Realtek HD Audio Driver Mod for Windows 10

Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
whoa Dolby digital plus :D thanks!

Alan, I was wondering, is there any way of forcing the drivers to install DTS instead of Dolby Digital Live (5.1 Surround) for the default format in Windows 10 under Realtek Digital Output ?
Good. At the moment I still do not know any way to do this. But I'll search.
 
Joined
Nov 11, 2017
Messages
76 (0.03/day)
Alan, the DRIVERPACK #2 - WITH DOLBY DS1 - DOLBY DIGITAL PLUS HOME THEATER *has* DTS Interactive (5.1 Surround), as well as Dolby Digital Live (5.1 Surround) as choices for the default format in Windows 10!

First time ever I've seen both! Thanks!
 

karimis

New Member
Joined
Jan 22, 2019
Messages
4 (0.00/day)
Thank for the driver Alan, for sure you are doing a great work!
So i installed the driver, it installed fine. But though i select to install dolby i do not get that software shown in the images.. The Audio manager sure has the options to enable Dolby and Dolby Theater but that's it, only turn it on/off, i can not open any dolby window. Sound Blaster seems to install though and i can access the UI, though i do not have previous experience with it and do not know if it is worth using or not.. Definitely turning dolby on makes a difference in sound, i can hear it, but i cannot configure anything.
Is it something i am missing or doing wrong?

PS. I am not in my PC right now I am using the option names as i can remember them, so forgive me if they are not accurate enough.. :)
 

tonnydonovan

New Member
Joined
Jan 23, 2019
Messages
4 (0.00/day)
NEW REALTEK DRIVERS RELEASED
VERSION 6.0.1.8603 - HDA



GOOD RESORT

Hello Allan, I am install this mod . this is good working . but if i am plug my headphone in my laptop . the sound play in speaker too . double sound in speaker and headphone . I dont know what the problem . please help me .
 
Joined
Sep 17, 2017
Messages
41 (0.02/day)
Hello Allan, I am install this mod . this is good working . but if i am plug my headphone in my laptop . the sound play in speaker too . double sound in speaker and headphone . I dont know what the problem . please help me .
I also have this problem,and dont have option to separate headphones and speakers outputs.
I also now have Realtek Control Panel instead of Asus.
 

Xeonic

New Member
Joined
Jan 22, 2019
Messages
21 (0.01/day)
Hello to all. Can you help me with my Edifier G4 headphones? Can I connect them to Sound Blasterx 720?
They have usb output and built-in sound card.
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Thank for the driver Alan, for sure you are doing a great work!
So i installed the driver, it installed fine. But though i select to install dolby i do not get that software shown in the images.. The Audio manager sure has the options to enable Dolby and Dolby Theater but that's it, only turn it on/off, i can not open any dolby window. Sound Blaster seems to install though and i can access the UI, though i do not have previous experience with it and do not know if it is worth using or not.. Definitely turning dolby on makes a difference in sound, i can hear it, but i cannot configure anything.
Is it something i am missing or doing wrong?

PS. I am not in my PC right now I am using the option names as i can remember them, so forgive me if they are not accurate enough.. :)
The "Dolby" folder is located on your Desktop.

Hello to all. Can you help me with my Edifier G4 headphones? Can I connect them to Sound Blasterx 720?
They have usb output and built-in sound card.
In this case, we need to modify the driver for this built-in sound card.

@ScrooW @Aleksandar012 @tonnydonovan
Please use the file below to correct the problem.

1 - Open the RAR file and extract the file "rtkhdaud.dat" to "%systemroot%\System32\drivers" and replace. After that just restart the PC.
Sorry for the inconvenience.
In the next packages this will already be fixed.

Images:
1.JPG

2.JPG

3.JPG

Sorry for the inconvenience.
 

Attachments

  • rtkhdaud.rar
    246 bytes · Views: 779
Last edited:

Xeonic

New Member
Joined
Jan 22, 2019
Messages
21 (0.01/day)
The "Dolby" folder is located on your Desktop.


In this case, we need to modify the driver for this built-in sound card.

@ScrooW @Aleksandar012 @tonnydonovan
Please use the file below to correct the problem.

1 - Open the RAR file and extract the file "rtkhdaud.dat" to "%systemroot%\System32\drivers" and replace. After that just restart the PC.
Sorry for the inconvenience.
In the next packages this will already be fixed.

Images:
View attachment 114957
View attachment 114958
View attachment 114959
Sorry for the inconvenience.
Driver installed:
C-MEDIA Inc.
USB \ VID_0D8C & PID_0012 & REV_0100 & MI_00
USB \ VID_0D8C & PID_0012 & MI_00
Xear audio center from Edifier.
(EDIFIER 7.1 GAMING HEADSET)
What driver can I replace it with?
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Driver installed:
C-MEDIA Inc.
USB \ VID_0D8C & PID_0012 & REV_0100 & MI_00
USB \ VID_0D8C & PID_0012 & MI_00
Xear audio center from Edifier.
(EDIFIER 7.1 GAMING HEADSET)
What driver can I replace it with?
What's your operating system ?
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
@Xeonic Soon I will post here for you the modified driver.
 

tonnydonovan

New Member
Joined
Jan 23, 2019
Messages
4 (0.00/day)
The "Dolby" folder is located on your Desktop.


In this case, we need to modify the driver for this built-in sound card.

@ScrooW @Aleksandar012 @tonnydonovan
Please use the file below to correct the problem.

1 - Open the RAR file and extract the file "rtkhdaud.dat" to "%systemroot%\System32\drivers" and replace. After that just restart the PC.
Sorry for the inconvenience.
In the next packages this will already be fixed.

Images:
View attachment 114957
View attachment 114958
View attachment 114959
Sorry for the inconvenience.

work . thank you so much .

@Alan Finote this is work for windows 7 or just work for windows 10 ?

1548253037296.png
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Joined
Feb 2, 2011
Messages
561 (0.12/day)
System Name Salamander
Processor Ryzen 5 3600 @ 4.325ghz 1.206v
Motherboard Asrock X370 Taichi
Cooling EK Supremacy Evo | Black Ice Nemesis 360GTS XFlow | Noiseblocker BlackSilent Pro 120mm x 3
Memory Team T-Force Xtreem 2x8GB DDR4 3733 @ 3733mhz c16 1.4v | IF @ 1866mhz
Video Card(s) XFX RX-470 RS Single Fan flashed to RX-570 @ stock water-cooled
Storage Samsung 850 Evo 256gb M.2 | Crucial M4 128GB | WD Blue 1TB | WD Blue 500GB 2.5" | Toshiba 2TB 2.5"
Display(s) LG 27MP68VQ 27" 1920x1080 75hz IPS Freesync monitor
Case Fractal Design Define C
Audio Device(s) onboard
Power Supply Seasonic Prime Gold 650w
Mouse Steelseries Kana White
Keyboard Steelseries 6GV2 Cherry MX Black
Software Windows 10 Pro N
How do I revert back to the default realtek drivers? I already did DDU to completely remove the realtek mod and it seems there are still remnants persisting after installing the official drivers.

I downloaded and installed the official one from my motherboard's site and I remember precisely how the gui look. This look totally different

del.png
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
How do I revert back to the default realtek drivers? I already did DDU to completely remove the realtek mod and it seems there are still remnants persisting after installing the official drivers.

I downloaded and installed the official one from my motherboard's site and I remember precisely how the gui look. This look totally different

View attachment 114979
Go to the list of installed applications in settings, and search for "Realtek Advanced HD Audio". Then just uninstall.
 
Joined
Feb 2, 2011
Messages
561 (0.12/day)
System Name Salamander
Processor Ryzen 5 3600 @ 4.325ghz 1.206v
Motherboard Asrock X370 Taichi
Cooling EK Supremacy Evo | Black Ice Nemesis 360GTS XFlow | Noiseblocker BlackSilent Pro 120mm x 3
Memory Team T-Force Xtreem 2x8GB DDR4 3733 @ 3733mhz c16 1.4v | IF @ 1866mhz
Video Card(s) XFX RX-470 RS Single Fan flashed to RX-570 @ stock water-cooled
Storage Samsung 850 Evo 256gb M.2 | Crucial M4 128GB | WD Blue 1TB | WD Blue 500GB 2.5" | Toshiba 2TB 2.5"
Display(s) LG 27MP68VQ 27" 1920x1080 75hz IPS Freesync monitor
Case Fractal Design Define C
Audio Device(s) onboard
Power Supply Seasonic Prime Gold 650w
Mouse Steelseries Kana White
Keyboard Steelseries 6GV2 Cherry MX Black
Software Windows 10 Pro N
already did that now I'm getting random BSODs everytime I unplug my headphones from the front port audio
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
already did that now I'm getting random BSODs everytime I unplug my headphones from the front port audio
Go to "%systemroot%\System32\drivers" and delete the file "rtkhdaud.dat". If necessary, restart your computer.
But before that, note that there is an icon that looks like a folder in the upper right corner of your realtek panel. Go there and turn off the second option.
 
Joined
Feb 2, 2011
Messages
561 (0.12/day)
System Name Salamander
Processor Ryzen 5 3600 @ 4.325ghz 1.206v
Motherboard Asrock X370 Taichi
Cooling EK Supremacy Evo | Black Ice Nemesis 360GTS XFlow | Noiseblocker BlackSilent Pro 120mm x 3
Memory Team T-Force Xtreem 2x8GB DDR4 3733 @ 3733mhz c16 1.4v | IF @ 1866mhz
Video Card(s) XFX RX-470 RS Single Fan flashed to RX-570 @ stock water-cooled
Storage Samsung 850 Evo 256gb M.2 | Crucial M4 128GB | WD Blue 1TB | WD Blue 500GB 2.5" | Toshiba 2TB 2.5"
Display(s) LG 27MP68VQ 27" 1920x1080 75hz IPS Freesync monitor
Case Fractal Design Define C
Audio Device(s) onboard
Power Supply Seasonic Prime Gold 650w
Mouse Steelseries Kana White
Keyboard Steelseries 6GV2 Cherry MX Black
Software Windows 10 Pro N
Go to "%systemroot%\System32\drivers" and delete the file "rtkhdaud.dat". If necessary, restart your computer.
But before that, note that there is an icon that looks like a folder in the upper right corner of your realtek panel. Go there and turn off the second option.

Thanks for the quick reply. I just did a system restore. Got it all fixed now.
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Thanks for the quick reply. I just did a system restore. Got it all fixed now.
Dude, what was your problem exactly? I will be happy to assist you.
 
Joined
Feb 2, 2011
Messages
561 (0.12/day)
System Name Salamander
Processor Ryzen 5 3600 @ 4.325ghz 1.206v
Motherboard Asrock X370 Taichi
Cooling EK Supremacy Evo | Black Ice Nemesis 360GTS XFlow | Noiseblocker BlackSilent Pro 120mm x 3
Memory Team T-Force Xtreem 2x8GB DDR4 3733 @ 3733mhz c16 1.4v | IF @ 1866mhz
Video Card(s) XFX RX-470 RS Single Fan flashed to RX-570 @ stock water-cooled
Storage Samsung 850 Evo 256gb M.2 | Crucial M4 128GB | WD Blue 1TB | WD Blue 500GB 2.5" | Toshiba 2TB 2.5"
Display(s) LG 27MP68VQ 27" 1920x1080 75hz IPS Freesync monitor
Case Fractal Design Define C
Audio Device(s) onboard
Power Supply Seasonic Prime Gold 650w
Mouse Steelseries Kana White
Keyboard Steelseries 6GV2 Cherry MX Black
Software Windows 10 Pro N
Dude, what was your problem exactly? I will be happy to assist you.

Usually after I plugged my headphones in the front audio, my speakers plugged at the rear automatically gets disabled. With the modded drivers both my headphone and speaker works simultaneously. Also the sound coming out of my right speakers seems to be louder than on the left. I tested it on my headphones and it sound normal as it should be. I dunno could be my set-up? My board is using ALC 1220.
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
NEW LINKS OF RELEASED REALTEK DRIVERS...

FIXED THE PROBLEM REPORTED BY SOME MEMBERS OF THE FORUM, WHEREEVER, EVEN CONNECTING A HEADSET TO THE FONTAL PANEL ON THE PC OR TO THE PORT P2 OF THE NOTEBOOK, THE REAR PANEL CONTINUED SOON.


GOOD RESORT

Usually after I plugged my headphones in the front audio, my speakers plugged at the rear automatically gets disabled. With the modded drivers both my headphone and speaker works simultaneously. Also the sound coming out of my right speakers seems to be louder than on the left. I tested it on my headphones and it sound normal as it should be. I dunno could be my set-up? My board is using ALC 1220.
Well, my friend, I've just posted new driver package links in the post above where this problem has been fixed. Install it and once installed, restart your pc. Once this is done, go to the folder icon in the upper right corner of your realtek panel, and if the third option is unchecked, check it and you're done.
Check the images:
1.JPG

2.JPG

3.JPG
 
Last edited:
Top