• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Trident Z Lighting Control not detecting RAM in Slots and other issues...

Joined
Mar 15, 2019
Messages
163 (0.48/day)
Processor AMD Ryzen 9 3900X
Motherboard Gigabyte Aorus Master Rev 1.0
Cooling NZXT Kraken X72 360MM
Memory G.Skill Trident Z Neo 32GB (2x16GB) DDR4-3600MHz CL16
Video Card(s) Galax GeForce RTX 2080 Ti Hall of Fame
Storage Samsung 970 EVO Plus 1TB NVMe M.2
Display(s) Alienware AW3418DW 34" UltraWide QHD 120Hz IPS 1900R Curved G-Sync Gaming Monitor
Case Lian Li PC-O11 Dynamic XL Black Steel
Audio Device(s) OnBoard Audio
Power Supply Corsair RM850i 850W
Mouse Logitech G502 LightSpeed Wireless Gaming Mouse
Keyboard Corsair K70 RGB MK.2 Cherry MX Brown Mechanical Gaming Keyboard
Software Windows 10 Professional
Hi,

I have tried everything I can think of to get this working. It's a bit of a long winded situation that I will try and explain and I really hope someone can help.
Before we get in to it, I am aware that the gigabyte software is SH@# but we have no other software to use to control the mobo lighting.

So, yesterday I noticed that everytime I tried opening the RGB Fusion app, it would say "Please Wait..." and then just exit. the same would happen with the Trident Z lighting control Software.

So I started the whole troubleshooting saga and eventually

  • completely uninstalled ALL Gigabyte software and G.Skill Trident Z Lighting Control Software.
  • I used CCleaner to remove any remnants of files and cleaned up the registry as well.
  • I also manually scanned my entire drive for an anything related to RGB Fusion and G.Skill
  • I then reinstalled the RGB Fusion software and I was surprised to see it work. However, NOW I can only control my mobo RGB and not the RAM.
The RAM is now stuck on RAINBOW.

ram_stuck_in_rainbow.jpg

So I figured, well I don't care, I will anyway control the RAM using the Triden Z Lighting Control software but when I started the G.Skill app, it also opened now but shows NO RAM sticks to manage.

So then I realise that the RAM is now not being detected.

Trident_Z_Lighting_Control_Screenshot.png

And so I start becoming concerned that maybe CCleaner has borked my drivers or OS or something but then I realised that this all started BEFORE I touched CCleaner so.....
  • I shut the machine down, removed and reseated the RAM sticks and tried again....NOTHING
  • Then I shut the machine down, cleared the CMOS and reset the BIOS settings and tried again....NOTHING
  • I then ran sfc /scannow from the command line as administrator....NOTHING
  • I then ran DISM /Online /Cleanup-Image /ScanHealth from the command line as adminstrator....NOTHING
  • I tried REINSTALLING the Chipset drivers and reboot....NOTHING
Then I look over to the LED display on my Galax 2080 ti HOF and notice that the display info is not showing. So...
  • I check if the Xtreme Tuner software is running and it is.
  • So I open up the app and exit it and restart it and the LED display STILL shows NOTHING.
HOF_LED_Display.jpg

So now I am at a loss...I don't know where to from here....

Has anyone got ANY suggestions for me?? I would really appreciate someones help here.

EDIT: So some news, Reinstalling the Xtreme Tuner for the Galax 2080ti HOF GPU seems to have resolved the LED Display issue.
so 1 down...

FINALUPDATE: is the following for any future people having the same problem.

I was ready to reinstall my windows when I read somewhere that someone downloaded the ASUS Aura software and was able to control their RAM Modules that way.

So I figured that if I was going to reinstall, I had nothing to lose....

It worked! I can't believe it. Running the ASUS Aura software to control my G.Skill RAM on a Gigabyte Aorus Master.

GG!!! o_O
 
Last edited:
Top