• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Wi-Fi adapter disappears with Clear Linux install

Joined
Jul 2, 2008
Messages
7,350 (1.77/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit
System was running Mint, but I wanted to try Clear as I was having problems with that Mint install. Booted from live USB AND IT SAW (and used) THE WI-FI ADAPTER which just happens to be an Intel adapter. Once I installed and rebooted, Clear can not find the adapter!

Edit: IIRC, I had the same problem with Tumbleweed.
 
Last edited:

johnspack

Here For Good!
Supporter
Joined
Oct 6, 2007
Messages
5,487 (1.24/day)
Location
Nelson B.C. Canada
System Name Blacknet
Processor E5-1680v2 Xeon
Motherboard Asus P9X79 Pro
Cooling Noctua NH-D14/7case fans
Memory 32gb Gskill 1866 Cas9
Video Card(s) EVGA FTW GTX 980 Ti ACX 2.0+
Storage Toshiba 3TB, x300 Toshiba 5TB, 2x EVO 850 250GB, EVO 860 500GB
Display(s) 24" LG 24GL600F 144HZ, 23" Asus VZ239H IPS
Case Antec 1200
Audio Device(s) Asus Xonar MKII+ AKG Q701 Studio Monitors
Power Supply XFX XTR 750 Gold
Mouse Logitech G900 Chaos Spectrum
Keyboard Ducky One 2 RGB
Software Kubuntu 19.10
Benchmark Scores It's linux baby!
Wow, I just installed clear in a vm. Don't bother. Really. Kubuntu. Seriously!
Make sure to enable 3rd party sources during install. Your driver will be there.
 
Joined
Jul 2, 2008
Messages
7,350 (1.77/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit
I also just noticed that although I'm seeing 8GB in BIOS, the OS is only seeing 3.9GB.
 

johnspack

Here For Good!
Supporter
Joined
Oct 6, 2007
Messages
5,487 (1.24/day)
Location
Nelson B.C. Canada
System Name Blacknet
Processor E5-1680v2 Xeon
Motherboard Asus P9X79 Pro
Cooling Noctua NH-D14/7case fans
Memory 32gb Gskill 1866 Cas9
Video Card(s) EVGA FTW GTX 980 Ti ACX 2.0+
Storage Toshiba 3TB, x300 Toshiba 5TB, 2x EVO 850 250GB, EVO 860 500GB
Display(s) 24" LG 24GL600F 144HZ, 23" Asus VZ239H IPS
Case Antec 1200
Audio Device(s) Asus Xonar MKII+ AKG Q701 Studio Monitors
Power Supply XFX XTR 750 Gold
Mouse Logitech G900 Chaos Spectrum
Keyboard Ducky One 2 RGB
Software Kubuntu 19.10
Benchmark Scores It's linux baby!
Yeah, I noticed weird things right off the bat with this one. Huge issues with virtualbox video drivers for one, it seems to want to use it's own driver base. I really wouldn't bother with it. I also had issues with mint before. It's why I do Kubuntu now. Try it, you won't regret it! https://kubuntu.org/getkubuntu/
 
Joined
Nov 11, 2004
Messages
4,536 (0.83/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard Gigabyte X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Audio Device(s) Corsair Virtuoso SE
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
I also just noticed that although I'm seeing 8GB in BIOS, the OS is only seeing 3.9GB.
32-bit vs 64-bit OS...

Also, you might need a third party non open source binary blob/firmware for the Wi-Fi to work.
 
Joined
Jul 26, 2019
Messages
131 (1.10/day)
Processor R7 1700 non-X @ 4.0 GHz
Motherboard Gigabyte AORUS Gaming 5
Cooling Noctua
Memory 32 GB 3200 MT/s CL16
Video Card(s) Sapphire Vega 64
Storage 2x 500 GB SSD, 2x 3 TB HDD
Case Silverstone FT02
Software Manjaro Linux, W10 if I have to
Clear linux is really a development platform, not a daily use OS. Anyway check what your wifi hardware is and do a search, someone probably has a fix.
 
Joined
Jul 2, 2008
Messages
7,350 (1.77/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit
Verified that it is running 64 bit.
The Wi-Fi adapter is Intel based like this: https://www.newegg.com/gigabyte-model-gc-wb867d-i/p/N82E16813995032
I think I have a hardware problem, not an OS problem.
I'm not trying this distro for desktop use, I'm after the performance that phoronix.com has documented so that I can get the most out of WCG.
 
Joined
Jun 2, 2017
Messages
1,500 (1.66/day)
System Name Best AMD Computer
Processor AMD TR4 1920X
Motherboard MSI X399 SLI Plus
Cooling Alphacool Eisbaer 420 x2 Noctua NHU-14S TR4
Memory Gskill RIpjaws 4 3000MHZ 48GB
Video Card(s) Sapphire Vega 64 Nitro, Gigabyte Vega 64 Gaming OC
Storage 6 x NVME 480 GB, 2 x SSD 2TB, 5TB HDD, 2 TB HDD, 2x 2TB SSHD
Display(s) Acer 49BQ0k 4K monitor
Case Thermaltake Core X9
Audio Device(s) Corsair Void Pro, Logitch Z523 5.1
Power Supply Corsair HX1200!
Mouse Logitech g7 gaming mouse
Keyboard Logitech G510
Software Windows 10 Pro 64 Steam. GOG, Uplay, Origin
Benchmark Scores Firestrike: 24955 Time Spy: 13500
Not that it should be a problem with yours or maybe it is a driver issue. I recently refreshed my Windows and my Intel AX200 was not recognized. I had to download the drivers from Intel and install them for the adapter to be recognized.
 

johnspack

Here For Good!
Supporter
Joined
Oct 6, 2007
Messages
5,487 (1.24/day)
Location
Nelson B.C. Canada
System Name Blacknet
Processor E5-1680v2 Xeon
Motherboard Asus P9X79 Pro
Cooling Noctua NH-D14/7case fans
Memory 32gb Gskill 1866 Cas9
Video Card(s) EVGA FTW GTX 980 Ti ACX 2.0+
Storage Toshiba 3TB, x300 Toshiba 5TB, 2x EVO 850 250GB, EVO 860 500GB
Display(s) 24" LG 24GL600F 144HZ, 23" Asus VZ239H IPS
Case Antec 1200
Audio Device(s) Asus Xonar MKII+ AKG Q701 Studio Monitors
Power Supply XFX XTR 750 Gold
Mouse Logitech G900 Chaos Spectrum
Keyboard Ducky One 2 RGB
Software Kubuntu 19.10
Benchmark Scores It's linux baby!
Again, Ill say Kubuntu. I've tested over 30 distros over 2 years because I needed to replace my ms obsession since dos 3.1... only old people will get that...
I've tried mint, yeah it's cute, but breaks apart quickly when you push it, Kubuntu is faster, more optimized, and can be configured far more.
I used to like OpenSuse, but it's far too constrained, and Debian is nice if you have to time to f with it. Bsd is meh. Other distros, why bother.
 
Top