• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Win11 doesn't work with my 5GHz network

Joined
Feb 18, 2005
Messages
5,212 (0.75/day)
Location
Ikenai borderline!
i doubt OP uses WEP. as about WPA2/3, win11 could use EZ both, BUT mediatek MAYBE could have issues with wpa3, if it's there lmfao. ax201 is rock solid lol
I have the exact same WiFi card as OP and no issues with it connecting to a WPA3 router (TP-Link AXE5400). But I'm still on Windows 10.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
I'm going to stay on WPA2-TKIP to maintain compatibility with other people's devices that also use this network. WPA3 is for later. The main thing right now is to be able to use 5GHz with this computer - it doesn't have a direct LAN cable to the router which is in another room.
 
Joined
Oct 2, 2020
Messages
569 (0.46/day)
System Name ASUS TUF F15
Processor Intel Core i5-10300H
Motherboard ASUS FX506LHB
Cooling Laptop built-in cooling lol
Memory 24GB @ 2933 Dual Channel
Video Card(s) Intel UHD & Nvidia GTX 1650 Mobile
Storage WD Black SN770 NVMe 1TB PCIe 4.0
Display(s) Dell 27 4K Monitor S2721QS; Samsung Odyssey G55 Curved 2K 144 Hz LC27G55TQWRXEN
Audio Device(s) LOGITECH 2.1-channel
Power Supply ASUS 180W PSU (from more powerful ASUS TUF DASH F15 lol)
Mouse Logitech G604
Keyboard SteelSeries Apex 7 TKL
Software Windows 11 Pro
I'm going to stay on WPA2-TKIP to maintain compatibility with other people's devices that also use this network. WPA3 is for later. The main thing right now is to be able to use 5GHz with this computer - it doesn't have a direct LAN cable to the router which is in another room.
i did 2 networks - 2.4 wpa2 for olders, wpa3 5.0 for normal (new)... lol
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
So, new router is bought, installed, and working great. My devices also accepted the new WPA3 network with no complaints. Most importantly, the Windows 11 gods are happy.

One question though: I have observed slow download speeds on my Windows 10 laptop on the new network. Wireless-only, of course (no built-in Ethernet), but instead of getting 200/200 symmetrical that is my connection, I'm getting something like 60/200.

Anyone else experienced something similar?
 
Joined
Aug 20, 2007
Messages
20,582 (3.41/day)
System Name Pioneer
Processor Ryzen R9 7950X
Motherboard GIGABYTE Aorus Elite X670 AX
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory 64GB (4x 16GB) G.Skill Flare X5 @ DDR5-6000 CL30
Video Card(s) XFX RX 7900 XTX Speedster Merc 310
Storage 2x Crucial P5 Plus 2TB PCIe 4.0 NVMe SSDs
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) TOSLINK->Schiit Modi MB->Asgard 2 DAC Amp->AKG Pro K712 Headphones or HDMI->B9 OLED
Power Supply FSP Hydro Ti Pro 850W
Mouse Logitech G305 Lightspeed Wireless
Keyboard WASD Code v3 with Cherry Green keyswitches
Software Windows 11 Enterprise (legit), Gentoo Linux x64
Anyone else experienced something similar?
No, can't say I have, but just for additional data, is that with the 2.4 or 5Ghz band?
 
Joined
Feb 22, 2022
Messages
486 (0.67/day)
Processor AMD Ryzen 7 5800X3D
Motherboard Asus Crosshair VIII Dark Hero
Cooling Custom Watercooling
Memory G.Skill Trident Z Royal 2x16GB
Video Card(s) MSi RTX 3080ti Suprim X
Storage 2TB Corsair MP600 PRO Hydro X
Display(s) Samsung G7 27" x2
Audio Device(s) Sound Blaster ZxR
Power Supply Be Quiet! Dark Power Pro 12 1500W
Mouse Logitech G903
Keyboard Steelseries Apex Pro
So, new router is bought, installed, and working great. My devices also accepted the new WPA3 network with no complaints. Most importantly, the Windows 11 gods are happy.

One question though: I have observed slow download speeds on my Windows 10 laptop on the new network. Wireless-only, of course (no built-in Ethernet), but instead of getting 200/200 symmetrical that is my connection, I'm getting something like 60/200.

Anyone else experienced something similar?
First thought is device driver. Re-install/upgrade that and test again.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
3,071 (0.46/day)
Making sure you're using the latest driver for the WiFi controller.

In the router, ensure you have the correct password for 5GHz and its AP settings are standard.

Try to switch 5GHz channels (DFS and regular) and bandwidth. Ensure other devices can connect to the 5GHz network so you know there is nothing wrong with it.

Its probably a driver issue and you may need to seek the latest one. I suggest looking on Station-Drivers and Windows Update Catalog website.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
It's not the driver - when I change the security from WPA3 to WPA2 (actually using WPA2/WPA3-Personal, make of that what you will), I start getting the expected speed again.

I'm using Intel's Driver Support Assistant, so the drivers remain up-to-date.
 

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
3,071 (0.46/day)
It's not the driver - when I change the security from WPA3 to WPA2 (actually using WPA2/WPA3-Personal, make of that what you will), I start getting the expected speed again.

I'm using Intel's Driver Support Assistant, so the drivers remain up-to-date.

So your WiFi controller doesn't really support WPA3. Stick with WPA2 or get WiFI PCIe card.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
No, thanks, what I have is good enough.
 
Joined
Aug 20, 2007
Messages
20,582 (3.41/day)
System Name Pioneer
Processor Ryzen R9 7950X
Motherboard GIGABYTE Aorus Elite X670 AX
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory 64GB (4x 16GB) G.Skill Flare X5 @ DDR5-6000 CL30
Video Card(s) XFX RX 7900 XTX Speedster Merc 310
Storage 2x Crucial P5 Plus 2TB PCIe 4.0 NVMe SSDs
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) TOSLINK->Schiit Modi MB->Asgard 2 DAC Amp->AKG Pro K712 Headphones or HDMI->B9 OLED
Power Supply FSP Hydro Ti Pro 850W
Mouse Logitech G305 Lightspeed Wireless
Keyboard WASD Code v3 with Cherry Green keyswitches
Software Windows 11 Enterprise (legit), Gentoo Linux x64
Yeah, that does not sound like something that is a hardware issue to me either. If it didn't like WPA3 it would not connect, IMO. Of course, I could be wrong, but this sounds like some kind of driver bug or something. Maybe try some other (possibly older?) versions of your client card driver? Just spitballing ideas.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
I'll try some stuff later but as it's not Windows 11 and I am not seeing any immediate problems after going to WPA2/WPA3 I'm not in any hurry.
I must say though, this new router is impressive, and my desktop's card is performing very well with it, now that it's done complaining about security.
Even though I'm behind a wall (and a metal cupboard) it's performing as if I were right next to the router.
 
Joined
Jul 5, 2013
Messages
25,387 (6.54/day)
Location
USA
So, new router is bought, installed, and working great. My devices also accepted the new WPA3 network with no complaints. Most importantly, the Windows 11 gods are happy.
I'll try some stuff later but as it's not Windows 11 and I am not seeing any immediate problems after going to WPA2/WPA3 I'm not in any hurry.
I must say though, this new router is impressive, and my desktop's card is performing very well with it, now that it's done complaining about security.
Even though I'm behind a wall (and a metal cupboard) it's performing as if I were right next to the router.
So which model did you settle on?

One question though: I have observed slow download speeds on my Windows 10 laptop on the new network. Wireless-only, of course (no built-in Ethernet), but instead of getting 200/200 symmetrical that is my connection, I'm getting something like 60/200.

Anyone else experienced something similar?
This could be the channel you're using for the 5GHZ. Try a different channel and see of that helps.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
So which model did you settle on?
Asus RT-AX53U. Cost $82.
 
Joined
Jan 1, 2021
Messages
1,066 (0.93/day)
System Name The Sparing-No-Expense Build
Processor Ryzen 5 5600X
Motherboard Asus ROG Strix X570-E Gaming Wifi II
Cooling Noctua NH-U12S chromax.black
Memory 32GB: 2x16GB Patriot Viper Steel 3600MHz C18
Video Card(s) NVIDIA RTX 3060Ti Founder's Edition
Storage 500GB 970 Evo Plus NVMe, 2TB Crucial MX500
Display(s) AOC C24G1 144Hz 24" 1080p Monitor
Case Lian Li O11 Dynamic EVO White
Power Supply Seasonic X-650 Gold PSU (SS-650KM3)
Software Windows 11 Home 64-bit
Yeah, it's a bit out of league for what people spend for a router here, which is usually $15-$20.

Most of it is Chinese crap, the rest is what I was using before.
 
Top