Wednesday, April 18th 2007

ATI Catalyst 7.4 Display Driver Released

AMD/ATI has released new official drivers for ATI based video cards. This release of Catalyst has improved OpenGL performance under the Microsoft Vista operating system for all Radeon X1000 series of products, in both single card and hardware CrossFire configurations. Typical improvements of 15% or more can be seen in games such as Doom 3, Quake 4 and Prey, with enthusiast class of products seeing improvements of 30% or more. This release of Catalyst also adds the Avivo Video Converter for Windows Vista (32-bit). Head over the AMD/ATI download section and select the proper Catalyst driver for your operating system and video card.Source: AMD/ATI
Add your own comment

33 Comments on ATI Catalyst 7.4 Display Driver Released

#1
Stryder75
Pinchy said:
Tried 7.4 from 7.2

My only test, CS:Source, and i went from 151.8 FPS to 150.6FPS. Huge diff :D

Hmmm, tested FEAR...

7.4:
Min:26
Average:56
Max:137

7.2:
Min:26
Average:57
Max:138


Nice 15-30% increase :wtf: :p
From what I have read, the performance increases are only really seen in Open GL games (Doom 3, Quake 4, Prey). If you don't play those, lol. They did fix some bugs with overdrive and color curves in CCC. (I got all this from the release notes). I am running 7.2 after 7.3 gave me the BSOD's.
Posted on Reply
#2
DRDNA
I am not sure if I even want to try the 7.4's ,Like the one guy posted 6.3's were the snit!I have not had a performance increases since 6.11's:o

Off topic but Strider's aviar has that familure look to it.
Posted on Reply
#4
mullered07
i dont want a perf increase i want stable fookin drivers with my x1950pro and my rig and 7.3 couldnt provide that but 7.4 looks good so far, and at least they havent give me any errors bsod or others(so far :wtf: ) so im sticking with. :toast:
Posted on Reply
#5
Joshmcmillan
I'm same as mullered I havn't even played a game since I got 7.4, but It did fix the CCC bug were I couldn't even go into it,a screen flickering problem I had(not sure for sure yet coz it didn't do it all the time but it hasn't done it so far) and I havn't got any blue screens of death but once again with 7.3 I got 2 in like 2 weeks so it's too early to say wether 7.4 fixed that or not.
Posted on Reply
#6
ktr
hmmm...i cannot seem to play any video on my comp any more. i get sound, but no video...
Posted on Reply
#7
Joshmcmillan
Hmm,,I'm check if I can maybe it's the 7.4 driver........Yep Godfather trailer and southpark still working.
Posted on Reply
#8
ktr
i just installed the good old 6.9 and everything is working fine now...
Posted on Reply