• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

3700X Memory Issue

Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
So, today is not my day. The 3700X is running and I am trying to get the specs dialed in.

So I have this kit of mem: https://www.newegg.com/g-skill-32gb-288-pin-ddr4-sdram/p/N82E16820232861
3700X
X570 Taichi

I can't for life of me get it to boot on anything other than 3600 16 19 19 19 39 with IF uncoupled at 1600. Anything else gives me a 0x07 on DrDebug which appears to be a lock after microcode (and not in my manual).

Sigh...
 
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
07 typically occurs when there's a CPU error that can't allow it to go further during POST.

What are you trying to run it at? I would try running your IF coupled at 1800. Should be doable.
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
07 typically occurs when there's a CPU error that can't allow it to go further during POST.

What are you trying to run it at? I would try running your IF coupled at 1800. Should be doable.
Negative. It POSTS and then dies and I have to hard power down and clear cmos. If I don't run 3600 16 19 19 19 39 with IF uncoupled at 1600 then I pretty much can't boot.
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
Might have to wait for AsRock to improved compatibility. They only list the Royals for 2/4 and OC
They do also list Trident Z which is basically what these are.

While also superficial and likely not useful, my CPU scored terribly in CPUZ bench lol
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
What sort of voltages are you running on the CPU?
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
What sort of voltages are you running on the CPU?
Everything is on auto at the moment. I literally finished putting it together Monday night and just got some stuff installed on it yesterday. First day of tweaking was today...:(

Edit: So far the highest boost I have is 4245mhz. I am on the newest BIOS as well.

Welp, I now can no longer boot unless the memory is on 2133.

Well, I made it back to windows again. Enough for tonight
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,908 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Nov 11, 2004
Messages
4,514 (0.82/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard Gigabyte X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Audio Device(s) Corsair Virtuoso SE
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
07 typically occurs when there's a CPU error that can't allow it to go further during POST.

What are you trying to run it at? I would try running your IF coupled at 1800. Should be doable.
That's not a CPU error, 07 is memory/memory controller related. It generally means that the memory controller doesn't accept the memory timings, but it might be a range of other issues from what I've been told by a mate at a motherboard manufacturer.

So far, from what I have seen, this has only been an issue with Gigabyte and MSI boards, but it seems now also ASRock. Most people with this issue have RMA:ed their CPUs in the end and that have solved the problem. It doesn't appear to be a board issue. Also, most people with this issue have had to do a fresh UEFI flash to get the boards to boot again after it happens.

What Agesa is the board on? If it's not on 1.0.0.3 ABBA, this could be part of the problem, so make sure the UEFI is updated to the latest version.

Also, get Thaiphoon burner and the DRAM Calculator to see what they spit out about your RAM.

From what I can tell, it's Hynix CJR, which should work fine with Ryzen 3000, at least based on my own experience, although my modules are from Patriot, not G.Skill.
Looks like they can run at the same timings as my modules, based on this review https://www.newegg.com/Product/SingleProductReview?ReviewID=10258805
As such, I can only guess two things, CPU or UEFI related problem.
 
Last edited:
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
ASUS has the D7 (or is it 07?) error too. I get it when pushing the IF too far. It still cannot recover itself, needs a manual reset.
 
Joined
Nov 11, 2004
Messages
4,514 (0.82/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard Gigabyte X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Audio Device(s) Corsair Virtuoso SE
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
ASUS has the D7 (or is it 07?) error too. I get it when pushing the IF too far. It still cannot recover itself, needs a manual reset.
Right, but you're getting it for an entirely different reason. A lot of people are seemingly getting the 07 error at random and the only way to recover for a lot of people, has been to use the USB UEFI flash button on the board and restore the UEFI from a USB key. This shouldn't be happening at all for one, but it has happened on at least Gigabyte and MSI boards from what I've seen. That you get a memory error that you can recover from by doing a clear CMOS, isn't a big deal, but when you can'r recover, it's a different matter altogether.
 
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
True. I saw the video from Jay about his MSI board failing POST...

What an absolute pain. :(
 
Joined
Nov 11, 2004
Messages
4,514 (0.82/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard Gigabyte X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Audio Device(s) Corsair Virtuoso SE
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
True. I saw the video from Jay about his MSI board failing POST...

What an absolute pain. :(
The problem is that there has been zero communication from AMD with regards to this issue, so it's not clear what causes it. Is it a flawed memory controller, something weird with certain RAM combinations, a poor UEFI/AGESA implementation, or a combination of all three? The two things that have solved it for some people have been to RMA the CPU and AGESA 1.0.0.3 ABB/ABBA. Swapping memory has in general not solved the problem.
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
What Agesa is the board on?
It is on 2.10 which should be 1.0.0.3 ABBA. At times last night, it would start up, and then shutdown three times before booting with a default bios.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,908 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
I put in for a return so we'll see.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,908 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
May have been ES, but it was very close to the retail sample. I’m not buying that it’s so massively different as ES vs retail. They only shipped them weeks before the retail samples... so they were in the final stages as ES boards.
 
Joined
Mar 10, 2015
Messages
2,251 (1.31/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,908 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
May have been ES, but it was very close to the retail sample. I’m not buying that it’s so massively different as ES vs retail. They only shipped them weeks before the retail samples... so they were in the final stages as ES boards.
It is, here you go

So you are returning the 3700X?
 
Joined
Apr 30, 2012
Messages
3,457 (1.25/day)
May have been ES, but it was very close to the retail sample. I’m not buying that it’s so massively different as ES vs retail. They only shipped them weeks before the retail samples... so they were in the final stages as ES boards.
Hardware Unboxed didn't have an issue with theirs
 
Joined
Feb 22, 2019
Messages
708 (2.62/day)
System Name Fatboii
Processor AMD Ryzen 7 3700X @ 4.2 GHz (all cores)
Motherboard ASUS Crosshair VIII Hero WiFI
Cooling Custom water
Memory Patriot Viper Steel 2x8GB @ 3733 15-15-15-34-52-1T
Video Card(s) EVGA GTX 1080 Ti FTW3 under water
Storage Samsung SM951 256GB + 860 EVO 1TB
Display(s) ASUS ROG PG278Q 144Hz
Case Fractal Design R6 Tempered Glass
Audio Device(s) Onboard
Power Supply EVGA SuperNOVA G3 850w
Mouse Logitech G502
Keyboard Cooler Master Pro Keys L
Software Win 10 Pro
Benchmark Scores I only game on this system... built for silence, not absolute max performance. ;)
That’s my point. It’s extremely unlikely that it was radically different to the point that the BIOS would matter. It sounds like a BS response to cover their butts. That’s my take on it after having dealt with many a pre-release board and NEVER having an issue flashing with a newer BIOS.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,908 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
That’s my point. It’s extremely unlikely that it was radically different to the point that the BIOS would matter. It sounds like a BS response to cover their butts. That’s my take on it after having dealt with many a pre-release board and NEVER having an issue flashing with a newer BIOS.
Either way i dont use msi, they went down the toilet after AM2
 
Top