• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Bad performance/Usage spikes with R9 290 Tri-X CF.

Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
I bought 2 R9 290 Tri-X recently and i have low FPS in games like Crysis 3 and BF4. In crysis i have somewhere between 35-90 fps and in BF4 i have around 50-60 on Ultra, 1080P. I have noticed some serious GPU usages spikes in those games.

I have turned off ULPS, tried in windows mode, the temps are good and the benchmarks "seems" okey.

Do you guys have any clue what the problem might be?
 
Joined
Jul 18, 2007
Messages
2,693 (0.49/day)
System Name panda
Processor 6700k
Motherboard sabertooth s
Cooling raystorm block<black ice stealth 240 rad<ek dcc 18w 140 xres
Memory 32gb ripjaw v
Video Card(s) 290x gamer<ntzx g10<antec 920
Storage 950 pro 250gb boot 850 evo pr0n
Display(s) QX2710LED@110hz lg 27ud68p
Case 540 Air
Audio Device(s) nope
Power Supply 750w superflower
Mouse g502
Keyboard shine 3 with grey, black and red caps
Software win 10
Benchmark Scores http://hwbot.org/user/marsey99/
games on the ssd or spinner?
 

Durvelle27

Moderator
Staff member
Joined
Jul 10, 2012
Messages
6,536 (1.77/day)
Location
Memphis, TN
System Name Black Prometheus
Processor AMD Ryzen 7 5800X
Motherboard ASRock B550M Pro4
Cooling ID Cooling Auraflow 360 Snow Edition
Memory TeamGroup Classic 64GB(2x32GB) DDR4 3200MHz
Video Card(s) Gigabyte RTX 3070 Ti Gaming OC
Storage Sandisk X300 512GB + WD Black 6TB+WD Black 6TB
Display(s) LG Nanocell85 49" 4K 120Hz+3x 24" 1200P Monitors
Case DeepCool Matrexx 55 V3 w/ 6x120mm Intake + 3x120mm Exhaust
Audio Device(s) LG Dolby Atmos
Power Supply Corsair RMX850 Fully Modular
Mouse Logitech Trackman
Keyboard Dell OEM
Software Windows 10 EDU x64
50-60 Ultra at 1080P seems very low for BF4
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
I ran the same settings as anandtech did in there bench. They got 77 with one card. I got 60 with 2. Something is wrong.
 

Durvelle27

Moderator
Staff member
Joined
Jul 10, 2012
Messages
6,536 (1.77/day)
Location
Memphis, TN
System Name Black Prometheus
Processor AMD Ryzen 7 5800X
Motherboard ASRock B550M Pro4
Cooling ID Cooling Auraflow 360 Snow Edition
Memory TeamGroup Classic 64GB(2x32GB) DDR4 3200MHz
Video Card(s) Gigabyte RTX 3070 Ti Gaming OC
Storage Sandisk X300 512GB + WD Black 6TB+WD Black 6TB
Display(s) LG Nanocell85 49" 4K 120Hz+3x 24" 1200P Monitors
Case DeepCool Matrexx 55 V3 w/ 6x120mm Intake + 3x120mm Exhaust
Audio Device(s) LG Dolby Atmos
Power Supply Corsair RMX850 Fully Modular
Mouse Logitech Trackman
Keyboard Dell OEM
Software Windows 10 EDU x64
I ran the same settings as anandtech did in there bench. They got 77 with one card. I got 60 with 2. Something is wrong.
what are temps for both cards and is anything OC'd
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
8,384 (1.86/day)
Location
Rochester area
System Name RPC MK2.5
Processor Ryzen 5800x
Motherboard Gigabyte Aorus Pro V2
Cooling Enermax ets-t50
Memory CL16 BL2K16G36C16U4RL 3600 1:1 micron e-die
Video Card(s) GIGABYTE RTX 3070 Ti GAMING OC
Storage ADATA SX8200PRO NVME \512GB Intel 545s ssd \500GB ADATA SU800 ssd 3TB Spinner
Display(s) 1440p Dell
Case Phanteks P300 /w 300A front panel conversion
Audio Device(s) onboard
Power Supply HX 750i
Mouse Kone burst Pro
Keyboard redragon k580 vata /w QMK-ORGB
Software Windows 11 +startisallback
welcome to the world of crossfire
pray that AMD fixes there drivers or simply disable Xfire are your options
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
welcome to the world of crossfire
pray that AMD fixes there drivers or simply disable Xfire are your options
Haha thank's. I would be happy if it was just CF problems. This feels like something else is wrong. Anandtech said i should get 77FPS(with 1 card) on Crysis 3 with a specific setting. I got 30 with one.
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
8,384 (1.86/day)
Location
Rochester area
System Name RPC MK2.5
Processor Ryzen 5800x
Motherboard Gigabyte Aorus Pro V2
Cooling Enermax ets-t50
Memory CL16 BL2K16G36C16U4RL 3600 1:1 micron e-die
Video Card(s) GIGABYTE RTX 3070 Ti GAMING OC
Storage ADATA SX8200PRO NVME \512GB Intel 545s ssd \500GB ADATA SU800 ssd 3TB Spinner
Display(s) 1440p Dell
Case Phanteks P300 /w 300A front panel conversion
Audio Device(s) onboard
Power Supply HX 750i
Mouse Kone burst Pro
Keyboard redragon k580 vata /w QMK-ORGB
Software Windows 11 +startisallback
Haha thank's. I would be happy if it was just CF problems. This feels like something else is wrong. Anandtech said i should get 77FPS(with 1 card) on Crysis 3 with a specific setting. I got 30 with one.
might not be throttling up all the way install msi afterburner and lock it to max nominal clocks and see what happens
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
might not be throttling up all the way install msi afterburner and lock it to max nominal clocks and see what happens
It says they are running at 1000Mhz when am playing. Don't know what the problem is.
 
Joined
Apr 29, 2014
Messages
4,001 (1.32/day)
Location
Texas
System Name SnowFire / The Reinforcer / Portable?
Processor i7 10700K 5.1ghz (24/7) / 2x Xeon E52650v2 / AMD Ryzen 5 3600X
Motherboard Asus Strix Z490 / Dell Dual Socket (R720) / Asrock X570 ITX
Cooling RX 360mm + 140mm Custom Loop / Dell Stock / Noctua L9i (Yes L9i)
Memory Corsair RGB 16gb DDR4 3000 CL 16 / DDR3 128gb 16 x 8gb / Corsair RGB 3200 16gb
Video Card(s) GTX Titan XP (2025mhz) / Asus GTX 950 (No Power Connector) / GTX 970 (Temp)
Storage Samsung 970 1tb NVME and 2tb HDD x4 RAID 5 / 300gb x8 RAID 5 / 2x Samsung 850 Pro 512gb
Display(s) Acer XG270HU, Samsung G7 Odyssey (1440p 240hz) / HP Omen 1080p 240hz
Case Thermaltake Cube / Dell Poweredge R720 Rack Mount Case / Fractal Design Node 202
Audio Device(s) Realtec ALC1150 (On board)
Power Supply Rosewill Lightning 1300Watt / Dell Stock 750 / Brick / Fractal Design 450 Watt Bronze
Mouse Logitech G5
Keyboard Logitech G19S
Software Windows 10 Pro / Windows Server 2016 / Windows 10 Pro
Haha thank's. I would be happy if it was just CF problems. This feels like something else is wrong. Anandtech said i should get 77FPS(with 1 card) on Crysis 3 with a specific setting. I got 30 with one.
That is not likely the cause, there are no issues with crossfire in those games as I play both on 3 290X cards with way better FPS (1 card on 1080p stays at 60FPS pretty constant) which likely leads to believe something else is the cause.

Odd that your getting usage spikes, are you using full screen mode or windowed?

You maybe hitting a bottleneck somewhere else or having an issue with a certain feature. I know for a fact many people report problems on i7 processor in BF4 with Hyper Threading enabled so you might want to look into that.

On the Crysis 3 note, that game has always been odd when running on any system and changes constantly. Sadly its not well optimized even on the most powerful rigs.
 
Joined
Nov 18, 2010
Messages
5,985 (1.39/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor AMD RYZEN 9 5950X
Motherboard ASUS Strix X570-E
Cooling Custom Loop. Two 360ies + 280 rad. 8x Nidec Servo Gentle Typhoons. EK-Quantum Momentum monoblock.
Memory 4x8GB G.SKILL Trident Z RGB F4-4133C19D-16GTZR 14-16-12-30-44
Video Card(s) ASUS 1080 Ti SLI + water blocks
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB+ 1TB 980PRO
Display(s) Philips PHL BDM3270 + Acer XV242Y
Case Lian Li O11 Dynamic EVO
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer BlackWidow V3 - Yellow Switch
Software Windows 11 insider
First thing... did you nuke the OS? Are CFX really active, full load on each card...

the dumb question... is v sync off? No pun intended.
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
First thing... did you nuke the OS? Are CFX really active, full load on each card...

the dumb question... is v sync off? No pun intended.

Nuke the OS? :p But yeah CF is active. But no, i don't get full load on both the cards. Massive usage spikes.
 
Joined
Jun 20, 2007
Messages
3,884 (0.70/day)
System Name Medusa
Processor i7 2600k @4.8ghz
Motherboard Asus P8P67 Pro
Cooling CPU : Noctua NH-L12 GPU: EK FC 1080 via Magicool 360 III PRO > Photon 170 (D5)
Memory 16gb Kingston Hyper X DDR3 @2133
Video Card(s) GTX 1080 TI
Storage Samsung 8series NVM 1TB, Hitachi 3TB 2x 5400
Display(s) Predator X34P/Tempest X270OC @ 120hz / LG W3000h
Case Fractal Define S [Antec Skeleton hanging in hall of fame]
Audio Device(s) Asus Xonar Xense with AKG K612 cans on Monacor SA-100
Power Supply Seasonic X-850
Mouse Razer Naga 2014
Software Windows 10 Pro
Benchmark Scores FFXIV ARR Benchmark 1600p score 12,098[this means nothing any more!]
might not be throttling up all the way install msi afterburner and lock it to max nominal clocks and see what happens
I'm certain that it's not downclocking due to Crossfire - only from personal experience I've seen that as soon as you add a second card, they no longer use dynamic clocks/boost.

Downclocking would happen if there was a problem e.g. heat.
 
Joined
Jul 18, 2007
Messages
2,693 (0.49/day)
System Name panda
Processor 6700k
Motherboard sabertooth s
Cooling raystorm block<black ice stealth 240 rad<ek dcc 18w 140 xres
Memory 32gb ripjaw v
Video Card(s) 290x gamer<ntzx g10<antec 920
Storage 950 pro 250gb boot 850 evo pr0n
Display(s) QX2710LED@110hz lg 27ud68p
Case 540 Air
Audio Device(s) nope
Power Supply 750w superflower
Mouse g502
Keyboard shine 3 with grey, black and red caps
Software win 10
Benchmark Scores http://hwbot.org/user/marsey99/
On the HDD, but with my 6950CF i had it on the HDD aswell and no problem.

the way they do xfire now puts more stress on the mobo which could be causing the hold ups which is why you are seeing dips in fps.

i would throw bf4 on the ssd and see if it helps any.

I ran the same settings as anandtech did in there bench. They got 77 with one card. I got 60 with 2. Something is wrong.

as your system is not the same as their testbench, you will see differences in results. you can only use charts like those as comparisons for other hardware in the same machine. not use them to say what your machine will get.

also what does just 1 card get?
 

Wrigleyvillain

PTFO or GTFO
Joined
Oct 13, 2007
Messages
7,693 (1.42/day)
Location
Chicago
System Name DarkStar
Processor i5 3570K 4.4Ghz
Motherboard Asrock Z77 Extreme 3
Cooling Apogee HD White/XSPC Razer blocks
Memory 8GB Samsung Green 1600
Video Card(s) 2 x GTX 670 4GB
Storage 2 x 120GB Samsung 830
Display(s) 27" QNIX
Case Enthoo Pro
Power Supply Seasonic Platinum 760
Mouse Steelseries Sensei
Keyboard Ducky Pro MX Black
Software Windows 8.1 x64
Yes it sounds like crossfire's simply not working. I get 50-70 in BF4 at 1440P with one 290X. Keep troubleshooting it. I assume you are running full screen.
 

Durvelle27

Moderator
Staff member
Joined
Jul 10, 2012
Messages
6,536 (1.77/day)
Location
Memphis, TN
System Name Black Prometheus
Processor AMD Ryzen 7 5800X
Motherboard ASRock B550M Pro4
Cooling ID Cooling Auraflow 360 Snow Edition
Memory TeamGroup Classic 64GB(2x32GB) DDR4 3200MHz
Video Card(s) Gigabyte RTX 3070 Ti Gaming OC
Storage Sandisk X300 512GB + WD Black 6TB+WD Black 6TB
Display(s) LG Nanocell85 49" 4K 120Hz+3x 24" 1200P Monitors
Case DeepCool Matrexx 55 V3 w/ 6x120mm Intake + 3x120mm Exhaust
Audio Device(s) LG Dolby Atmos
Power Supply Corsair RMX850 Fully Modular
Mouse Logitech Trackman
Keyboard Dell OEM
Software Windows 10 EDU x64
which slots are you using
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
the way they do xfire now puts more stress on the mobo which could be causing the hold ups which is why you are seeing dips in fps.

i would throw bf4 on the ssd and see if it helps any.


as your system is not the same as their testbench, you will see differences in results. you can only use charts like those as comparisons for other hardware in the same machine. not use them to say what your machine will get.

also what does just 1 card get?

Around 30-40 FPS and two card get between 40-60 FPS. When i play at window mode. 1 card seem to work at 100% but still 30-40FPS.

Yes it sounds like crossfire's simply not working. I get 50-70 in BF4 at 1440P with one 290X. Keep troubleshooting it. I assume you are running full screen.

Yes i am.


which slots are you using

The two blue slots. They are PCI-E 16X i think.
 
Joined
Apr 29, 2014
Messages
4,001 (1.32/day)
Location
Texas
System Name SnowFire / The Reinforcer / Portable?
Processor i7 10700K 5.1ghz (24/7) / 2x Xeon E52650v2 / AMD Ryzen 5 3600X
Motherboard Asus Strix Z490 / Dell Dual Socket (R720) / Asrock X570 ITX
Cooling RX 360mm + 140mm Custom Loop / Dell Stock / Noctua L9i (Yes L9i)
Memory Corsair RGB 16gb DDR4 3000 CL 16 / DDR3 128gb 16 x 8gb / Corsair RGB 3200 16gb
Video Card(s) GTX Titan XP (2025mhz) / Asus GTX 950 (No Power Connector) / GTX 970 (Temp)
Storage Samsung 970 1tb NVME and 2tb HDD x4 RAID 5 / 300gb x8 RAID 5 / 2x Samsung 850 Pro 512gb
Display(s) Acer XG270HU, Samsung G7 Odyssey (1440p 240hz) / HP Omen 1080p 240hz
Case Thermaltake Cube / Dell Poweredge R720 Rack Mount Case / Fractal Design Node 202
Audio Device(s) Realtec ALC1150 (On board)
Power Supply Rosewill Lightning 1300Watt / Dell Stock 750 / Brick / Fractal Design 450 Watt Bronze
Mouse Logitech G5
Keyboard Logitech G19S
Software Windows 10 Pro / Windows Server 2016 / Windows 10 Pro
Around 30-40 FPS and two card get between 40-60 FPS. When i play at window mode. 1 card seem to work at 100% but still 30-40FPS.
Ok so then your getting some interesting FPS, like I said before I would check your processor on this one especially considering your running at stock. BF4 has issues running Hyper Threading on the i7's which has cause poor performance issues. Also you might try enabling Mantle and see if that helps (Or Vice Versa).
Yes i am.
Ok well that knocks that out of the picture.
The two blue slots. They are PCI-E 16X i think.
Running two cards with that board would be at 8X which is more than fine so thats not the problem unless your board is running them at 4x or something. You can check that in CCC when checking hardware.
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
Ok so then your getting some interesting FPS, like I said before I would check your processor on this one especially considering your running at stock. BF4 has issues running Hyper Threading on the i7's which has cause poor performance issues. Also you might try enabling Mantle and see if that helps (Or Vice Versa).

Ok well that knocks that out of the picture.
Running two cards with that board would be at 8X which is more than fine so thats not the problem unless your board is running them at 4x or something. You can check that in CCC when checking hardware.

Yeah it was 8X. So that's not the problem either. I saw that the CPU usage was around 60-90% on all cores on Crysis 3.

I got 38FPS Avg in some places when playing Crysis 3 in fullscreen. That's worse than my 6950CF.
 
Joined
Apr 29, 2014
Messages
4,001 (1.32/day)
Location
Texas
System Name SnowFire / The Reinforcer / Portable?
Processor i7 10700K 5.1ghz (24/7) / 2x Xeon E52650v2 / AMD Ryzen 5 3600X
Motherboard Asus Strix Z490 / Dell Dual Socket (R720) / Asrock X570 ITX
Cooling RX 360mm + 140mm Custom Loop / Dell Stock / Noctua L9i (Yes L9i)
Memory Corsair RGB 16gb DDR4 3000 CL 16 / DDR3 128gb 16 x 8gb / Corsair RGB 3200 16gb
Video Card(s) GTX Titan XP (2025mhz) / Asus GTX 950 (No Power Connector) / GTX 970 (Temp)
Storage Samsung 970 1tb NVME and 2tb HDD x4 RAID 5 / 300gb x8 RAID 5 / 2x Samsung 850 Pro 512gb
Display(s) Acer XG270HU, Samsung G7 Odyssey (1440p 240hz) / HP Omen 1080p 240hz
Case Thermaltake Cube / Dell Poweredge R720 Rack Mount Case / Fractal Design Node 202
Audio Device(s) Realtec ALC1150 (On board)
Power Supply Rosewill Lightning 1300Watt / Dell Stock 750 / Brick / Fractal Design 450 Watt Bronze
Mouse Logitech G5
Keyboard Logitech G19S
Software Windows 10 Pro / Windows Server 2016 / Windows 10 Pro
Yeah it was 8X. So that's not the problem either. I saw that the CPU usage was around 60-90% on all cores on Crysis 3.

I got 38FPS Avg in some places when playing Crysis 3 in fullscreen. That's worse than my 6950CF.
Well something has to be a miss here... I get above that running at 4k reolution so something is not right...

Might I inquire what driver version your using?

You should be getting averages much closer to this area...
 
Joined
Jul 31, 2014
Messages
81 (0.03/day)
System Name Quasar
Processor Intel i7 2600K
Motherboard ASRock P67 Extreme 4 B3
Cooling Intel Stock Cooler
Memory 8GB DDR3
Video Card(s) AMD HD 6950
Storage 1TB 7200RPM, Samsung 840 Evo 120GB
Display(s) LG IPS 236
Case Silverstone Raven RV02-E
Audio Device(s) Sound Blaster Z
Power Supply Corsair HX 850W
Software W7
Benchmark Scores 3D Mark 2013: 13000+ Heaven 4.0: 2460+
Well something has to be a miss here... I get above that running at 4k reolution so something is not right...

Might I inquire what driver version your using?

You should be getting averages much closer to this area...

Just my thinking. I was using 14.4 and today i installed 14.7 beta. Got the same result.
 
Joined
May 15, 2008
Messages
2,863 (0.55/day)
Location
Brasil
System Name Sovereign // HTPC
Processor i7 3770k 4.2 // i7 3770k 4.2
Motherboard Maximus V Gene // Sabertooth Z77
Cooling Noctua D14 // Intel HSF
Memory 16GB Samsung // 16GB VengeanceLP
Video Card(s) Deciding // 660 DC2
Storage OS (X25-M), Data (Seagate 1TB) // Samsung 840 120GB & bunch of drives
Display(s) Samsung T240HD // LG TV
Case TJ08e // Grandia GD08
Audio Device(s) DT880 Pro 250 ohm // TV speakers
Power Supply Seasonic Plat 1000 // Seasonic Gold 760
Software Windows 8 Pro x64 // Windows 7 Pro x64
Joined
Aug 12, 2012
Messages
616 (0.17/day)
Location
Nebulas
System Name X99
Processor 5930K @ 4.7GHz @ 1.323v
Motherboard Rampage V Edition 10
Cooling EK
Memory Dominator Platinum 32GB
Video Card(s) 2x Gigabyte xtreme gaming 980ti
Storage Samsung 950 Pro M.2, 850 Pro & WD320
Display(s) Tempest X270OC @100Hz
Case Thermaltake Core P5
Audio Device(s) On-board
Power Supply 120-G2-1600-X1
Mouse Mamba 2012
Keyboard K70
Software Win10
Benchmark Scores http://www.3dmark.com/fs/6823139
What driver do you have installed? Do you use vsync? I have two 290x GPUs and run 1440p on 2x ultra settings vsync at 100Hz and get a pretty steady 100 fps with the 14.4 drivers.
 
Top