• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Can somebody please help me identify this card, and if possible, provide me a VBIOS for it?

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
Hello!
Recently I got a "presumably" SAPPHIRE RX580 card from someone who used it for mining. I got it for 15$ but he said it might not work.

The fans spin, the SAPPHIRE logo lights up but i got no video signal. Had to use my second PCI-E slot to use an old GT210 as a video adapter.


It looks like a NITRO+ from the outside and the sticker on the fan shroud points to an RX580 4GB but when I took off the heatsink, I found this:

which is most likely an RX570
there are 8 SAMSUNG memory chips around it, but i cant really read the chip part number





And here's what info GPU-Z gave me:
1621606818063.png


Can I make this card work by flash the right VBIOS? If yes, where can I get it from?
 
Joined
Aug 11, 2014
Messages
804 (0.31/day)
Processor ryzen 5 5600x
Motherboard AB350m Pro4 with B450M Pro4-F bios
Cooling custom loop
Memory TEAMGROUP T-Force TXKD416G3600HC18ADC01 16gbs XMP
Video Card(s) HP GTX1650 super 4gb
Storage MZVLB256HBHQ-000H1 PM981a (256GB)/3TB HDD
Display(s) Nitro XF243Y Pbmiiprx
Case Rosewill CULLINAN
Audio Device(s) onboard
Power Supply Corsair 750w
Mouse Best Buy Insignia
Keyboard Best Buy Insignia
Software Win 10 pro
try flicking the bios switch and see what it does.

proxy.jpg
 
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
Hi.
If you find exact model and sub ID of your card - yes you will flash a new BIOS in it to try to restore it to factory default.
1st step is to idetify the producer and model - You told that you have Samsung chips. Good then you must clean one chip with a clean cloth.
Then you must use a light source and with a phone you must make a picture using zoom to see exact numbers on those chips.
This way we can figure out if you have 4 gb or 8 gb
On the second part, if you look closer on the case you should find a sticker with a bar code and some numbers and serials.
Be so kind and make a picture and put it here in order for us to help you identify the card
 

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
Sure thing. In the meantime, switching back to BIOS 1, with that bios switch, I entered GPU_Z again, to find this:
2304 shader units. Doesnt that mean its an RX580?
Also, only 160MB of VRAM were read.

and afaik, its supposed to be a Polaris GPU if it's An RX 5XX

1621608870941.png


I will open up the GPU once again and take close up pictures.
Thanks in advance for your help

GPU Die number:
1621609802079.png


Memory chip:

K4G41325FE-HC25​


1621609874675.png



PCI-E connector inscription:
1621610419578.png



Fan shroud inscription:
1621611028107.png
 
Last edited:
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
Ok
From the last picture i was able to identify exact model of your card : Sapphire Nitro Radeon RX 580 4gb - with Samsung memory chips
From one of the pictures where you zoomed on the video chipset, (GPU die number) - i noticed plenty of arctic paste on the components that surrounds the video processor.
You should fast clean that up, because that arctic cooling paste contains silver that is a very good electricity conductor.
So 1st : you clean up with a ear bud all area surrounding the video processor
2nd : you use isopropilic alcohol with ear buds to clean the rest of the arctic paste that will be stuck in the small pieces that surrounds the video processor
3rd : you will use the original BIOS for your card to reflash it to restore it to factory default
4th : you give it a try (should work at that time at full speed)

This is the BIOS for your card.

Good luck mate
 
Joined
Oct 22, 2014
Messages
12,543 (4.96/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
- i noticed plenty of arctic paste on the components that surrounds the video processor.
You should fast clean that up, because that arctic cooling paste contains silver that is a very good electricity conductor.
You can tell what brand thermal paste is on the chip just by looking at it? :rolleyes:
It was obvious to me it is a RX580 4GB and the sticker on the shroud should have been in the initial post, not some assumption it may be a RX570
p.s. Arctic Silver is NOT good at being electrically conductive.
 

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
You can tell what brand thermal paste is on the chip just by looking at it? :rolleyes:
It was obvious to me it is a RX580 4GB and the sticker on the shroud should have been in the initial post, not some assumption it may be a RX570
p.s. Arctic Silver is NOT good at being electrically conductive.
it was not an assumption. If you look at the numbers on the die, it's an RX570 chip
 

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
After flashing an RX570 4GB VBIOS, the card is identified correctly in GPU-Z but i still get error 43 in windows, and the PC wont post without an additional VGA card.
 
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
So after all you flashed a 570 BIOS instead 580 as it should ?
 
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
OK.
If you still got that nasty error 43, can you at least try to flash the BIOS for RX580 ?
Maybe who knows ....

Ok. Because basically it is a RX570, even if the clock are lower then rx580, wouldn't be wiser to flash a RX570 with correct Samsung chips ?
Because as you said earlier, this video card was made only for chinese market so finding a correct BIOS will be like a pain in the ass ?
I did now saw the die from rx570 but instead i used the info from the labels from the card.
AstroNoot provided picture with the actual part number and i found out that it is a RX580.
Interesting option from manufacturer to use a lower chip and to clock it higher :)
 
Last edited:
Joined
Nov 11, 2020
Messages
84 (0.26/day)
Location
Earth, Solar System
Processor AMD Ryzen 7 3700X
Motherboard Asus TUF Gaming B550M-Plus (Wi-Fi)
Cooling Thermalright AS120, Arctic P12, Arctic F12
Memory Crucial BL8G32C16U4W.M8FE1 ×2
Video Card(s) Radeon RX 6600 XT
Storage Samsung MZVLB1T0HBLR-000L2, Seagate ST1000DM010-2EP102
Display(s) AOC I2490PXH5
Case Huntkey GS409
Audio Device(s) Somic G923
Power Supply EVGA 650 GD
Mouse Logitech G102
Keyboard Logitech K845 TTC Brown
Software Windows 10 Pro 1903, Dism++
Benchmark Scores CPU-Z 17.01.64: 3700X @ 4.6 GHz 1.3375 V scoring 557/6206; 760K @ 5 GHz 1.5 V scoring 292/964
The die part number indicates that it is either an RX 570 or an RX 580 2048SP which is a Chinese market only SKU. However, there is no VBIOS for the former with 4 GB of 2000 MHz Samsung VRAM in the VBIOS collection, so your card is more likely to be the latter. See more infomation here: https://www.techpowerup.com/gpu-specs/radeon-rx-580-2048sp.c3321

Try this VBIOS in the link which follows. It is the most well-matched VBIOS I've found. Same VRAM spec, same BIOS version, same 8-pin and 6-pin power supply. But still I am not 100% sure whether this IS the one. https://www.techpowerup.com/vgabios/201113/sapphire-rx580-4096-180119-1

Here is what I have got: a Pulse rather than a Nitro+, and Hynix VRAM running at default 1750 MHz. Mine is almost the same as yours but you can't flash my VBIOS into yours because they have different VRAM.
0.gif
 
Last edited:

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
Thank you, but this didn't fix anything :(
I'm pretty sure the name of the card cant be altered by the bios,and thats why i think this is truly an RX570.

1621766143541.png
1621766155571.png
 
Joined
Nov 11, 2020
Messages
84 (0.26/day)
Location
Earth, Solar System
Processor AMD Ryzen 7 3700X
Motherboard Asus TUF Gaming B550M-Plus (Wi-Fi)
Cooling Thermalright AS120, Arctic P12, Arctic F12
Memory Crucial BL8G32C16U4W.M8FE1 ×2
Video Card(s) Radeon RX 6600 XT
Storage Samsung MZVLB1T0HBLR-000L2, Seagate ST1000DM010-2EP102
Display(s) AOC I2490PXH5
Case Huntkey GS409
Audio Device(s) Somic G923
Power Supply EVGA 650 GD
Mouse Logitech G102
Keyboard Logitech K845 TTC Brown
Software Windows 10 Pro 1903, Dism++
Benchmark Scores CPU-Z 17.01.64: 3700X @ 4.6 GHz 1.3375 V scoring 557/6206; 760K @ 5 GHz 1.5 V scoring 292/964
Thank you, but this didn't fix anything :(
I'm pretty sure the name of the card cant be altered by the bios,and thats why i think this is truly an RX570.

View attachment 201340View attachment 201341
Damn. This is really weird... Have you tried re-install the driver? Maybe that would help.
But I think that we still haven't found the exact VBIOS... Try multiple times.
Ask the seller for the original VBIOS maybe? Or ask him to provide you with more detailed info of the card such as what exact model it is. The worst case is that the seller bought this card from a cryptominer and sold to you because he found it didn't work properly... Hope for the best.
I'll keeping looking for more infomation. Good luck.
 
Last edited:
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
Well about miner version BIOS...it should work normally under windows, more then this it should let you install the drivers and start working under windows environment.

If you got that nasty 43 error probably who sold you the card tried several BIOS on it and you do not have a working BIOS for it.
So yeah , you have a huge work to do....you must test a lot of BIOS-es until you will find the right one for you.
I suggest you to use the support ticket from Sapphire , where you will provide picture with that barcode and video chip so they will send you exact BIOS
They are pretty fast
 

AstroNoot

New Member
Joined
May 21, 2021
Messages
13 (0.10/day)
The seller *was* a cryptominer :D

I got this card for 15$ so I can fix it and play games.
I doubt i'd get any reliable info from the seller, since he basically lied to me at the beginning, saying its an RX580.

The only way to confirm its actually a Sapphire is because i can see the Sapphire holographic sticker on the DVI port
 
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
Then you can use the support form to contact sapphire to obtain original BIOS
Good luck mate
 
Joined
Nov 11, 2020
Messages
84 (0.26/day)
Location
Earth, Solar System
Processor AMD Ryzen 7 3700X
Motherboard Asus TUF Gaming B550M-Plus (Wi-Fi)
Cooling Thermalright AS120, Arctic P12, Arctic F12
Memory Crucial BL8G32C16U4W.M8FE1 ×2
Video Card(s) Radeon RX 6600 XT
Storage Samsung MZVLB1T0HBLR-000L2, Seagate ST1000DM010-2EP102
Display(s) AOC I2490PXH5
Case Huntkey GS409
Audio Device(s) Somic G923
Power Supply EVGA 650 GD
Mouse Logitech G102
Keyboard Logitech K845 TTC Brown
Software Windows 10 Pro 1903, Dism++
Benchmark Scores CPU-Z 17.01.64: 3700X @ 4.6 GHz 1.3375 V scoring 557/6206; 760K @ 5 GHz 1.5 V scoring 292/964
I think at least the 2304SP VBIOS doesn't work. If you're willing to try this out. https://www.techpowerup.com/gpu-specs/sapphire-nitro-rx-580-4-gb.b4433
This is the VBIOS of an RX 580 (2304SP) which runs at 1411 MHz and with Samsung VRAM running at 2000 MHz. I don't think this would work...
Everything is weird now. This model is of SKU# 11265-07-20G, similar to your card's label. But they are totally different die part number, so I don't think it would work...
 
Joined
Apr 22, 2021
Messages
255 (1.65/day)
Location
Europe
As i suggested...let him get support from Sapphire based on his serial number and video chip type.
They move really fast
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,251 (6.20/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I just did that! Thanks!

This is your card, it is a RX 580 Nitro by Sapphire Tech with 4GB Samsung GDDR5.

SKU 11265-31

The PN 299-1E366-501BC says exactly this card

https://www.ebay.com/itm/Sapphire-NITRO-AMD-Radeon-RX-580-4GB-GDDR5-AMD-Graphics-Card-/224002802786

This is the bios for the card.

@impero, sapphire 2048SP cards for Sapphire start with Dev ID: 1002 6FDF Subsys ID: 1DA2 *** (E353 etc) which are the chinese 580 or the stock 570
 
Last edited:
Top