• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Constant "EDP Other" under RING in ThrottleStop

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
in comparison to my PC I consider temperatures to be high.
That is correct. When you shove one of Intel's 6 core CPUs into a laptop and cover it with a tiny heatsink compared to a desktop, it is going to run hot. Temperatures up over 90°C are perfectly normal. At your laptop's default settings, your CPU will thermal throttle when it hits 92°C so everything is OK as is.

Will lowering voltages lower temperatures?
Yes. Lowering voltages will lower power consumption and that should result in lower temperatures. Sometimes it does not make a huge difference. Many laptops adjust the CPU fan speed so you might see lower temperatures or less fan noise or a little of both.

The default turbo ratios when 1 or 2 cores are active is 45 and 44. When 1 or 2 cores are active, your CPU is not overheating so I do not see the need to lower these values. Using the 40 multiplier whether 1, 2, 3, 4, 5 or 6 cores are active is perfectly fine but you are sacrificing performance when you really do not need to do so.

The new PROCHOT Offset feature might be useful for you. It was included in ThrottleStop so a user can run their CPU at whatever temperature they like, within Intel spec of course. I prefer full performance and maximum temperatures but you can also do the opposite. If you do not want to see your CPU go over 75°C then all you need to do is set a PROCHOT Offset value of 25.

100°C - 25 = 75°C

Your CPU will start thermal throttling at this temperature so no matter what software you run, it will not exceed this temperature. Your CPU will slow down to a crawl if it has to so it does not exceed this temperature. Have a look in the Options window. The latest ThrottleStop version that I posted a download link to above has this new feature.



Some laptops lock the adjustable PROCHOT (processor hot) feature. If you see a black dot in that red box, this feature is locked. If it is not locked, it might be just what you are looking for without having to fine tune the power limits. Setting PROCHOT Offset will give you full control of your CPU temps.
 

Lesiu

New Member
Joined
May 11, 2020
Messages
5 (0.19/day)
Unfortunately, the field is blocked.

I would prefer a temperature of 75-80

situation below with multiplier 40
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
Your log file shows that your cooling system can keep your CPU at 80°C when power consumption is at 45W. Set the long and short turbo power limits to 45W and your problem is solved.

Another possibility is to leave your power limits at 45W and 60W but reduce the turbo time limit. This will allow the CPU to run fast for a short period of time before switching to the lower power limit. If you are using the default 28 seconds, try cutting that in half to 14 seconds or somewhere around there.

I would prefer a temperature of 75-80
Those temperatures are not any safer than 90°C. All of these temperatures are "safe operating temperatures" according to Intel. If you disagree with Intel or just want a cool CPU, you can set the turbo power limits however you like to achieve your goal. Less power equals less performance and a cooler CPU. Find a compromise that works best for you.
 

miino82

New Member
Joined
May 17, 2020
Messages
1 (0.05/day)
Dear Unclewebb,

Thank you so much for posting your responses to everyone here, it has been a huge help for me in figuring out how to configure my setup. Your input is greatly appreciated.
 

Adrianis

New Member
Joined
May 21, 2020
Messages
1 (0.06/day)
Dear unclewebb,
Thank you very much for all your posts were you explain to everybody what to do and how to it properly .
I am a i7 9750h CPU owner in a Rog Strix Scar 3 case and it was running damn` hot . After I found this thread things became a little bit more easy for me. Next couple of days I will post screenshots with my settings in ThrottleStop.

Cheers , stay safe u all .
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
Hi unclewebb,
So I have a Macbook Bootcamp setup with i9-9880H and an eGPU, basically, everything works until I run the CPU at high load. Then the CPU always peaks at 100c and performs less stable. I notice that when I get from 100 FPS to 50 or less and shortly after that it jumps up again, I would like to make the CPU run more stable with Turbo Boost enabled. Ah and EDP Other constantly flashes red if the CPU is doing something even in idle, Throttle if I do high CPU load. And VR Current sometimes. The Log File is 5 min in a game and one TS Bench at the end. Is there anything I can do?

I would appreciate all help
 

Attachments

Last edited:

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
@DarkByteZero - In the log I see the CPU multiplier dropping down to 23 at times which is equivalent to the base multiplier for a 9880H. Have you tried enabling Speed Shift in the TPL window? If this works, you will see SST in green on the main ThrottleStop screen. If you see SST, check the Speed Shift EPP box and adjust EPP to 0 for maximum performance. Set EPP to 80 if you are interested in a balanced profile where the CPU clocks down when lightly loaded. This might prevent the CPU from dropping down to the 23 multiplier. These drops might be caused by a voltage regulator that heats up and cannot cope.

Your CPU has a 45W TDP rating. In a well designed chassis, it is capable of so much more. An adequate heatsink, fan and power delivery are all important. Your Mac is struggling to control what this CPU is capable of. The log file shows lots of EDP and TEMP related throttling with the CPU running at 40W to 45W. For a smooth gaming experience, try decreasing the long term turbo power limit from 100W down to about 35W. Also reduce the short power limit to about 45W. You might have to decrease the turbo time limit too. The chassis and power delivery circuits cannot handle much more than this for any sustained period of time.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
Okay I changed the settings, the CPU is still at 80c while doing like nothing, and EDP Other permanently blinking. (With Speed Shift 0, Speed Shift 80 works better. )
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
the CPU is still at 80c while doing like nothing
Open up the C States window (C10 button). When your computer is idle, are any of the C States being used? If you see 0.0 for all of them, that is why your CPU is running so hot when idle. I am not sure how to enable the C states on a Mac running BootCamp.

Try running another log file while gaming. Are there still multiplier drops down to 23.00?
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
With Speed Shift 80 it runs much cooler, i will make a new log. And yeah i think the C States are used idk xD
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
The package C states appear to be disabled but at least the core C states are working.

Check the Task Manager Details tab. Organize the running tasks by CPU Usage. You seem to have a lot of stuff running in the background which adds heat.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
oh god this time i had BD PROCHOT throttle, and i have no idea what is overheating... i dont even use the dGPU.
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
The log file looks ugly. Any sensor can send a signal down the BD PROCHOT line which will throttle your CPU down to 800 MHz. You can use ThrottleStop to disable BD PROCHOT but this is your decision, at your own risk. I am not going to make any recommendations when I do not know what sensor is complaining.

If it was my computer, I would disable BD PROCHOT without a second thought. Your CPU will still thermal throttle if it gets too hot. Disabling BD PROCHOT only blocks external sensors from triggering throttling.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
Could it be the Voltage Regulator Module? Is there any way to know wich sensor is overheating?
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
Unless you are the guy that engineered this laptop, it is very difficult to find out what sensor is feeding info into the BD PROCHOT line. The voltage regulator current and temp trigger separate warnings within Limit Reasons so probably not either of those.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
I've watched a video, someone said that this would help with Temp for the current 16" MBP. At first glance the temp looks good.
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
If your laptop has some serious issues with the power limit set to 35W, increasing that limit to 48W is going to make your problem worse.

Time to roll the dice. Clear BD PROCHOT and see how it goes. That combined with the 35W limit should be OK.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
I'm really wondering if something is broken, the CPU is at max 70-80c and then BD PROCHOT Throttle begins, all sensors I can look are below 70 degrees and the laptop does not feel really hot. Was with 48W tho
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
It does not have to be a temperature sensor feeding into BD PROCHOT. It could also be power related. That is why most people disable BD PROCHOT. It is often times a bad sensor of some sort that triggers this.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
If your laptop has some serious issues with the power limit set to 35W, increasing that limit to 48W is going to make your problem worse.
Ok i set it to 35 but should i keep Turbo Limit Time at lowest like the guy said ?

BD PROCHOT is still an issue...
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
The turbo time limit controls how long the CPU runs at the short turbo power limit before switching to the long turbo power limit. Your screenshot shows that both long and short power limits were set to the same value, 48. In that situation, it makes no difference what the turbo time limit is set to. If you are using 35W and 45W then sure, try reducing your time limit to maybe 4 seconds.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
Turbo Boost Short is disabled, at least I thought that the checkmark next to it controls that?
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,836 (0.42/day)
When that box is not checked, I have no idea what value the CPU will use for turbo boost short. It might use a default value or it might continue to use the last value that it was set to.

I always recommend checking this box so the CPU knows what value you want to use without any ambiguity.
 

DarkByteZero

New Member
Joined
May 22, 2020
Messages
10 (0.67/day)
I will try that config now

EDIT:
I will go to sleep now, at least I got a stable run of 3DMark Time Spy Bench without BD PROCHOT.
Later I will call Apple and ask them about this issue because I actually think that all these problems occur because of Bootcamp. On Mac OS the thing runs 90-98c without even thinking about a throttle ...

Good Night
 

Attachments

Last edited:

Sambor11

New Member
Joined
May 20, 2020
Messages
7 (0.39/day)
I just download and run Cinebench r20. Is anything what I should adjust on my settings? Is essential to install in FIVR Disable and Lock Turbo Power Limits or just check the box?
 

Attachments

Top