• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

CPU power limit throttling causing bad fps drops

Joined
Jul 20, 2020
Messages
2 (0.13/day)
System Name Thinkpad X1 Extreme Gen 1
Processor Intel Core i7-8750H
Motherboard Stock
Cooling Stock
Memory 16GB DDR4 2667MHz (Single stick)
Video Card(s) GTX 1050Ti Max-Q
Storage 512GB M.2 NVMe + 1TB M.2 NVMe
Display(s) Stock (1080p 60Hz LCD)
Power Supply 135W
Mouse Razer Mamba Wireless
Hello
I currently have a ThinkPad X1 Extreme (i7 8750H + GTX 1050Ti Max-Q) and I use it for some gaming occasionally. I recently started using Throttlesotp because Lenovo has this dumb 80° C hard limit on this laptop. After using Throttlestop my CPU was able to reach 97° C (I set the PROCHOT offset to 3 so it doesn't overheat).
When I'm gaming without using Throttlestop my CPU gets throttled to 1.4 GHz, but my fps was very consistent at about 40 fps (BFV Medium) because my CPU is pinned at 100% usage and 80° C, my GPU gets only 50% usage because how the CPU was so throttled.
However, when I turn on Throttlestop my CPU instantly goes up to 3.6 GHz, my GPU gets 100% usage, and I'm getting 60 FPS. But the thing is every few seconds the CPU gets too hot and gets throttled and power limited, which literally made the game unplayable because it would drop to below 20 fps every few seconds.
Is there a way to let the CPU run at constant 95° C so that there are no fps drops? (I don't mind getting 50 fps)

Thanks!

1596041102800.png

1596041130292.png
1596041173933.png
1596041205782.png
1596041293269.png

1596041390027.png
 

Attachments

Joined
Oct 22, 2014
Messages
8,951 (4.23/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
It's not Power Limit throttling, it is Thermal Throttling.
Try undervolting or using a cooling pad under the laptop.
 
Joined
Jul 20, 2020
Messages
2 (0.13/day)
System Name Thinkpad X1 Extreme Gen 1
Processor Intel Core i7-8750H
Motherboard Stock
Cooling Stock
Memory 16GB DDR4 2667MHz (Single stick)
Video Card(s) GTX 1050Ti Max-Q
Storage 512GB M.2 NVMe + 1TB M.2 NVMe
Display(s) Stock (1080p 60Hz LCD)
Power Supply 135W
Mouse Razer Mamba Wireless
Sorry that I didn't make it clear, but by Power limiting, I actually mean power limiting caused by thermal throttling.
I did actually use a cooling pad, repasted, and unlocked my fan (so they run at full speed), but the problem is still there.
I just undervolted my CPU but sadly it doesn't seem to improve.
Thanks anyways
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,017 (0.45/day)
@Shuzhengz - Your log file shows that your thermal throttling temperature keeps dropping to 80°C. This is a big part of the problem with inconsistent performance. Lenovo has really dropped the ball with this new random thermal throttling nonsense. You need to use the ThrottleStop feature, Lock PROCHOT Offset to prevent Lenovo software from making these random and unnecessary changes to the thermal throttling temperature. Tell the idiots at Lenovo to stop being so cheap. They need to include an adequate heatsink and fan and not screw around with the thermal throttling temperature on the fly.

What voltage settings are you using? Are you undervolting both the CPU core and CPU cache? Are these in sync? Post some more info.

Your log file shows that your CPU heatsink is struggling to keep your CPU from thermal throttling when power consumption is at 40W. I know this CPU has a 45W TDP rating but your cooling is not up to the task. You have the short term turbo power limit at 78W and the long term limit set to 55W. That is overkill for the cooling that you have. I would set the short limit to about 45W and the long limit to 40W. You need to reduce power consumption to prevent your CPU from constantly bouncing off the thermal throttling temperature.
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,921 (2.10/day)
Location
Rochester area
System Name RPC MK2
Processor Intel Core i5 9600K@ 4.8Ghz 1.32V
Motherboard Asrock z390 phantom gaming 4
Cooling Enermax ets-t50
Memory CMK16GX4M2B3000C15 16GB DDR4-3000
Video Card(s) EVGA GeForce RTX 2060 XC ULTRA GAMING
Storage 512GB Intel 545s ssd 500GB ADATA SU800 ssd 1TB WD blue
Display(s) Cheap VA panel
Case Phanteks P300
Audio Device(s) onboard
Power Supply HX 750i
Mouse M65 Pro RGB
Keyboard K70 RGB
Software Windows 10 +startisback
I would be using lquid metal on that to get the temps under-control that laptop as unclewebb says is simply under-cooled and lenovo has opted to apply a software fix for a hardware problem
for gaming you may want to consider just running it with hyper threading disabled this MAY lower the thermal output considerably and allow the cpu to stay above that magical 3.5Ghz mark

HT off and liquid metal I would expect you to drop at least 10c off the temps if not more
 
Joined
Jun 29, 2009
Messages
1,294 (0.32/day)
Location
Heart of Europe
System Name ibuytheusedstuff
Processor 5960x
Motherboard x99 sabertooth
Cooling water
Memory 32 dual ranked
Video Card(s) 1080ti on morpheus 1
Storage raptors+ssd
Display(s) acer 120hz
Case open bench
Power Supply antec 1200 oc
Mouse mx 518
Keyboard roccat arvo
i am with OneMoar on this with HT=off
moar then 6 cores mostly not needed on games or even faster on some then with hyperthreading
 

tparty42

New Member
Joined
Jul 30, 2020
Messages
7 (1.40/day)
Hi,
I'm having a similar problem with power limit throttling constantly on high load. I have an Alienware M15 R2, i7-9750H and RTX 2060. I've repasted the CPU/GPU with thermal grizzly kryonaut. I get major FPS drops while playing now and I've been running stress tests with Prime95 and TS has shown constant PL1 throttle. I've undervolted core and cache to the same -.125, I haven't changed the PL1 or PL2 from what they were when I opened Throttlestop, they were both set at 90 but it looks like it is throttling at 45. Are there some settings that I am missing? The PL1 doesn't seem to take.

Thanks for any help!
 

Attachments

Joined
May 10, 2020
Messages
159 (1.85/day)
Hi,
I'm having a similar problem with power limit throttling constantly on high load. I have an Alienware M15 R2, i7-9750H and RTX 2060. I've repasted the CPU/GPU with thermal grizzly kryonaut. I get major FPS drops while playing now and I've been running stress tests with Prime95 and TS has shown constant PL1 throttle. I've undervolted core and cache to the same -.125, I haven't changed the PL1 or PL2 from what they were when I opened Throttlestop, they were both set at 90 but it looks like it is throttling at 45. Are there some settings that I am missing? The PL1 doesn't seem to take.

Thanks for any help!
Put x to the turbo long powe max clamp. Change short to 120 and pp0 to 200. Enable speedsift at start.

edit. but im sorry to say that I think dell is the one of the worst laptop. I think they are blocking everything. But you can try.
 
Last edited:

tparty42

New Member
Joined
Jul 30, 2020
Messages
7 (1.40/day)
Hey thanks! I'm going to try it, for pp0 to 200, is that current limit or power limit? Should I check any boxes in there?
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,017 (0.45/day)
@tparty42 - Some Dell laptops set a hard long term power limit at 45W. This limit is used and the 90W limits you have set in ThrottleStop are ignored. There is no easy way around this limitation. Your screenshot shows power limit throttling. This is the limit that you are up against. The current limit is OK.

Your log file shows that Dell was really generous. Instead of setting the internal power limit to 45W like some laptops do, they set your laptop to 47W. It is impossible to get maximum performance out of the 9750H when it is being limited to 45W or 47W. These CPUs can easily go up over 70W if the power limits are unlocked and if the cooling is adequate.

Do some Cinebench R20 testing when adjusting your voltages. The 9750H can benefit if you set the CPU core voltage offset to a much bigger number compared to the cache. These do not need to be set equal. Up to -200 mV for the core works well.
 

tparty42

New Member
Joined
Jul 30, 2020
Messages
7 (1.40/day)
Thanks for the info, I'm testing things out with it. Is there no way to change the limit in the BIOS or some other method?
 
Joined
May 10, 2020
Messages
159 (1.85/day)
Its just like unclewebb said. There is ways to "fix" that. But Im not going to link anything, if youre rdy to void your warranty etc pm me.
 

tparty42

New Member
Joined
Jul 30, 2020
Messages
7 (1.40/day)
Hey thanks ereko, I might take you up on that if I can't figure out performance... I have adjusted my core voltage offset to -190mV and I am still getting FPS drops in game. I've also opened up GPU-Z and logged that. It looks like I am getting VRel perf cap now when the frame rate drops and sitting at Idle the majority of time which I guess is normal? Are these settings related or is there some way that I can tinker to fix the VRel cap?
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,017 (0.45/day)
@tparty42 - Your first log file showed lots of power limit throttling at 45W. Your second log file does not show any power limit throttling but the CPU is being deliberately limited to the 29 or 30 multiplier so your is being limited to a max of 3.0 GHz. By best guess is that your computer comes with some Alienware software that is forcing this level of performance on you. Personally, I would ditch any factory software like that in a heartbeat.

If you want to keep that software, open it up and see if there is any max performance setting. The performance you are getting has your CPU running at 75% of its rated speed.
 

tparty42

New Member
Joined
Jul 30, 2020
Messages
7 (1.40/day)
Hey unclewebb, I am thinking that it is probably the alienware command center. That is meant to control the power level, fan speed, etc. I'll get rid of it and do some more tests but I'm not sure if there would be something else controlling that as well.

So I uninstalled the command center and have been running tests with cinebench and just as you said I see it has the multiplier at 31 and not going above that, so limiting the CPU. I thought maybe it was not recognizing my power adapter correctly so I checked the BIOS and the AC adapter shows up as 240, not unknown, so it knows it's the factory adapter. Where should I be looking for settings that are limiting the multiplier or what can I try to change?
 

Attachments

Last edited:

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,017 (0.45/day)
@tparty42 - Something is not right. Are you using a Dell power profile? Open a command window and type in this command.

powercfg /s SCHEME_MIN

This will switch to the default Windows high performance power profile. The power profile you are using might have the Maximum processor state set below 100%.

Change the SpeedShift EPP value on ThrottleStop's main screen from 128 to 0. Just click on that value and edit it. Double check the Speed Shift Max value in the TPL window. Default Max is 45. Double check your turbo ratio limits. Default for them is 45, 44, 43, 42, 41, 40. Make sure all profiles are set the same.

Open up ThrottleStop and try running something simple like a TS Bench test. First try a 1 Thread test and see what multiplier ThrottleStop reports and then do another full load test. Open up Limit Reasons and watch for anything lighting up in red.

If you are still having problems, try running the Dump program so I can have a look at what values your CPU registers are set to.

DufusDump

This program will create a simple text file. You can attach it to your next post or copy and paste the data to www.pastebin.com and post a link here.
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,017 (0.45/day)
Your log file shows that your CPU is running at the full 40.00 multiplier which is correct when all 6 cores are active. It only drops down after PL1 throttling starts. Your Alienware is ignoring your 90W request in ThrottleStop and is enforcing a 47W limit internally. This is why Alienware laptops are not what they used to be. As an enthusiast that is willing to pay top dollar for a laptop, you should be able to run it however you like. Alienware is in charge of your laptop's performance, not you.

The problem with the MHz being locked to a low level might only happen when the Nvidia GPU is active. This could be another Alienware feature that Dell forgot to mention in their sales documentation. Run another log file while gaming. Check the Multi column and see if your CPU is being limited to the 29, 30 or 31 multiplier. If you can ALT+TAB back out to the desktop, try running DufusDump again. It might show what register is being used to control your CPU speed. Your previous Dump file was OK because your CPU was running at its rated speed.

You might be able to trigger this throttling by running something simple like the GPU-Z render test in a small window on screen. Maybe that much Nvidia GPU usage will trigger CPU multiplier throttling. Try to solve this problem before adjusting the core voltage any further. Save that for later.
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,921 (2.10/day)
Location
Rochester area
System Name RPC MK2
Processor Intel Core i5 9600K@ 4.8Ghz 1.32V
Motherboard Asrock z390 phantom gaming 4
Cooling Enermax ets-t50
Memory CMK16GX4M2B3000C15 16GB DDR4-3000
Video Card(s) EVGA GeForce RTX 2060 XC ULTRA GAMING
Storage 512GB Intel 545s ssd 500GB ADATA SU800 ssd 1TB WD blue
Display(s) Cheap VA panel
Case Phanteks P300
Audio Device(s) onboard
Power Supply HX 750i
Mouse M65 Pro RGB
Keyboard K70 RGB
Software Windows 10 +startisback
kind of derailing the Op's thread here can we nudge this to its own thread ?
 

LowResTexture

New Member
Joined
Aug 1, 2020
Messages
1 (0.33/day)
Your log file shows that your CPU is running at the full 40.00 multiplier which is correct when all 6 cores are active. It only drops down after PL1 throttling starts. Your Alienware is ignoring your 90W request in ThrottleStop and is enforcing a 47W limit internally. This is why Alienware laptops are not what they used to be. As an enthusiast that is willing to pay top dollar for a laptop, you should be able to run it however you like. Alienware is in charge of your laptop's performance, not you.

The problem with the MHz being locked to a low level might only happen when the Nvidia GPU is active. This could be another Alienware feature that Dell forgot to mention in their sales documentation. Run another log file while gaming. Check the Multi column and see if your CPU is being limited to the 29, 30 or 31 multiplier. If you can ALT+TAB back out to the desktop, try running DufusDump again. It might show what register is being used to control your CPU speed. Your previous Dump file was OK because your CPU was running at its rated speed.

You might be able to trigger this throttling by running something simple like the GPU-Z render test in a small window on screen. Maybe that much Nvidia GPU usage will trigger CPU multiplier throttling. Try to solve this problem before adjusting the core voltage any further. Save that for later.

Hello sir, how you doing? I hope you are very well.

I´m new in the community of throattlestop and undervolting, i got my first good laptop just 2 months ago for university and somo mid gaming. I´ve been searching A LOT, reading forums in spanish and english, asking friends and people that i know they know pc stuff and nobody could help me, recently i downloaded a profile of throattlestop (it is an old version) and tweak that up a little bit. Hope you can help me sir. I´ll let you atach all the info that i could get from the app. The picture that show yellow Pl and edp was taken just closing the game.

Hope you can help me ! Have a nice day

EDIT: The last picture was taken just a few minutes ago while benchmarking
 

Attachments

Last edited:
Top