• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Failed to use desktop vga with laptop. (eGPU)

Joined
Jun 2, 2021
Messages
23 (0.02/day)
Hello!
The continuation of the adapter story did not go well. In the meantime, I bought a similar laptop with more powerful hardware. A Clevo P751TM1 laptop because of the more powerful CPU.
Now the problem is that there is no internal screen. Only the external monitor display is logged in. I heard that there is no IGP here, so the situation is different.
The bios is unlocked.
Could you help me with that?
1, where can I find the IGP unlock? I would like to use it.
2, how can I project an external vga image onto the laptop display?
(no mxm vga)

How does Clevo laptop hardware and bios work? I don't dare try very hard, I'm afraid of the black screen. What can I safely try? I'll post some photos.
((the previous MSI laptop is also there.....not for sale! :) ))
 

Attachments

  • IMG_20220901_144343.jpg
    IMG_20220901_144343.jpg
    772.9 KB · Views: 185
  • IMG_20220901_150506.jpg
    IMG_20220901_150506.jpg
    711.1 KB · Views: 179
  • IMG_20220901_151016.jpg
    IMG_20220901_151016.jpg
    893.8 KB · Views: 179
  • Képernyőfelvétel (108).jpg
    Képernyőfelvétel (108).jpg
    219.2 KB · Views: 223
  • IMG_20220913_130345.jpg
    IMG_20220913_130345.jpg
    994.3 KB · Views: 193
  • IMG_20220901_145737.jpg
    IMG_20220901_145737.jpg
    731.4 KB · Views: 195

dhampir_x

New Member
Joined
Sep 25, 2022
Messages
5 (0.01/day)
hey, I bought the same dock and I am trying it on my GT60 using GTX980. When I connected everything and turned on the power and the laptop, the fan on the gpu and power supply just turned on for one second and stopped. The dock did not power on. Do you know what might be causing this?
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
hey, I bought the same dock and I am trying it on my GT60 using GTX980. When I connected everything and turned on the power and the laptop, the fan on the gpu and power supply just turned on for one second and stopped. The dock did not power on. Do you know what might be causing this?
Interesting, unfortunately I have no idea. My bios is unlocked. Is the desktop power supply OK? Bios setting (SG is the internal display and Auto or PCIe is the external monitor with HDMI connection.)
Maybe I need another bios?

Now I use a Clevo laptop. There is only an external display (no igpu). When I start it, the fan stops for a moment. But then it starts and runs fine. Interesting. Did you buy the X16 version? The lossless version?
You have to open the bios and see what is set.
https://www.techinferno.com/index.php
Look for the GT60-70 topic. And look for the bios moderator named KLem. I got bios opening from him a long time ago, it helped a lot. It's even good in private. I gave him beer money. :)
 

dhampir_x

New Member
Joined
Sep 25, 2022
Messages
5 (0.01/day)
Interesting, unfortunately I have no idea. My bios is unlocked. Is the desktop power supply OK? Bios setting (SG is the internal display and Auto or PCIe is the external monitor with HDMI connection.)
Maybe I need another bios?

Now I use a Clevo laptop. There is only an external display (no igpu). When I start it, the fan stops for a moment. But then it starts and runs fine. Interesting. Did you buy the X16 version? The lossless version?
You have to open the bios and see what is set.
https://www.techinferno.com/index.php
Look for the GT60-70 topic. And look for the bios moderator named KLem. I got bios opening from him a long time ago, it helped a lot. It's even good in private. I gave him beer money. :)
Yea I bought the x16 version and quite a while ago. I only set it up recently. I checked my power supply and graphic card on a desktop and they powered up just fine. I just hope the dock is not faulty. With GT70, does the dock turn on without the graphic card when plugged in to the laptop? Just wondering if there is a way to check if the dock is faulty. It would be nice to know it is the faulty dock and not my incompetence.

I will give an unlocked bios a go, I have the locked version and I am running out of ideas what else to try but I suspect it probably won't make a difference, I expect the dock to at least power up when plugged in to my GT60 :(

Anyway, thanks for your reply. As with your P751tm1, I am pretty sure it doesn't support optimus so no graphic switching options to unlock. If you want to utilize the internal screen while using the dock, I think the best bet is to stick with models that support optimus like GT60, GT70 and for clevo's old p15x, p17x, p37x models, I owned a P150em before.
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Yea I bought the x16 version and quite a while ago. I only set it up recently. I checked my power supply and graphic card on a desktop and they powered up just fine. I just hope the dock is not faulty. With GT70, does the dock turn on without the graphic card when plugged in to the laptop? Just wondering if there is a way to check if the dock is faulty. It would be nice to know it is the faulty dock and not my incompetence.

I will give an unlocked bios a go, I have the locked version and I am running out of ideas what else to try but I suspect it probably won't make a difference, I expect the dock to at least power up when plugged in to my GT60 :(

Anyway, thanks for your reply. As with your P751tm1, I am pretty sure it doesn't support optimus so no graphic switching options to unlock. If you want to utilize the internal screen while using the dock, I think the best bet is to stick with models that support optimus like GT60, GT70 and for clevo's old p15x, p17x, p37x models, I owned a P150em before.
There's my story at the beginning. I also own an MSI GT70 laptop and everything is fine with it (almost!)
1, turn on the adapter (be powered on)
2, start the laptop.
It is important that ACPI is disabled in the device manager (there will be no battery) gpu-z will be fine then. Read back, it's written for me how it was solved. Is everything connected well? (Photo)

Clevo: External display with HDMI port is perfect. I just bought this one.
https://ipon.hu/shop/termek/hannspr...yB4t2lhjItrDEE91lxClNdk4mrSRsR6RoCnhkQAvD_BwE
There will also be an internal display...it has HDMI. Show me bios photos when the bios is open.

A tip from someone, try it. Bios unlock key. I don't know if it works or not.
"press right shift, right control, left alt, f2 -> you have to press it after entering bios, it works for most models."
 

Attachments

  • IMG_20220925_151712.jpg
    IMG_20220925_151712.jpg
    860.7 KB · Views: 76

dhampir_x

New Member
Joined
Sep 25, 2022
Messages
5 (0.01/day)
There's my story at the beginning. I also own an MSI GT70 laptop and everything is fine with it (almost!)
1, turn on the adapter (be powered on)
2, start the laptop.
It is important that ACPI is disabled in the device manager (there will be no battery) gpu-z will be fine then. Read back, it's written for me how it was solved. Is everything connected well? (Photo)

Clevo: External display with HDMI port is perfect. I just bought this one.
https://ipon.hu/shop/termek/hannspr...yB4t2lhjItrDEE91lxClNdk4mrSRsR6RoCnhkQAvD_BwE
There will also be an internal display...it has HDMI. Show me bios photos when the bios is open.

A tip from someone, try it. Bios unlock key. I don't know if it works or not.
"press right shift, right control, left alt, f2 -> you have to press it after entering bios, it works for most models."
Can you confirm the exact time the dock and the gpu got turned on in your case? Did it turn on as soon as you turned on the computer power supply or as soon as you turned on your laptop or when you got to Windows?

I think I get the connection right (see photo). I also tried to connect the dock to my friend’s Dell M6700 today but same thing happened..the gpu and psu fan turned and then a “click” sound then nothing was on. I am starting to think that the dock could be faulty :(
 

Attachments

  • 16B02558-99CA-449C-B6B0-CFEECE9F7DEF.jpeg
    16B02558-99CA-449C-B6B0-CFEECE9F7DEF.jpeg
    1.6 MB · Views: 114
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Can you confirm the exact time the dock and the gpu got turned on in your case? Did it turn on as soon as you turned on the computer power supply or as soon as you turned on your laptop or when you got to Windows?

I think I get the connection right (see photo). I also tried to connect the dock to my friend’s Dell M6700 today but same thing happened..the gpu and psu fan turned and then a “click” sound then nothing was on. I am starting to think that the dock could be faulty :(
When I turn on the laptop, the dock starts immediately and the fan spins. The led on the dock starts to light up and work only after the laptop is switched on.

Is the mxm connector not damaged? Or just dirty? Based on the photo, it looks ugly.
 

dhampir_x

New Member
Joined
Sep 25, 2022
Messages
5 (0.01/day)
When I turn on the laptop, the dock starts immediately and the fan spins. The led on the dock starts to light up and work only after the laptop is switched on.

Is the mxm connector not damaged? Or just dirty? Based on the photo, it looks ugly.
Yea, the dock was sitting on my work shelf collecting dust before I finally had time and patience to test it out. Looks like it could be the mxm connector or the dock. I think I will just get another one to test it sometime later. I will keep you updated if I get one running if you like. Thanks for your help and congratulation for getting yours running well.
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Yea, the dock was sitting on my work shelf collecting dust before I finally had time and patience to test it out. Looks like it could be the mxm connector or the dock. I think I will just get another one to test it sometime later. I will keep you updated if I get one running if you like. Thanks for your help and congratulation for getting yours running well.
Yes, if there is anything, please let me know!
(((According to my friends, there is a problem with the power supply. The power supply is weak. Another desktop power supply?))))...I know you said you tested it separately......
I have shared the problem with others if you don't mind.

Yes, if there is anything, please let me know!
(((According to my friends, there is a problem with the power supply. The power supply is weak. Another desktop power supply?))))...I know you said you tested it separately......
I have shared the problem with others if you don't mind.
I would like to fix it.....several people say that you have the wrong bios version on your machine!
They read what you wrote. That's what they're betting on.
 
Last edited:

dhampir_x

New Member
Joined
Sep 25, 2022
Messages
5 (0.01/day)
Yes, if there is anything, please let me know!
(((According to my friends, there is a problem with the power supply. The power supply is weak. Another desktop power supply?))))...I know you said you tested it separately......
I have shared the problem with others if you don't mind.


I would like to fix it.....several people say that you have the wrong bios version on your machine!
They read what you wrote. That's what they're betting on.
Ok, I will see what I can do with changing the bios. I have not tried flashing a bios in my machine.
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
IMG_20220930_202359.jpg
IMG_20220930_211854.jpg
 

Attachments

  • IMG_20221001_221807.jpg
    IMG_20221001_221807.jpg
    1.1 MB · Views: 85
  • IMG_20221001_221820.jpg
    IMG_20221001_221820.jpg
    789.3 KB · Views: 88
  • IMG_20221001_222209.jpg
    IMG_20221001_222209.jpg
    782.3 KB · Views: 98
Last edited:
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Upgrade.....Geforce RTX 3080 Ti
 

Attachments

  • IMG_20221020_004340.jpg
    IMG_20221020_004340.jpg
    788.1 KB · Views: 123
  • Képernyőfelvétel (310).jpg
    Képernyőfelvétel (310).jpg
    131.5 KB · Views: 145
  • Képernyőfelvétel (316).jpg
    Képernyőfelvétel (316).jpg
    298.3 KB · Views: 145
  • Képernyőfelvétel (334).jpg
    Képernyőfelvétel (334).jpg
    223.7 KB · Views: 122
  • Képernyőfelvétel (335).jpg
    Képernyőfelvétel (335).jpg
    212.5 KB · Views: 120
  • Képernyőfelvétel (336).jpg
    Képernyőfelvétel (336).jpg
    178.1 KB · Views: 112
  • Képernyőfelvétel (337).jpg
    Képernyőfelvétel (337).jpg
    180.4 KB · Views: 102
  • Képernyőfelvétel (338).jpg
    Képernyőfelvétel (338).jpg
    166 KB · Views: 101
  • Képernyőfelvétel (340).jpg
    Képernyőfelvétel (340).jpg
    229 KB · Views: 107
  • IMG_20221021_232845.jpg
    IMG_20221021_232845.jpg
    573.6 KB · Views: 113

zex4

New Member
Joined
Jan 7, 2023
Messages
2 (0.00/day)
this project is insane tbh i have also a clevo p775dm3 with unlocked bios for years now but sadly the original 1060 dying slowly after many repairs until now :(

how are you doing so far ? everything is still working ?
 

Tecchie

New Member
Joined
Jan 7, 2024
Messages
3 (0.02/day)
Hello!
The continuation of the adapter story did not go well. In the meantime, I bought a similar laptop with more powerful hardware. A Clevo P751TM1 laptop because of the more powerful CPU.
Now the problem is that there is no internal screen. Only the external monitor display is logged in. I heard that there is no IGP here, so the situation is different.
The bios is unlocked.
Could you help me with that?
1, where can I find the IGP unlock? I would like to use it.
2, how can I project an external vga image onto the laptop display?
(no mxm vga)

How does Clevo laptop hardware and bios work? I don't dare try very hard, I'm afraid of the black screen. What can I safely try? I'll post some photos.
((the previous MSI laptop is also there.....not for sale! :) ))

Edit to add that I've been a long time lurker, like 15+ years and thought I had an account, apparently I did not.. haha


Wanted to say I have the P775DM-G, Z170 chipset, fully unlocked and modified BIOS.

I will tell you on these Clevo series of Desktop replacement laptops, DO NOT enable the iGPU. There is no MUX circuit and you will end up with a blank display. If this happens, you'll have to reset the BIOS by holding FN + D if memort serves. I believe right when you power it up.. hold those two keys.

Mine is modified by DSANKE to also have the CoffeeTime mods, inclduing support for Xeons and up to the i9-9900K (onlly requiring to cover a few pads on the bottom of the CPU). But I was looking into playing with this MXM extesion adapter but the x16 version.. I wish there was a US seller so I could get it faster

I currently have a i7-6700K and 64GB of ram, plus a GTX 970m 6GB.


my point is these models mostly don;'t have the MUX chip to use the iGPU..
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Hello! I've been around here a long time.
Sorry, I see a few wrote to me and I didn't reply. A new upgrade, this is a report. I'm absolutely satisfied. It looks like I'm the only one using this miracle adapter courtesy of a genius Chinese engineer.
I wish you could see what you created in 2019. It would have been nice to meet you. This is laptop hardware. I travel with it from table to table without a house. I really like it, despite a couple of shortcomings in terms of compatibility. There are no new deficiencies, only what was there before. Everything is old and better, faster. i9-9900K....I don't care about the cpu limit. It has water cooling. The performance is sufficient...it has many fps and remains my old favorite laptop. /Clevo p751tm1/ But there is also the old MSI GT70 laptop and it is also suitable from this point of view, it also works with the new hardware.:)
 

Attachments

  • Képernyőfelvétel (2248).jpg
    Képernyőfelvétel (2248).jpg
    169.8 KB · Views: 25
  • Képernyőfelvétel (2252).jpg
    Képernyőfelvétel (2252).jpg
    171.2 KB · Views: 25
  • Képernyőfelvétel (2232).jpg
    Képernyőfelvétel (2232).jpg
    163.1 KB · Views: 22
  • Képernyőfelvétel (2233).jpg
    Képernyőfelvétel (2233).jpg
    159.5 KB · Views: 22
  • Képernyőfelvétel (2234).jpg
    Képernyőfelvétel (2234).jpg
    182.7 KB · Views: 19
  • Képernyőfelvétel (2236).jpg
    Képernyőfelvétel (2236).jpg
    137.8 KB · Views: 22
  • Képernyőfelvétel (2237).jpg
    Képernyőfelvétel (2237).jpg
    144.4 KB · Views: 22
  • Képernyőfelvétel (2239).jpg
    Képernyőfelvétel (2239).jpg
    163.7 KB · Views: 26
  • IMG_20240425_123109.jpg
    IMG_20240425_123109.jpg
    679.8 KB · Views: 19
  • IMG_20240425_124555.jpg
    IMG_20240425_124555.jpg
    863.9 KB · Views: 27
  • Képernyőfelvétel (2225).jpg
    Képernyőfelvétel (2225).jpg
    277.6 KB · Views: 29
  • Képernyőfelvétel (2195).jpg
    Képernyőfelvétel (2195).jpg
    169.7 KB · Views: 28

SuperMacro

New Member
Joined
Feb 24, 2024
Messages
5 (0.04/day)
1, where can I find the IGP unlock? I would like to use it.
2, how can I project an external vga image onto the laptop display?
(no mxm vga)
I would find HDMI adaptor board to the screen currently in your laptop.

I too would like to enable iGPU, but only for QuickSync
 
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Yes, with this laptop (clevo p751tm1) only hdmi and external display. The cpu igpu part is disabled. Clevo laptops disable the internal graphics controller by hardware.
I am currently using a portable external display attached to the laptop display. It is also an hdmi connection from the graphics card.
Different laptop, open bios, internal display is possible where there is igpu.

Well, this adapter is not popular, maybe it's just me using it. :)
 

SuperMacro

New Member
Joined
Feb 24, 2024
Messages
5 (0.04/day)
Yes, with this laptop (clevo p751tm1) only hdmi and external display. The cpu igpu part is disabled. Clevo laptops disable the internal graphics controller by hardware.
I am currently using a portable external display attached to the laptop display. It is also an hdmi connection from the graphics card.
Different laptop, open bios, internal display is possible where there is igpu.

Well, this adapter is not popular, maybe it's just me using it. :)
I mean connect this to your screen in the laptop lid: https://www.aliexpress.us/item/2255800003128861.html
Or this:

I considered the adapter you used, but there were RTX3080 Clevo MXM for $300 available here for a short time, I purchased a P750TM1 to put it in because the P870 is too large and only x8 lanes. Your adapter might work with my P870DM because it has a spare MXM slot. $100 for adapter only is too much for me, maybe later. And now I have an extra 1070 removed from P750TM1 I can do SLi in the P870. (I do have M.2 to PCIe adapter, and an MXM to M.2 Adapter is only $10).
 
Last edited:
Joined
Jun 2, 2021
Messages
23 (0.02/day)
Thanks for your help! I will show it to a laptop mechanic friend.:toast:

I'll stick with the current lineup. It's ready and running. Next year there will be an upgrade to a desktop rtx "5080" vga. This gives me the speed I want.
Portability itself became a secondary consideration for me, but it's still not impossible, all elements can fit in a backpack.

No other solution tempts me, because this is the best that exists. All you need is a table.
 

SuperMacro

New Member
Joined
Feb 24, 2024
Messages
5 (0.04/day)
Thanks for your help! I will show it to a laptop mechanic friend.:toast:

I'll stick with the current lineup. It's ready and running. Next year there will be an upgrade to a desktop rtx "5080" vga. This gives me the speed I want.
Portability itself became a secondary consideration for me, but it's still not impossible, all elements can fit in a backpack.

No other solution tempts me, because this is the best that exists. All you need is a table.
I know it's not a laptop, but I chose a PIO motherboard with an i5-12500 (https://www.cpubenchmark.net/compare/3593vs4675/Intel-i9-9900KS-vs-Intel-i5-12500). I am still working on a case to hold cards 200-400mm. But it is only as thin as the GPU . Motherboard was cheap at $75 plus shipping with Superbuy, $24.

 
Top