• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Gainward gtx 1070 ti reviving

samto

New Member
Joined
Jun 1, 2020
Messages
1 (0.03/day)
Hello guys,
so i bought gtx 1070 ti in aftermarket. Long story short it was described as no posting card. Seller tried to change motherboard and card just magically dead. He described it as error 43.
After i bring it home and put it in my system everything seems as he described. No post, black screen. System detecting card as it is - gtx 1070 ti (add photo devicemanager.png) First I tried everything from driver installation, rolling back drivers, turning the device off, enabling/disabling. Nothing worked, so I downloaded and looked in gpu-z (add photo named gainward.gif).
So as it looks vbios broken. I tried to look up in vbios database in tpu - found one. After flashing bios appeared but there is no size of memory detectable (add photo f.gif, sensors.gif). As nvflash said i restarted the system. After restarting - gpu-z showing that bios is unknown and everything broken as before (add photo after.gif).
Any ideas guys? What's up with that card and is there any method to fix it? Looking at pcb, shroud and fan - card looks as new, nothing burnt or broken.
Also adding serial number (serial number.jpg) and my system specification (system.png)

Thanks in advance
 

Attachments

Joined
May 8, 2016
Messages
1,036 (0.68/day)
System Name BOX
Processor Xeon E5-1680 v2 @ 4,3GHz
Motherboard Sabertooth X79 (BIOS 4801 + NVMe mod + uCode update)
Cooling Thermalright Venomous-X (w/LGA 2011 kit) + 2x Delta PWM Push-Pull
Memory 8x A-Data Xtreme 2000X 2GB (1868MHz CL8.9.8.24 CR2T @ 1,65V)
Video Card(s) ASUS GTX 1080 (FE)
Storage Samsung SM961 256GB NVMe, RAID0 2x WD10EZEX (1TB), HGST HUS726060ALE610 (6TB)
Display(s) Samsung T240
Case NZXT Tempest (Nanoflux/PWM fans only, some w/LEDs)
Audio Device(s) ASUS Essence ST Deluxe 7.1
Power Supply Seasonic X-760 (760W)
Mouse Roccat Savu
Keyboard Logitech UltraXPremium
Software Windows 10 Pro x64
Benchmark Scores https://www.passmark.com/baselines/V9/display.php?id=108080818886
Probably BGA under GPU, maybe one (or more) VRAM chip are dead/damaged.
 

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
2,304 (0.43/day)
See this thread to learn how to recover from a bad video BIOS flash.

Here is a copy of the original BIOS: https://www.techpowerup.com/vgabios/196761/196761

Uninstall all display drivers and then perform a cleanup with Display Driver Uninstaller (DDU) from safe mode.

Carefully remove the heatsink from the graphics card and clean the fans with a toothbrush.

Clean the graphic cards with isopropyl alcohol and cotton swabs. Especially the GPU area and PCIe pins.

When you're done, reapply thermal paste on the GPU, remount the heatsink, plug it back in.

Download and install the latest drivers from Nvidia's website.

If the graphics card still doesn't work, check if it's under warranty, if it is, just RMA it.

If warranty expired, consider sending it to graphics cards repair lab, if there isn't any in your area, you can try the oven trick as the last resort.
 
Top