• We've upgraded our forums. Please post any issues/requests in this thread.

GTA IV low frame rate, and lock up issues

Joined
Nov 7, 2007
Messages
1,471 (0.40/day)
Likes
124
Location
The Peoples Republic of New South Jersey
System Name The Grand Phoenix Clusterflop
Processor AMD Phenom II X4 965 Black Edition Deneb @3.4GHz
Motherboard ASRock 870 EXTREME3
Cooling Xigmatec S1284 (Lapped)1x200mm, 4x120mm
Memory Muskin Silverline 4GB DDR3 1333 (PC3 10666) 9-9-9-24
Video Card(s) eVGA GTX 470 SC Edition 1280mb RAM (C/S/M)(640/1280/1705)
Storage 2x500GB Seagate, 32MB Cache 1xWD 40GB UMD IDE Hdd.
Display(s) SAMSUNG 22" LCDTV HD Monitor and Samsung 24"
Case COOLER MASTER RC-690
Audio Device(s) USB 2.0 Sound (USB out to my Stero System)
Power Supply Thermaltake XT TPX-775M 775W
Software Windows XP Home SP3
#1
Ok so when ever i get out of the building where the player lives the frame rates go from 55sh to 25fps, then if i get into a car LOL down to 10-12 fps.

I have tried different graphics drivers, and patches for the game, even dropped down my filtering to tri linear, and my draw distance down low, but it still does this.

Any ideas from fellow GTA players.:banghead:
 

Bo$$

Lab Extraordinaire
Joined
May 7, 2009
Messages
5,626 (1.79/day)
Likes
971
Location
London, UK
System Name Desktop | Server
Processor Intel i7 2700k @ 4.4GHZ | AMD 5350 @ 2500MHZ
Motherboard Asus P7Z77-V Pro | Asus AM1I-A
Cooling GeLID Tranquilo | Stock Air
Memory Crucial Ballistix 2x8GB CL8 1600MHZ | Corsair Vengence 2x4GB CL9 1600MHZ
Video Card(s) Gainward GTX 780 Phantom GLH | PNY GTX 750Ti
Storage Samsung 840 EVO 250GB + 4TB WD Red | 2x Seagate Barracuda 2TB
Display(s) Samsung S27D390H + Asus VE276Q | Headless
Case Fractal Design R5 | CM Elite 110
Audio Device(s) Asus Xonar D1 w/Otone Stilo 5.1 and Creative Fatal1ty headset
Power Supply EVGA Supernova 850 G2| Corsair CX430M
Mouse Razer Imperator 2012
Keyboard Corsair K90
Software Windows 7 SP1 X64 | Ubuntu 16.04LTS
#2
Ok so when ever i get out of the building where the player lives the frame rates go from 55sh to 25fps, then if i get into a car LOL down to 10-12 fps.

I have tried different graphics drivers, and patches for the game, even dropped down my filtering to tri linear, and my draw distance down low, but it still does this.

Any ideas from fellow GTA players.:banghead:
fully patched? even my brothers 3850 + q6600 gets more than that?!
 
Joined
Nov 7, 2007
Messages
1,471 (0.40/day)
Likes
124
Location
The Peoples Republic of New South Jersey
System Name The Grand Phoenix Clusterflop
Processor AMD Phenom II X4 965 Black Edition Deneb @3.4GHz
Motherboard ASRock 870 EXTREME3
Cooling Xigmatec S1284 (Lapped)1x200mm, 4x120mm
Memory Muskin Silverline 4GB DDR3 1333 (PC3 10666) 9-9-9-24
Video Card(s) eVGA GTX 470 SC Edition 1280mb RAM (C/S/M)(640/1280/1705)
Storage 2x500GB Seagate, 32MB Cache 1xWD 40GB UMD IDE Hdd.
Display(s) SAMSUNG 22" LCDTV HD Monitor and Samsung 24"
Case COOLER MASTER RC-690
Audio Device(s) USB 2.0 Sound (USB out to my Stero System)
Power Supply Thermaltake XT TPX-775M 775W
Software Windows XP Home SP3
#3
fully patched? even my brothers 3850 + q6600 gets more than that?!
what OS is he running, and im wondering if my brother put that god mode patch into the game, knowing him he wanted to put some home made trainer in it.
 

Bo$$

Lab Extraordinaire
Joined
May 7, 2009
Messages
5,626 (1.79/day)
Likes
971
Location
London, UK
System Name Desktop | Server
Processor Intel i7 2700k @ 4.4GHZ | AMD 5350 @ 2500MHZ
Motherboard Asus P7Z77-V Pro | Asus AM1I-A
Cooling GeLID Tranquilo | Stock Air
Memory Crucial Ballistix 2x8GB CL8 1600MHZ | Corsair Vengence 2x4GB CL9 1600MHZ
Video Card(s) Gainward GTX 780 Phantom GLH | PNY GTX 750Ti
Storage Samsung 840 EVO 250GB + 4TB WD Red | 2x Seagate Barracuda 2TB
Display(s) Samsung S27D390H + Asus VE276Q | Headless
Case Fractal Design R5 | CM Elite 110
Audio Device(s) Asus Xonar D1 w/Otone Stilo 5.1 and Creative Fatal1ty headset
Power Supply EVGA Supernova 850 G2| Corsair CX430M
Mouse Razer Imperator 2012
Keyboard Corsair K90
Software Windows 7 SP1 X64 | Ubuntu 16.04LTS
#4
what OS is he running, and im wondering if my brother put that god mode patch into the game, knowing him he wanted to put some home made trainer in it.
he has XP SP3 X86, i run 7 X64 neither of us suffer from ANY lag at all in missons or multiplayer

maybe they modified the config files or something, try a clean install of GTA?
 
Joined
May 17, 2008
Messages
405 (0.12/day)
Likes
47
Location
Bulgaria
System Name HAF
Processor i5 3570k @ 4.2GHz
Motherboard AsRock Z77 EXTREME 4
Cooling XIGMATEK HDT-SD964
Memory 2 x 4GB Corsair Vengance 1600MHz
Video Card(s) EVGA GTX670 FTW
Storage Seagate 250GB
Display(s) LG 24' + Samsung 22'
Case HAF 922
Power Supply CoolerMaster GX750W
Software Windows 7 x64
#5
Try using Patch 1.0.4.0, it's not the latest but the patches after it drops the average FPS dramatically. Although you can try to disable the shadows in the video settings to gain fps boost
 
Joined
Jul 21, 2008
Messages
4,434 (1.29/day)
Likes
1,050
Location
Clifton Park, NY
System Name [Uber Noober Setup]
Processor [i7 3770K]
Motherboard [MSI P67A-G45(B3)]
Memory [32GB Corsair Vengeance (8GBx4)]
Video Card(s) [EVGA GTX 1080]
Storage [128GB OCZ VTX4 SSD, 2TB Internal HDD]
Display(s) [2x 27" ASUS at 1920x1080p - 1x 34" Samsung at 1440p]
Case [Coolermaster CM 690]
Audio Device(s) [X-Fi XtremeGamer]
Power Supply [CORSAIR 850W]
Software [Windows 10 64-Bit]
#6
This game is the most unoptimized shit coding experience on the pc... performance is all over the map so theirs a chance nothing you do will make a difference
 
Joined
Jun 2, 2007
Messages
5,105 (1.33/day)
Likes
1,249
Location
Kansas
Processor Core i5 3570K
Motherboard AsRock z77 Pro4
Cooling Zalman CNPS10X Extreme
Memory 2x4GB GSkill Sniper
Video Card(s) MSI GTX970 Gaming
Storage 240GB OCZ ARC 100, Samsung Spinpoint F3 1TB
Display(s) LG 23" 1920x1080
Case Antec P100
Audio Device(s) Onboard
Power Supply Antec Edge 750W
Software Windows 8.1 Pro 64
#7
Shutting off vsync helped me a lot. Faster load times as well.
 
Joined
Jun 24, 2008
Messages
1,365 (0.39/day)
Likes
109
Location
Alden, NY
System Name Turbo_Fighter/Pitbull
Processor AMD FX-9590/Intel i7 6700K 4.7GHZ @ 1.41 volts
Motherboard Gigabyte 990FXA-UD3 Rev 4.0/Gigabyte GA-Z170N-Gaming 5
Cooling Corsair H105/Corsair H100iv2
Memory 32 GB G.Skill Ares/32 GB G.Skill Trident-Z
Video Card(s) XFX Radeon R9 Fury X/Sapphire R9 Nano
Storage Mix of HDDs SSDs Externals and a 256GB Samsung M.2 in the pitbull
Display(s) 24" Nixeus 144hz freesync/24'' Benq XL2420TE/21.5'' Asus VH226/Panasonic 42" Plasma
Case White Phantom NZXT/Fractal Define Nano S
Audio Device(s) MayFlower O2 ODAC/HT Omega Claro+/Turtlebeach Earforce DSS
Power Supply Corsair AX1200i/Thermaltake Smart 650Watt(EVGA GS 650 Watt took a shit on me)
Mouse Logitech G502
Keyboard Corsair K70
Software Windows 10
Benchmark Scores They can run Crysis.
#8
upgrading to eight gigs of ram allowed the game to close down quicker...not anything to do with performance, but an interesting observation.

all i can say is disable/uninstall any antivirus software