• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Issue with old 775 Socket rig

Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#1
Hi All,

So, I have an old Core2 Quad Q9650 paired with a EVGA 790i FTW mobo and 8GB of Corsair XMS3 (Big silver heatsinks) RAM and the issue I'm having with the machine is that I cannot get a video display out of it (using the old GTX 285 with it). From memory, the last time this rig was used, it was working fine with no issues (it was the wife's old PC). I've just recently pulled it out of my storage and have moved it into a new case and changed the CPU cooler (from the stock cooler because the fan had stopped was making horrible noises) to a spare Cryorig R1 Ultimate (Was a very tight fit with the huge heatsinks on the board) I had lying around and for some reason, as mentioned, I cannot get a display out of it. The mobo displays the post codes of FF on it, and from the manual for the board, it just means "boot" which I take to mean as good.

I've tried booting the system with all the different configurations of the RAM that I can (1 stick, 2 sticks, etc etc) but that's made no difference. Also tried booting the machine with only the minimums attached, no drives or SSD's, only the GPU in addition to what needs to be on the board, again, no difference. At the timing of this post, I've removed the BIOS battery and am leaving the machine disconnected for a while to discharge it to see if that helps at all, but I'm not 100% sure what else I can try on the hardware. I would welcome any suggestions/recommendations.

If any further information is required, please let me know and I'll post.

Cheers!!
 
Joined
Dec 6, 2005
Messages
10,665 (2.21/day)
Likes
4,483
Location
Manchester, NH
System Name Working on it ;)
Processor I7-4790K (Stock speeds right now)
Motherboard MSI Z97 U3 Plus
Cooling Be Quiet Pure Rock Air
Memory 16GB 4x4 G.Skill CAS9 2133 Sniper
Video Card(s) GIGABYTE Vega 64 (Non Reference)
Storage Samsung EVO 500GB / 8 Different WDs / QNAP TS-253 8GB NAS with 2x2Tb WD Black
Display(s) 34" LG 34CB88-P 21:9 Curved UltraWide QHD (3440*1440) *FREE_SYNC*
Case Rosewill Challenger
Audio Device(s) Onboard + HD HDMI
Power Supply Corsair HX750 (love it)
Mouse Logitech G5
Keyboard Corsair Strafe RGB & G610 Orion Red
Software Win 10 upgraded from Win 7 Pro
#2
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#3
@Sasqui, that actually is incredibly useful!!! Thank you so much for that mate!! Looks like I may need to get my hands on another power supply and test using that and see what happens. I currently have the whole set up hooked up outside of case using a mobo box as a test bench base so not as though it's the stand offs short circuiting something...and I just hope it's not the damn CPU cooler as it's a great one to have on it (cool & quiet) and I don't believe that when I installed it, I put it on SUPER tight. Also hope it's not the CPU. But nevertheless, thanks for that, again, very helpful. Will have to see how I go.

Edit: So, it's not a power supply issue. I got hold of another one and it does exactly the same thing as the previous one....
 
Last edited:
Joined
Jun 15, 2016
Messages
703 (0.72/day)
Likes
342
System Name My PC
Processor 4670K@4.4GHz
Motherboard Gryphon Z87
Cooling CM 212
Memory 2x8GB+2x4GB @2400GHz
Video Card(s) XFX Radeon RX 580 GTS Black Edition 1425MHz OC+, 8GB
Storage Intel 530 SSD 480GB + Intel 510 SSD 120GB + 2x500GB hdd raid 1
Display(s) HP envy 32 1440p
Case CM Mastercase 5
Audio Device(s) Sbz Zxr
Power Supply Antec 620W
Mouse G502
Keyboard G910
Software Win 10 pro
#4
Use another gpu(PCI if you have it!) and see what happens or test GTX 285 on another rig.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
24,933 (5.87/day)
Likes
8,357
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#5
@Sasqui, that actually is incredibly useful!!! Thank you so much for that mate!! Looks like I may need to get my hands on another power supply and test using that and see what happens. I currently have the whole set up hooked up outside of case using a mobo box as a test bench base so not as though it's the stand offs short circuiting something...and I just hope it's not the damn CPU cooler as it's a great one to have on it (cool & quiet) and I don't believe that when I installed it, I put it on SUPER tight. Also hope it's not the CPU. But nevertheless, thanks for that, again, very helpful. Will have to see how I go.

Edit: So, it's not a power supply issue. I got hold of another one and it does exactly the same thing as the previous one....
Breadboard the rig
 
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#6
Joined
Dec 6, 2005
Messages
10,665 (2.21/day)
Likes
4,483
Location
Manchester, NH
System Name Working on it ;)
Processor I7-4790K (Stock speeds right now)
Motherboard MSI Z97 U3 Plus
Cooling Be Quiet Pure Rock Air
Memory 16GB 4x4 G.Skill CAS9 2133 Sniper
Video Card(s) GIGABYTE Vega 64 (Non Reference)
Storage Samsung EVO 500GB / 8 Different WDs / QNAP TS-253 8GB NAS with 2x2Tb WD Black
Display(s) 34" LG 34CB88-P 21:9 Curved UltraWide QHD (3440*1440) *FREE_SYNC*
Case Rosewill Challenger
Audio Device(s) Onboard + HD HDMI
Power Supply Corsair HX750 (love it)
Mouse Logitech G5
Keyboard Corsair Strafe RGB & G610 Orion Red
Software Win 10 upgraded from Win 7 Pro
#7
Tabletop build out in the open, no case, no chance for a short and really easy to swap components.

I have an ASUS Px58 that just plain died. The only thing left to try is flashing the BIOS backdoor style.
 
Joined
Dec 6, 2005
Messages
10,665 (2.21/day)
Likes
4,483
Location
Manchester, NH
System Name Working on it ;)
Processor I7-4790K (Stock speeds right now)
Motherboard MSI Z97 U3 Plus
Cooling Be Quiet Pure Rock Air
Memory 16GB 4x4 G.Skill CAS9 2133 Sniper
Video Card(s) GIGABYTE Vega 64 (Non Reference)
Storage Samsung EVO 500GB / 8 Different WDs / QNAP TS-253 8GB NAS with 2x2Tb WD Black
Display(s) 34" LG 34CB88-P 21:9 Curved UltraWide QHD (3440*1440) *FREE_SYNC*
Case Rosewill Challenger
Audio Device(s) Onboard + HD HDMI
Power Supply Corsair HX750 (love it)
Mouse Logitech G5
Keyboard Corsair Strafe RGB & G610 Orion Red
Software Win 10 upgraded from Win 7 Pro
#9
does it display bios screen ?
He said bellow in the first post, so no ...yea, trying a known good vid card would be the next logical step.

I cannot get a display out of it. The mobo displays the post codes of FF on it, and from the manual for the board, it just means "boot" which I take to mean as good.
 
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#11
Ok, so a bit of an update about this...I've tried 2 separate known working GPU's and still no output, mobo still is going into FF mode. I, luckily, had a spare E8400 lying around so I've thrown that into the set up but the issue still persists. The only thing, at this stage, going by the link @Sasqui posted, is to potentially try a different CPU cooler as the one currently on the machine is either exerting too much pressure on the CPU socket or some other weirdness with it. I just don't have another socket 775 cooler on hand to try, will need to see what I can scrounge up....
 
Joined
May 8, 2016
Messages
709 (0.70/day)
Likes
824
System Name BOX
Processor Xeon E5-1680 v2 @ 4,3GHz
Motherboard Sabertooth X79 (BIOS 4801 + NVMe mod + uCode update)
Cooling Thermalright Venomous-X (w/LGA 2011 kit) + 2x Delta PWM Push-Pull
Memory 8x A-Data Xtreme 2000X 2GB (1868MHz CL8.9.8.24 CR2T @ 1,65V)
Video Card(s) ASUS GTX 1080 (FE)
Storage Samsung SM961 256GB NVMe, RAID0 2x WD10EZEX (1TB), HGST HUS726060ALE610 (6TB)
Display(s) Samsung T240
Case NZXT Tempest (Nanoflux/PWM fans only, some w/LEDs)
Audio Device(s) ASUS Essence ST Deluxe 7.1
Power Supply Seasonic X-760 (760W)
Mouse Roccat Savu
Keyboard Logitech UltraXPremium
Software Windows 10 Pro x64
Benchmark Scores https://www.passmark.com/baselines/V9/display.php?id=108080818886
#12
Put Celeron 4x0 inside and try to power on without a cooler.
 
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#14
Did you pull the board from the case?
Yeah, it was originally in a Bitfenix case, but I removed it from that and it’s currently sitting in pieces on my dining table...
 
Joined
Dec 6, 2005
Messages
10,665 (2.21/day)
Likes
4,483
Location
Manchester, NH
System Name Working on it ;)
Processor I7-4790K (Stock speeds right now)
Motherboard MSI Z97 U3 Plus
Cooling Be Quiet Pure Rock Air
Memory 16GB 4x4 G.Skill CAS9 2133 Sniper
Video Card(s) GIGABYTE Vega 64 (Non Reference)
Storage Samsung EVO 500GB / 8 Different WDs / QNAP TS-253 8GB NAS with 2x2Tb WD Black
Display(s) 34" LG 34CB88-P 21:9 Curved UltraWide QHD (3440*1440) *FREE_SYNC*
Case Rosewill Challenger
Audio Device(s) Onboard + HD HDMI
Power Supply Corsair HX750 (love it)
Mouse Logitech G5
Keyboard Corsair Strafe RGB & G610 Orion Red
Software Win 10 upgraded from Win 7 Pro
#15
Ok, so a bit of an update about this...I've tried 2 separate known working GPU's and still no output, mobo still is going into FF mode. I, luckily, had a spare E8400 lying around so I've thrown that into the set up but the issue still persists. The only thing, at this stage, going by the link @Sasqui posted, is to potentially try a different CPU cooler as the one currently on the machine is either exerting too much pressure on the CPU socket or some other weirdness with it. I just don't have another socket 775 cooler on hand to try, will need to see what I can scrounge up....
I got fed up with my ASUS x58 not posting, so I slapped an i7 970 CPU in WITHOUT a cooler. Put my finger on the IHS as it tried to boot, it never ever got warm.
 
Joined
May 8, 2016
Messages
709 (0.70/day)
Likes
824
System Name BOX
Processor Xeon E5-1680 v2 @ 4,3GHz
Motherboard Sabertooth X79 (BIOS 4801 + NVMe mod + uCode update)
Cooling Thermalright Venomous-X (w/LGA 2011 kit) + 2x Delta PWM Push-Pull
Memory 8x A-Data Xtreme 2000X 2GB (1868MHz CL8.9.8.24 CR2T @ 1,65V)
Video Card(s) ASUS GTX 1080 (FE)
Storage Samsung SM961 256GB NVMe, RAID0 2x WD10EZEX (1TB), HGST HUS726060ALE610 (6TB)
Display(s) Samsung T240
Case NZXT Tempest (Nanoflux/PWM fans only, some w/LEDs)
Audio Device(s) ASUS Essence ST Deluxe 7.1
Power Supply Seasonic X-760 (760W)
Mouse Roccat Savu
Keyboard Logitech UltraXPremium
Software Windows 10 Pro x64
Benchmark Scores https://www.passmark.com/baselines/V9/display.php?id=108080818886
#17
Stab chokes/inductors with DMM, and see if they supply Vcore/IMC(QPI) voltages to your CPU.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
24,933 (5.87/day)
Likes
8,357
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#18
Sometimes cases cause weird angles with pci/pcie devices, that is why breadboarding allows you to know you pushed the card in fully and squared.

I've heard though on some motherboards you may need to do the oppossite, raise the card out of slot just slightly.

Check for bent socket pins, use electronic contact cleaner to blow all dust out of socket/slots.
 
Joined
Oct 30, 2008
Messages
1,563 (0.42/day)
Likes
685
Processor 3930K
Motherboard Asus X79 DELUXE
Cooling WATER
Memory 16GB 2133 G skillz
Video Card(s) Asus 2 X 780TI DCII OC
Storage SEVERAL SSD"S
Display(s) Catleap/Yamakasi 2560X1440
Case D Frame MINI drilled out
Audio Device(s) onboard
Power Supply Corsair TX750
Mouse DEATH ADDER
Keyboard Razer Black Widow Tournament
Software W10HB
Benchmark Scores PhIlLyChEeSeStEaK
#19
Did u try another PCI-e slot? Pretty sure the 790 with a FF code means you shit out of luck. Does it cycle through oter post codes or go straight to the FF?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
24,933 (5.87/day)
Likes
8,357
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#21
So, upon further testing, yes, I think the board is, for lack of a better word, fucked. I’ve tried different CPU’s, different power supplies, got my hands on a stock socket 775 cooler, different GPU’s and the board is still stuck on FF on boot. Damn.

Well, given that, do the experts here have any recommendations on a good socket 775 ATX board I can replace this with? I know it can be said to just ditch this machine but legit every other part works & I have a use planned for this machine so I would welcome any solid suggestions for a replacement full ATX 775 mobo.

Cheers all & thanks to all who have been providing help so far, I really am appreciative of it.
 
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#23
any Asus P38 or preferably P45 chipset board you can find localy or ebay/gumtree /online forums should see you ok
Any specific P45 chipset board you may recommend?
 
Last edited:
Joined
Jul 28, 2016
Messages
58 (0.06/day)
Likes
35
Location
Sydney, Australia
System Name Main Gaming Rig
Processor Intel Core i7 4770K @ 4.4Ghz 1.20V
Motherboard ASUS Maximus VI GENE Z87 Motherboard
Cooling NZXT Kraken X52 in Push Config & 3 Corsair AF140 Case Fans
Memory Corsair Vengeance Pro CMY16GX3M2A1600C9R 8GB (2x8GB) DDR3 x 2
Video Card(s) Asus Strix GTX 1080Ti ROG-STRIX-GTX1080TI-O11G-GAMING
Storage 2 x 1TB Samsung 850 Pro SSD / Seagate Barracuda 2TB ST2000DM001
Display(s) Asus PB278Q 27” 16:9 2560x1440 WQHD
Case Corsair Obsidian 350D with Window
Audio Device(s) Onboard
Power Supply Corsair AX860i Platinum Power Supply /w Red Sleeved Cabling
Mouse Razer DeathAdder Chroma
Keyboard Razer Blackwidow Chroma v2
Software Windows 10 Pro
#25
Top