• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

M2000M for Zbook 15 G3 vbios

Joined
May 22, 2020
Messages
126 (0.16/day)
Location
Ukraine
M2000M for Zbook 15 G3 vbios - One from bios and second with added GOP

IMPORTANT: this vbioses doesn't contain NVGI header, which is important for initialization of graphics for driver.


Posting this vbioses for easy access

1647228931170.png
 

Attachments

  • M2000M.zip
    63.4 KB · Views: 29
  • M2000M_GOP.zip
    131.4 KB · Views: 33
Joined
May 22, 2020
Messages
126 (0.16/day)
Location
Ukraine
M2000M MXM updated GOP



Also GOPS and ROMS from Zbook G3




GOP ROMS AND EFI DRIVERS - Efi drivers are from Zbook G3 BIOS
 

Attachments

  • M2000M_MXM.zip
    136.3 KB · Views: 23
  • GOP ROMS AND EFI DRIVERS.zip
    692.9 KB · Views: 19

g3llings

New Member
Joined
Feb 28, 2021
Messages
1 (0.00/day)
Hey bigguygeo... I'm very interested in the vbios. I am trying to run an m2000m in an HP Elite 8200 USDT... With any other vBIOS I end up getting code 43. So far using your m2000m_mxm.rom it shows up as "Microsoft Basic Video Adapter", and if I modify the Nvidia driver to install I get a black screen which is different than any other vBIOS. I noticed you said it doesn't have NVGI Header and think this may be my problem. How do I add that? I don't really know anything about vBIOS modding. Any help is appreciated!
 
Joined
May 22, 2020
Messages
126 (0.16/day)
Location
Ukraine
Hey bigguygeo... I'm very interested in the vbios. I am trying to run an m2000m in an HP Elite 8200 USDT... With any other vBIOS I end up getting code 43. So far using your m2000m_mxm.rom it shows up as "Microsoft Basic Video Adapter", and if I modify the Nvidia driver to install I get a black screen which is different than any other vBIOS. I noticed you said it doesn't have NVGI Header and think this may be my problem. How do I add that? I don't really know anything about vBIOS modding. Any help is appreciated!
Yeah, I Know that problem.
The reason of this that this build is Missing NVGI image. That image is used to identify GPU by driver.


I have made some research, but have no time to test pathed image. Only unsolved is checksum byte.


If you have a programmer for unbricking, we can try to make NVGI image

Hey bigguygeo... I'm very interested in the vbios. I am trying to run an m2000m in an HP Elite 8200 USDT... With any other vBIOS I end up getting code 43. So far using your m2000m_mxm.rom it shows up as "Microsoft Basic Video Adapter", and if I modify the Nvidia driver to install I get a black screen which is different than any other vBIOS. I noticed you said it doesn't have NVGI Header and think this may be my problem. How do I add that? I don't really know anything about vBIOS modding. Any help is appreciated!
Also keep in mind that motherboard should support mxm 3.1. And this new gen gpu, it could have problems with mapping registers. In fact, it can be unstable on non UEFI platforms
 
Last edited:
Joined
May 22, 2020
Messages
126 (0.16/day)
Location
Ukraine
Hey bigguygeo... I'm very interested in the vbios. I am trying to run an m2000m in an HP Elite 8200 USDT... With any other vBIOS I end up getting code 43. So far using your m2000m_mxm.rom it shows up as "Microsoft Basic Video Adapter", and if I modify the Nvidia driver to install I get a black screen which is different than any other vBIOS. I noticed you said it doesn't have NVGI Header and think this may be my problem. How do I add that? I don't really know anything about vBIOS modding. Any help is appreciated!
I think error 43 is related to memory addresses


System Resources
Memory Base Address 0 E4000000-E4FFFFFF
Memory Base Address 1 A0000000-AFFFFFFF
Memory Base Address 3 B0000000-B1FFFFFF
I/O Base Address 5 0

Latest NVGI header research reveals some useful info. The checksum byte is located at byte number 0x4, the checksum type is at byte number 0x7. So it can be sum = 00, or 80
 
Top