• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Making Audio Enhancers Work on Windows

baribal

New Member
Joined
Mar 11, 2019
Messages
18 (0.03/day)
So what is the currently working Dolby Atmos solution atm? With both 2.7.7 and 2.8.0 APO drivers and latest .732 and previous .702 UWP apps I can't make Dolby Atmos Speaker System to work correctly. Turning OFF and ON Dolby Atmos in UWP GUI doesn't make any difference to sound. Even stopping DAX service does nothing. But Graphic Equalizer is working in the Personalize tab. However switching OFF and ON Sound Virtualizer, Dialog Enchancer, Volume Leveler also does no changes to the sound. Only if I remove APO driver completely and restart I feel that the sound changed drastically - seems like some effects are working in the Dolby Atmos even if DAX service is not running. I tried 3.2.0 xml from Dolby_Profiles_09012020.rar and 3.4.2 xml from the test archive provided here recently.

Another thing is when I switch my Creative AE-9 sounds card to the Direct Headphones mode (SBX and all creative "improvements" are switched off), put the card into the Stereo mode and have APO driver uninstalled I still hear sounds from all 5.1 or 7.1 channels in demos in Potplayer (output mode is Same as Input, so Windows mixer is used). So smth is doing HRTF 5.1->2.0. Do you folks maybe know some software etc. which can visualize/determine the audio signal path in OS so I could find what is doing this downmix?
 
Joined
Jul 30, 2020
Messages
19 (0.23/day)
Location
Rio de Janeiro / RJ - Brazil
Processor Intel® Core™ i5-6500
Motherboard H110 Pro BTC+
Cooling Aero cool LGA 1151
Memory 4 GB DDR4-2132 (1066 Mhz) + 8 GB DDR4-2400(1200 Mhz)
Video Card(s) GTX 1050 Ti 4GB
Display(s) LG 43" LED HDR 10
Case AeroCool DS-20
Power Supply Corsair CX430
Yes, your are right ... & ... No, you are not right. :p

I have experienced too, that DDL/DTS-C not reports 5.1 to the games.
That's why I wrote "may", because I didn't know exactly. ;)

I didn't meant that like you had written. ;)
I know, that DDL/DTS-C has nothing to do with DD/DTS output capablity of applications.
Most video players could output DD/DTS if there's a 5.1 sound track in the file - games (maybe) not.

So: your solution depends on games that support forcing multichannel audio output. These fact is really rare to find. :ohwell:
That's why another solution is what I wanna find out.

Virtual Cable may be one other solution for that, so games gets reported by the output device (VC) a 5.1 signal.
But 5.1 capability depends on the used VC software. And for every other game you has to change the VC to 2.0, 5.1 or 7.1. :kookoo:

So thanks for clearing that out a bit!
Here, I configured my audio output to use Dolby Home Theater V4. In the game he already detects that it is a 5.1 sound system. There are no settings in the game to choose the number of channels. Dolby Home Theater only upscales when the content is stereo when it is 5.1 it only uses audio enhancements.


1600620277377.png



But here when I use Dolby Digital in games I feel a delay in the audio. I saw it in some forums and it has to do with the LG TV.
But the DTS in my home theater system the sound is unbalanced. The voices are very low, but the effects are very loud.
With Dolby Home Theater it's perfect, if it weren't for the delay. :(


What games have you had problems with?
There are some DLLs that force games to detect 5.1 sound. Not many games I needed to use. In The Witcher 3 I had to use it ff you need, I can upload it for you.
 
Last edited:
Joined
Jun 20, 2017
Messages
565 (0.46/day)
@Jayce
My experience is that DHT4 can fillup Speakers (2.0 -> 5.1), when it's switched "on".
Then it could also make sound louder with intelligent equalizer, dialogue enhancer and Loudness equalization.

I don't like this only "making louder". My sound system is loud enough.
So both DHT4 is okay in (upfilling LS, make sound more present).
so your saying that it's not really good for real 5.1?
 
Joined
Sep 13, 2020
Messages
43 (1.10/day)
I only tested it a bit in the last couple of days.

For music it should be okay. It fills more the room.
For movies it fills up speakers okay, but there's no special surround sound ( like I know from Dolby ProLogic II ).
It's more like "stereo with multichannel speakers", if you know what I mean?
PL II can produce rain in the background to rain from the rear speakers.

What is your experience?
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
I only tested it a bit in the last couple of days.

For music it should be okay. It fills more the room.
For movies it fills up speakers okay, but there's no special surround sound ( like I know from Dolby ProLogic II ).
It's more like "stereo with multichannel speakers", if you know what I mean?

What is your experience?
I never tried. I have a 5.1 sound bar system with two rears, I just was looking to boost volume little bit. But it seems like dolby atmos from apo driver 2.7.7 sounds the best.
 
Joined
Sep 13, 2020
Messages
43 (1.10/day)
Maybe DHT4 is the tiny version of D Atmos ... :laugh: ??

What do I need to install Dolby Atmos on Win7 and on Win10?

On Win10 there are a lot of apps, but which is good & what sound would it make? Only highlifting like Yamaha AVRs or something special?

For Win7 I don't know any program. APO 2.8 has it in the options, but I need a driver or programm to install. Win10 apps aren't useful.

When I'm going to do an audio test this error is show.
View attachment 169211
This is through Windows Driver Model (WDM). Apps or programs get this audio output exclusivly.
So if an app, program or task use this output, then other could not. The sound test couldn't thatswhy you get this little nice 3rror. :p

P.e.: my Voicemeeter mixer can use three hardware audio outputs. If WDM, then exclusive & forbidden for others.
If MME or KS, then is no problem to share the output device with other tasks.
On the well side WDM has little buffer size of 512, where MME has 1024.
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
So what is the currently working Dolby Atmos solution atm? With both 2.7.7 and 2.8.0 APO drivers and latest .732 and previous .702 UWP apps I can't make Dolby Atmos Speaker System to work correctly. Turning OFF and ON Dolby Atmos in UWP GUI doesn't make any difference to sound. Even stopping DAX service does nothing. But Graphic Equalizer is working in the Personalize tab. However switching OFF and ON Sound Virtualizer, Dialog Enchancer, Volume Leveler also does no changes to the sound. Only if I remove APO driver completely and restart I feel that the sound changed drastically - seems like some effects are working in the Dolby Atmos even if DAX service is not running. I tried 3.2.0 xml from Dolby_Profiles_09012020.rar and 3.4.2 xml from the test archive provided here recently.

Another thing is when I switch my Creative AE-9 sounds card to the Direct Headphones mode (SBX and all creative "improvements" are switched off), put the card into the Stereo mode and have APO driver uninstalled I still hear sounds from all 5.1 or 7.1 channels in demos in Potplayer (output mode is Same as Input, so Windows mixer is used). So smth is doing HRTF 5.1->2.0. Do you folks maybe know some software etc. which can visualize/determine the audio signal path in OS so I could find what is doing this downmix?
27.7 is the currently working dolby atmos effect atm. anything above isn't working at all.
 

baribal

New Member
Joined
Mar 11, 2019
Messages
18 (0.03/day)
27.7 is the currently working dolby atmos effect atm. anything above isn't working at all.
2.7.7 and and latest UWP app 3.20703.732? For me not - reinstalled APO driver and that didn't help. Which Windows build do you have? I have 19042.508. Maybe I need to re-install Windows after playing around with APO drivers reinstallation multiple time. :(

This is my config:

Code:
[MFX]
[EFX]
[KDSFX]
[KDMFX]
[KDEFX]
[OSFX]
[OMFX]
[CompositeSFX]
{0EBD8505-17BB-4AE7-AD76-E86F99A425E9}
[CompositeMFX]
{0EBD8506-17BB-4AE7-AD76-E86F99A425E9}
[CompositeEFX]
{0EBD8507-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDSFX]
{0EBD8508-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDMFX]
{0EBD8509-17BB-4AE7-AD76-E86F99A425E9
[CompositeKDEFX]
{0EBD8510-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOSFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOMFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[ProcessingLFX]
[ProcessingGFX]
[ProcessingSFx]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingEFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingKDSFx]
[ProcessingKDMFX]
[ProcessingKDEFX]
[ProcessingOSFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingOMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[Notes]
 
Joined
Mar 1, 2017
Messages
759 (0.57/day)
Location
Rio de Janeiro, Brazil
System Name Alan Finotty
Processor AMD Phenom II X4 960T (Quad-Core)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)
Cooling Stock
Memory 2x4GB Kingston HyperX Fury DDR3 1866MHz + 2+1GB Memory Modules DDR3 1333 = 11GB
Video Card(s) Zogis GT 730 1GB DDR3
Storage 1: Intel 320 Series SSD 80GB; 2: Seagate Barracuda HD 1TB; 3: Toshiba MQ01ABD050 HD 500GB
Display(s) Samsung SyncMaster 933SN/933N/SN1933
Case Cooler Master Storm Scout
Audio Device(s) Realtek ALC892 with My Modified Drivers
Power Supply Casemall 600W (Auto-Switch 110V/220V)
Mouse Estone X7 Gaming
Keyboard Backlit SemiMechanical Keyboard
Software Windows 10 Pro x64 (2009) (20H2)
2.7.7 and and latest UWP app 3.20703.732? For me not - reinstalled APO driver and that didn't help. Which Windows build do you have? I have 19042.508. Maybe I need to re-install Windows after playing around with APO drivers reinstallation multiple time. :(

This is my config:

Code:
[MFX]
[EFX]
[KDSFX]
[KDMFX]
[KDEFX]
[OSFX]
[OMFX]
[CompositeSFX]
{0EBD8505-17BB-4AE7-AD76-E86F99A425E9}
[CompositeMFX]
{0EBD8506-17BB-4AE7-AD76-E86F99A425E9}
[CompositeEFX]
{0EBD8507-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDSFX]
{0EBD8508-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDMFX]
{0EBD8509-17BB-4AE7-AD76-E86F99A425E9
[CompositeKDEFX]
{0EBD8510-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOSFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOMFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[ProcessingLFX]
[ProcessingGFX]
[ProcessingSFx]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingEFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingKDSFx]
[ProcessingKDMFX]
[ProcessingKDEFX]
[ProcessingOSFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingOMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[Notes]
Try This:
Code:
[SFX]
[MFX]
[EFX]
[KDSFX]
[KDMFX]
[KDEFX]
[OSFX]
[OMFX]
[CompositeSFX]
{D9916FA0-99F7-11E7-BF21-6C0B849889E1}
[CompositeMFX]
[CompositeEFX]
{D9916F9C-99F7-11E7-BF21-6C0B849889E1}
[CompositeKDSFX]
[CompositeKDMFX]
[CompositeKDEFX]
[CompositeOSFX]
{D9916FA0-99F7-11E7-BF21-6C0B849889E1}
[CompositeOMFX]
[ProcessingLFX]
[ProcessingGFX]
[ProcessingSFx]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
[ProcessingMFX]
[ProcessingEFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
[ProcessingKDSFx]
[ProcessingKDMFX]
[ProcessingKDEFX]
[ProcessingOSFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
[ProcessingOMFX]
[Notes]
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
Code:
[MFX]
[EFX]
[KDSFX]
[KDMFX]
[KDEFX]
[OSFX]
[OMFX]
[CompositeSFX]
{0EBD8505-17BB-4AE7-AD76-E86F99A425E9}
[CompositeMFX]
{0EBD8506-17BB-4AE7-AD76-E86F99A425E9}
[CompositeEFX]
{0EBD8507-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDSFX]
{0EBD8508-17BB-4AE7-AD76-E86F99A425E9}
[CompositeKDMFX]
{0EBD8509-17BB-4AE7-AD76-E86F99A425E9
[CompositeKDEFX]
{0EBD8510-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOSFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[CompositeOMFX]
{0EBD8511-17BB-4AE7-AD76-E86F99A425E9}
[ProcessingLFX]
[ProcessingGFX]
[ProcessingSFx]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingEFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingKDSFx]
[ProcessingKDMFX]
[ProcessingKDEFX]
[ProcessingOSFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[ProcessingOMFX]
{C18E2F7E-933D-4965-B7D1-1EEF228D2AF3}
{4780004E-7133-41D8-8C74-660DADD2C0EE}
{B26FEB0D-EC94-477C-9494-D1AB8E753F6E}
[Notes]
[/QUOTE]

I have windows 10 1941.508 and the dolby atmos config, I use with apo driver 2.7.7 for use product config non dolby gaming -> Dolby DAX3 UWP (APIv3.xxxxx, XML 3.3.0) OR product config for gaming: Dolby DAX3 UWP (APIv3.xxxxx - Gaming, XML 3.3.0) and apply it and make sure you put the xml files in dolbyaposvc and then restart pc
 

baribal

New Member
Joined
Mar 11, 2019
Messages
18 (0.03/day)
I have windows 10 1941.508 and the dolby atmos config, I use with apo driver 2.7.7 for use product config non dolby gaming -> Dolby DAX3 UWP (APIv3.xxxxx, XML 3.3.0) OR product config for gaming: Dolby DAX3 UWP (APIv3.xxxxx - Gaming, XML 3.3.0) and apply it and make sure you put the xml files in dolbyaposvc and then restart pc
And what xml version are you using? Which archive with xmls did you use?

Try This:
Unfortunately nothing changed: :(
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
And what xml version are you using? Which archive with xmls did you use?
I use xml 3.3.0 preset and I use this archive of xmls
make sure to change your speaker configuration of xml.

Also you probably need to clean install apo driver, delete everything related in registrys and the folders in program data and system32.
if this doesn't work, you might need clean install windows 10 and then try installing the apo driver 2.7.7.

just note that clean installing windows 10 won't make apo driver 2.8.0 work because @alanfox2000 needs to fix himself
 
Joined
Dec 13, 2014
Messages
262 (0.12/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education v1809

Cardepils

New Member
Joined
Aug 27, 2020
Messages
15 (0.27/day)
I've managed to install realtekdriver_2019_02_25 @Alan Finote but i have some question, im using 7.1 but when I tested the speakers, the sound just came out of the front left and right. i've set the cable input im using rca cable, do you know the solution?

Screenshot_4g.jpg


Thankyou
 

DriVE654

New Member
Joined
May 13, 2020
Messages
12 (0.07/day)
@Cardepils, please note that built-in sound tests are unreliable, you should instead download a proper 5.1 test/demo sound from a DTS/DDL source and play it in one of available players - that would show you if your surround system actually works or not. I suppose you need some kind of an upmix (speaker fill) software to make sure it converts audio sources having less than 6 channels to 5.1/7.1, otherwise you will still have sound only out of the front speakers - which was my case previously too. Even if you properly configure transmission of 5.1 signal to the AVR/TV/sound system it doesn't necessarily mean that you will have sound out of all your speakers as the key bit is missing, and it's an upmix software (either Creative or Sonic Studio or APO-based matrix mixer like Peace etc.)
Easiest way to check it is to play a pre-mixed 5.1 source (the demo records I mentioned earlier) so if they play well then you need an upmixer, otherwise your transmission route is not set up properly and you will not get surround sound.
 

krush_lion

New Member
Joined
Dec 9, 2018
Messages
9 (0.01/day)
So what is the currently working Dolby Atmos solution atm? With both 2.7.7 and 2.8.0 APO drivers and latest .732 and previous .702 UWP apps I can't make Dolby Atmos Speaker System to work correctly. Turning OFF and ON Dolby Atmos in UWP GUI doesn't make any difference to sound. Even stopping DAX service does nothing. But Graphic Equalizer is working in the Personalize tab. However switching OFF and ON Sound Virtualizer, Dialog Enchancer, Volume Leveler also does no changes to the sound. Only if I remove APO driver completely and restart I feel that the sound changed drastically - seems like some effects are working in the Dolby Atmos even if DAX service is not running. I tried 3.2.0 xml from Dolby_Profiles_09012020.rar and 3.4.2 xml from the test archive provided here recently.
Same thing here with Dolby Atmos Speaker System. Only the Personalize tab works. Voice, Music, Movie, Dynamic and Game do not work. I tried several times installing and reinstalling, but it did not work. Any solution to that? Thanks in advance.
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
So what is the currently working Dolby Atmos solution atm? With both 2.7.7 and 2.8.0 APO drivers and latest .732 and previous .702 UWP apps I can't make Dolby Atmos Speaker System to work correctly. Turning OFF and ON Dolby Atmos in UWP GUI doesn't make any difference to sound. Even stopping DAX service does nothing. But Graphic Equalizer is working in the Personalize tab. However switching OFF and ON Sound Virtualizer, Dialog Enchancer, Volume Leveler also does no changes to the sound. Only if I remove APO driver completely and restart I feel that the sound changed drastically - seems like some effects are working in the Dolby Atmos even if DAX service is not running. I tried 3.2.0 xml from Dolby_Profiles_09012020.rar and 3.4.2 xml from the test archive provided here recently.

Another thing is when I switch my Creative AE-9 sounds card to the Direct Headphones mode (SBX and all creative "improvements" are switched off), put the card into the Stereo mode and have APO driver uninstalled I still hear sounds from all 5.1 or 7.1 channels in demos in Potplayer (output mode is Same as Input, so Windows mixer is used). So smth is doing HRTF 5.1->2.0. Do you folks maybe know some software etc. which can visualize/determine the audio signal path in OS so I could find what is doing this downmix?
2.7.7 apo driver works properly if you clean install the dolby and the apo driver. anything above it doesn't work. @alanfox2000 still hasn't figure out how to fix issues. He is the only that can really change configuration for to make the new dlls work with older ones.
 
Joined
Sep 3, 2020
Messages
5 (0.10/day)
System Name Windows 10 Pro N 2004,
Processor Core i3, 2.50 GHz (4th Gen)
Motherboard HP Probook 440G1 Laptop
Memory 12 GB
Video Card(s) AMD Radeon HD 8600/8700 M
Storage 480 GB, SSD
Display(s) 1
Any luck with APO Driver [2.8.1]? Haven't tried yet. Anyone tried? Does Dolby works?
 
Joined
Jun 20, 2017
Messages
565 (0.46/day)
Any luck with APO Driver [2.8.1]? Haven't tried yet. Anyone tried? Does Dolby works?
Only Personalized sound profile works if you mess with the equalizer.
Turning off and on the dolby sound effect doesn't work and
Every other sound profile doesn't work including surround virualizer, dialogue enhancer and sound leveler.
 
Last edited:
Joined
Dec 13, 2014
Messages
262 (0.12/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education v1809
Joined
Jun 20, 2017
Messages
565 (0.46/day)
second note to alanfox2000

Dolby v3.20703.733.0 APO SWC component driver & Dolby HSA v3.20703.732.0 driver available from MS Update Catalog

and MSI Realtek UAD 9042 driver contains Nahimic3 APO3 SWC v3.0.0 driver

hope you can include these updated components in next APO driver release
@alanfox2000 And hopefully fix the dolby sound effect issue as stated below
APO Drivers after 2.7.7,
Only Personalized sound profile works if you mess with the equalizer.
Turning off and on the dolby sound effect doesn't work and
Every other sound profiles doesn't work including the sound features: surround virualizer, dialogue enhancer and sound leveler.
 
Last edited:
Top