• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Mining BIOS repository

cryptofosho

New Member
Joined
May 7, 2021
Messages
3 (0.01/day)
memory straped.
They're humming along at 30 MH/s with very little tweaking. THANK YOU!

The rest of my cards arrived today and some of them have Elpida memory. Can you do the same thing with the BIOS for those? Just for fun I tried uploading the ROM you modified for my Hynix cards and the hash rate dropped to less than half, so I had to flash the Elpidas back to stock.

I've attached the stock BIOS for my Elpida cards.

THANK YOU AGAIN!
 

Attachments

  • Elpida Stock_4_ASUS-Radeon-RX-570-4GB_115-C940PI0-100.zip
    108.5 KB · Views: 56
Joined
Mar 21, 2021
Messages
113 (0.18/day)
They're humming along at 30 MH/s with very little tweaking. THANK YOU!

The rest of my cards arrived today and some of them have Elpida memory. Can you do the same thing with the BIOS for those? Just for fun I tried uploading the ROM you modified for my Hynix cards and the hash rate dropped to less than half, so I had to flash the Elpidas back to stock.

I've attached the stock BIOS for my Elpida cards.

THANK YOU AGAIN!

Hello, i need help, i have 2 msi rx 570 armor oc 8gb with samsung memory, i use nicehash and i have 24MH/s i try a lot of bios and i can't take over than 24 MH/s and i can't go over 2000 Mhz in memory clock because i have pink pixel on my screen. Can you make a good bios for me. i give you my bios just one click timing and my bios with timing change

you need to overclock them properly. I did a slight change to bios, it should give you 30. not all cards go above 2000 on memory
if using amd whattman don't change memory timing now from auto. 1150 core, 900 volt, 2000 memory, rxboost 20 should be enough. finetune after that.
 

Attachments

  • Elpida Stock_4_ASUS-Radeon-RX-570-4GB_Mod.zip
    110.3 KB · Views: 55
  • bios.zip
    220.7 KB · Views: 62

solyrismd

New Member
Joined
May 10, 2021
Messages
1 (0.00/day)
Good day. Can you help me with the BIOS modification. I looked through the entire branch and did not find a ready-made version. Thank you
 

Attachments

  • OriginalRX580RedDevil8GB.rar
    107.3 KB · Views: 55
  • rx580.gif
    rx580.gif
    26.9 KB · Views: 112

Amitox

New Member
Joined
May 9, 2021
Messages
5 (0.01/day)
yes and ones cards strap
Which file ?

I flash with bios3 on cards and i have the same performance, I make rxboost in nicehash before run afterburner and its same, if i up the memory clock on the second card i have 22MH/s
 

Attachments

  • Mh.PNG
    Mh.PNG
    149.4 KB · Views: 79
  • Mh2.PNG
    Mh2.PNG
    156.1 KB · Views: 90
Joined
Mar 21, 2021
Messages
113 (0.18/day)
@atifsh ive posted my original bios have you had chance to tweak it?
umm incase I've missed it.
let me know the results

Which file ?

I flash with bios3 on cards and i have the same performance, I make rxboost in nicehash before run afterburner and its same, if i up the memory clock on the second card i have 22MH/s
i don't use nicehash.
your overclocks are wrong.

exit msi after burner and use amd's tool whattman
core 1150
volt 900
memory 2100

see what you get
fine tune from there.
 

Attachments

  • bios-strapmod.zip
    110.3 KB · Views: 70

Amitox

New Member
Joined
May 9, 2021
Messages
5 (0.01/day)
I can't make 2100 in memory clock because i have pink pixel on all screen
 

cryptofosho

New Member
Joined
May 7, 2021
Messages
3 (0.01/day)
you need to overclock them properly. I did a slight change to bios, it should give you 30. not all cards go above 2000 on memory
if using amd whattman don't change memory timing now from auto. 1150 core, 900 volt, 2000 memory, rxboost 20 should be enough. finetune after that.
Elpida cards running smoothly at 30.2 MH/s with no change to previous overclock after flashing your BIOS. You rock, my dude. Please PM me a BTC, ETH, LTC or ETC address.
 
Joined
Mar 21, 2021
Messages
113 (0.18/day)
Elpida cards running smoothly at 30.2 MH/s with no change to previous overclock after flashing your BIOS. You rock, my dude. Please PM me a BTC, ETH, LTC or ETC address.
glad it works.
regarding eth address..no need for that.

Its same, when i overclock i have 22MH/s
ok try direct mining, its easier to troubleshoot.
use phoenix miner and see what you get
 

cypher007

New Member
Joined
Apr 14, 2021
Messages
12 (0.02/day)
@atifsh err, no you havent posted the modded version yet.

heres the original again.
 

Attachments

  • biosoriginal.zip
    110.1 KB · Views: 46

cypher007

New Member
Joined
Apr 14, 2021
Messages
12 (0.02/day)
cheers @atifsh managed to squeeze another 1mhs with my voltage settings which are 0.9V for mem and core. total power consumption 91W and getting 29mhs.
 
Last edited:
Joined
Mar 21, 2021
Messages
113 (0.18/day)
cheers @atifsh managed to squeeze another 1mhs with my voltage settings which are 0.9V for mem and core. total power consumption 91W and getting 29mhs.
what miner? of my experience 30 is the least one can get stable on these cards, anything below should be double checked.
 

cypher007

New Member
Joined
Apr 14, 2021
Messages
12 (0.02/day)
what miner? of my experience 30 is the least one can get stable on these cards, anything below should be double checked.
team red. was using phoenix 5.5c which gave me 29.8 before i tried your bios. not sure what it would give now. i started using team red as it was listed as the best miner for the RX580. it does seem to give me a better share rate.

im using it with a stock bat though, only added --enable compute, as it needed it apparently even though the driver is set to compute.

if you have a set of switches i could try that would be good.

@atifsh

was swayed by this report:

https://2miners.com/blog/best-ethereum-mining-software-for-nvidia-and-amd/

and this:

https://www.reddit.com/r/NiceHash/comments/lvor7p
 
Joined
Mar 21, 2021
Messages
113 (0.18/day)
what are your clocks..

regarding accepted shares, unfortunately I had to restart one rig but if this tells anything they're pretty similar in accepted shares.

2589 in 9:01 hours phoenix 187 MHs
4643 in 16:28 hours teamred 190 MHs

i get 31.85 on my RX480's on HiveOS. and 32.5 if memory to 2150 but unstable and rig restarts randomly.
i get 31.45 on my one 580 Hynix anything above 2100 it gives invalid shares very few.. 5 to 6 in 24 hours but i like rig without invalids.
i get 31 on another 580 with Samsung that card gives invalids above 2060 memory.

my clocks are straps only in bios
1180 core
875 volts
2100 memory
rxboost 20
 

cypher007

New Member
Joined
Apr 14, 2021
Messages
12 (0.02/day)
@atifsh
core 1300 900mv
mem 2000 900mv

teamredminer.exe -a ethash -o stratum+tcp://eu1.ethermine.org:4444 -u 0x0xxxxxx(removed) --enable_compute

any other switches i should be using?

im also using a driver from August 2020 as the latest one wouldnt work with Phoenix.

tried 21.3.1 today and same mhs. except the vcore was locked to 950mv. so gone back to 20.8.2.
 
Joined
Mar 21, 2021
Messages
113 (0.18/day)
@atifsh
core 1300 900mv
mem 2000 900mv

teamredminer.exe -a ethash -o stratum+tcp://eu1.ethermine.org:4444 -u 0x0xxxxxx(removed) --enable_compute

any other switches i should be using?

im also using a driver from August 2020 as the latest one wouldnt work with Phoenix.

tried 21.3.1 today and same mhs. except the vcore was locked to 950mv. so gone back to 20.8.2.
cant you do 2100 on memory? if you can do it.
1300 is too high, set it from 1150 to 1200 .
 

cypher007

New Member
Joined
Apr 14, 2021
Messages
12 (0.02/day)
cant you do 2100 on memory? if you can do it.
1300 is too high, set it from 1150 to 1200 .
its a Power Colour Red Dragon RX580 with i think Samsung memory.

@atifsh ok tried that and getting 30.66mhs. though heat and power are up slightly. 55c i think before now 58c. power 91w now 93w.

@atifsh should i have any other switches set on the miner? seen some switch people mention --ref 20?
 
Joined
Mar 21, 2021
Messages
113 (0.18/day)
its a Power Colour Red Dragon RX580 with i think Samsung memory.

@atifsh ok tried that and getting 30.66mhs. though heat and power are up slightly. 55c i think before now 58c. power 91w now 93w.

@atifsh should i have any other switches set on the miner? seen some switch people mention --ref 20?
i don't know if teamred have rxboost or vmr commands on windows. i only used windows when i started mining with phoenix you can use command -rxboost 20
now on hiveOS i can use -ref 20 regardless of miner.

@atifsh. though heat and power are up slightly. 55c i think before now 58c. power 91w now 93w.

bump fan speeds to 60 to 75 if there on auto or lower
 
Top