• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

My EDP Current Keeps bleeping non Stop.

Ryan040

New Member
Joined
Sep 15, 2020
Messages
2 (0.18/day)
Hi, Sorry in advance if i have posted in the wrong Section.
Actually its been a week since my power limit throttling got fixed thanks to the thread "Unexplained Power Limitation". My Laptop is an i5 5250U with a clockspeed of 1.6ghz to 2.7ghz and whenever little load is applied, it immediately starts power throttling. This caused many unexplained performance problems, from games struggling to even simple tasks too(0 multi tasking). After using powercut technique, the performance improved drastically. Thank You!! Now power doesn't show up next to limitations whenever i am doing anything and my clockspeeed is at 2.5ghz .

But yesterday, a really funny situation happened. I technically forgot to use powercut technique while the system was idle(mistake from my part) and did it after playing a game(which power throttled) .And what happened after that was, even though the power indicator was not displaying next to limits, the system was struggling from screen recording to games,. And i did a cine bench test and my system was underperforming(508 pts) when before it was 521 pts. Soo only after doing a shut down, it got resolved(527 pts). The only thing which logically makes sense is that i must have locked the system when it was power throttling at 9 10W,which resulted in this performance difference.

Is it okay if the edp current keeps bleeping non stop even if the power is not displaying next to limits? i tried clearing it, but never disappears ie both gpu and ring always have the edp current tag displayed and it keeps bleeping. I have set the cpu to 31 and gpu to 0 in tp3, and this has caused the edp currents to only be displayed in the ring and gpu, when before, it would display in all(ie cpu 0 and gpu 31).Adjusting the ppo turbo time limit hasn't resolved it because i cant add a value greater than 28 since it would reset back to 28. Is there anything i can do for this? and does it does it need fixing?
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
2,193 (0.49/day)
Here is an example of what not to do when using PowerCut. I "accidentally" enabled PowerCut while running Prime95. After exiting Prime95, the C0% shows that my CPU is idle but the CPU is still reporting power consumption at over 56W. Lots of power limit throttling showing up in the Limit Reasons window. The multiplier is usually up around 34 or higher when idle. Throttling has disabled turbo boost so the CPU cannot go higher than its default multiplier which is 24.

Today's lesson. Do not enable PowerCut when the CPU is loaded. :)
As you found out, if you accidentally do this, you need to reboot to reset the CPU.

Do not worry about a few boxes always yellow in Limit Reasons. The CORE column is all clear. That is the important one. If 2 cores are active, your multiplier will always be at 25.00 if your CPU is not throttling. Watch the reported multiplier for any signs of throttling.

The PP0 Current Limit is locked at 32. If this setting was not locked, perhaps you could increase this limit and the yellow boxes would go away. It is locked so there is nothing you can do about this.

Great to see that the PowerCut feature is still proving to be useful.

When using PowerCut, you probably do not need to check TDP Level Control or the Power Balance feature. If you enable SpeedStep, the Set Multiplier function should work as long as you set the Non Turbo Ratio to 0. Handy if you need to slow your CPU down. I usually set the Non Turbo Ratio to 1 so the CPU goes for maximum speed. Most computers do not check the PP0 Power Limit and this is set to 0 by default. This value is ignored when set like this.
 

Attachments

Last edited:

Ryan040

New Member
Joined
Sep 15, 2020
Messages
2 (0.18/day)
Thank You Soo Much !! I am really glad that i dont need to fix anything else in this laptop except the thermal. :clap:

Yea PowerCut has truly saved this laptop Big Time! Now atleast i can use the laptop without getting cranky for every little thing :p
Ever since powercut has been enabled, it has never fallen below 2.5ghz. Really Happy :rolleyes:
i have unchecked everything else ie the tdp level control, power balance and set the ppo to 0.
Thank You Once Again !!
 
Top