• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire RX 570 Nitro+ 4GB Elpida big issue

Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#1
Hello,

I am new here, i am literally tortured, spent days and nights trying to fix that second hand GPU but nothing works, i am trying hard because i cannot afford buying a new one atm so i have no choice. I hope someone will give me some help.
To summarize the issue, this GPU is behaving like that since the day i got it. Whenever i do anything i get a MSG "Wattman settings have been restored due to an error "i used DDU for a clean driver installation, downloaded latest and old drivers, nothing works, the PC is crashing if i click the Windows Start Button or if i start any game. i reinstalled the windows several times, tried almost all windows versions, i figured out eventually that its an ex miner and its bios seem to have been modded before.

I have no experience in this at all, i start to learn how to do it and i found that Bios file in here which is compatible with mine 256bit. I shut the PC down, moved the switch to the OC side, started the PC, turned the switch to the HDMI/DVI port side, i used the AMD Flash Utility by administrator and it was successfully flashed. restarted the PC, yet problem is still there.

Looked everywhere for a bios which is compatible with this GPU but cannot find any, just found an original bios but it was 512 bit so i couldn't flash as i got an error "cannot erase ROM" i dont really know what is the problem. here are picture from GPUZ. any help would be highly appreciated. thanks

PC Specs:
MOBO: Asus Sabertooth 990FX R2.0
Processor: AMD FX-8350
RAM: Corsair 16 GB "4x4"
SSD: Samsung 850 EVO 500 GB
PSU: Corsair 750 W
Windows 10
 

Attachments

Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#4
1st thing remove your gpu drivers, use DDU twice in Windows and then once in safe mode.

Download chipset drivers from AMD. Download GPU Driver too.

Do not install any drivers yet

Here are some bios files

From verified list (I would recommend downloading this one first)
https://www.techpowerup.com/vgabios/191336/sapphire-rx570-4096-170323

Unverified List will work though

https://www.techpowerup.com/vgabios/192822/192822

https://www.techpowerup.com/vgabios/197358/197358

https://www.techpowerup.com/vgabios/197227/197227

https://www.techpowerup.com/vgabios/200150/200150


This one Says Nitro but may in fact be nitro+

https://www.techpowerup.com/vgabios/198494/198494

This one Doesn't say Nitro but may work

https://www.techpowerup.com/vgabios/196050/196050

Download this tool

https://www.techpowerup.com/download/ati-atiflash/

Flash 1 bios side only and verify it restarts and boots to windows with display on screen.

Never flash both sides of a bios without verifying it restarts and you have display on screen.

If in the event it does not show anything on screen after restart do not flash the other side. Flip bios switch to other side and restart pc to get windows loaded on screen, then flip switch to non working bios side. Delete the bios you downloaded and get another from the list and try to reflash.

Follow this Video thanks @F7GOS


Ok once you know the system boots correctly and windows is on screen, Install the chipset driver for your motherboard and restart, then install your gpu driver and restart.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#6
Hello eidairaman1,

Ok, thanks a lot!! will try it out and get back with feedback. After removing all AMD drivers in both windows and safe mode, should i reinstall the AMD drivers before or after flashing the BIOS?
Ok go towards the OC side first.

Reinstall your drivers after the bios flash.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#11
I won't. I will do everything you've mentioned and get back asap. Really appreciate your help.

Testing now. Done with steps and now installing chipset, restart, and driver/ restart. Then I will try and get back. The question here with every bios for I have to ddu everything before and follow all steps all over again? Or I can just leave the fresh drivers as they are?

crashed. i got that msg on the bottom to the right. Followed all steps as explained. i will try to flash another bios now. but not sure if i have to reinstall the drivers again?
 

Attachments

Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#12
I won't. I will do everything you've mentioned and get back asap. Really appreciate your help.

Testing now. Done with steps and now installing chipset, restart, and driver/ restart. Then I will try and get back. The question here with every bios for I have to ddu everything before and follow all steps all over again? Or I can just leave the fresh drivers as they are?

crashed. i got that msg on the bottom to the right. Followed all steps as explained. i will try to flash another bios now. but not sure if i have to reinstall the drivers again?
No dont bother with drivers, look at event viewer in windows.

Could be a bad card or the OS is broken or your motherboard could be too
 
Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#13
Don't think so. Forgot to tell you. I installed Windows 7, 8.1 and 10. Windows 10 especially has been reinstalled like 5 times. Last one is quite a fresh copy from Microsoft. Also tried 3 motherboards. That one, and Asus M5A99X EVO and M5A97. Also used 3 processors. 2 different fx-8350 and Phenom II 1100T. I just think it's the gpu card :((. But the card actually look so new, barely untouched. So clean as it just came out of the box. Even though it's a second hand
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#14
Either that or psu. Try the card in another machine with a different psu, if it crashes there the card is bad
 
Joined
May 6, 2018
Messages
437 (1.24/day)
Likes
449
Location
Upstate NY
System Name HexaCore
Processor AMD Phenom II X6 @ 3.5Ghz
Motherboard Biostar A880GZ
Cooling Fractal Designs S36 360mm Liquid Cooling System
Memory 8GB DDR3 @ 1600Mhz 7-8-7-16
Video Card(s) MSI RX580 Gaming X 8GB
Storage 3 x 80GB Intel SSD
Display(s) 1080P
Case CoolerMaster Sileo 500
Audio Device(s) Integrated
Power Supply Antec NeoPower 650W Blue
Mouse Microsoft Intellimouse
Keyboard Dell
Software Windows 10 Pro
#16
I'm sorry you are having such trouble getting it running. The used video card market can be a rocky road. I recommend buying new if at all possible due to problems like this.
 
Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#17
Thanks storm, but cannot afford another one at the moment. Gotta wait for sometime then. It seems broken as we apparently tried everything possible.

Just wondering is there any other way to factory reset it? Or even modded bioses possiblity can revive it?
 
Joined
Apr 9, 2019
Messages
34 (2.43/day)
Likes
10
#18
That card is about $130.
I see it on Slickdeals on sale here and there.
NEW

You can probably find one on OfferUP or CRAIGSLIST.


I remember watching a video about about fixing a dead graphics card.. JayZTwoCents is good at this stuff on YouTube. Maybe watch some of his vids, go in his forums and ask him.

But $100 card, is it worth your time? If my card fried ( and my pc doesn't have video on board ) I would find another one... probably another of the exact same card ( And you don't want to know what Card I'm using, not telling ) because my water block fits it... then I would upgrade to another one.

Doing windows installs, cpu motherboard swaps to try to debug your issue.... Not worth the time. Go buy a 30 card off OfferUp and see if it works then you know if your board is OK.

If this was a $1000 card, I would totally understand. I would look under magnifying glass at everything on the board, even bake it in the oven and re-flow the CPU on the card... but not this card. Not a 570 4gb.

Although Sapphire is the best AMD cards.
Maybe even send it to the company say, please test this for me..../sadface
570.JPG
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#19
Thanks storm, but cannot afford another one at the moment. Gotta wait for sometime then. It seems broken as we apparently tried everything possible.

Just wondering is there any other way to factory reset it? Or even modded bioses possiblity can revive it?
No, no modded bios will fix this.

Some minning cards were abused
 
Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#20
That card is about $130.
I see it on Slickdeals on sale here and there.
NEW

You can probably find one on OfferUP or CRAIGSLIST.


I remember watching a video about about fixing a dead graphics card.. JayZTwoCents is good at this stuff on YouTube. Maybe watch some of his vids, go in his forums and ask him.

But $100 card, is it worth your time? If my card fried ( and my pc doesn't have video on board ) I would find another one... probably another of the exact same card ( And you don't want to know what Card I'm using, not telling ) because my water block fits it... then I would upgrade to another one.

Doing windows installs, cpu motherboard swaps to try to debug your issue.... Not worth the time. Go buy a 30 card off OfferUp and see if it works then you know if your board is OK.

If this was a $1000 card, I would totally understand. I would look under magnifying glass at everything on the board, even bake it in the oven and re-flow the CPU on the card... but not this card. Not a 570 4gb.

Although Sapphire is the best AMD cards.
Maybe even send it to the company say, please test this for me..../sadface View attachment 121207
Thanks Good3als, well cannot deny that makes a lot of sense to me. Been trying for a month.

No, no modded bios will fix this.

Some minning cards were abused
Thanks eidairaman for your help today, and of course the time you put Into this.
 
Last edited:
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#21
One last thing before you give up.

Try to change the gpu die thermal compound, clean the heatsink and fan thoroughly. If thermal pads are no good replace them too.
 
Joined
Apr 16, 2019
Messages
13 (1.86/day)
Likes
5
#22
Will do and gotta give it one more try. I am curious about something I read somewhere in the forums here about something called 8 pin trick what is that?
 
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#23
Will do and gotta give it one more try. I am curious about something I read somewhere in the forums here about something called 8 pin trick what is that?
That is only for if you forcw flashed a mismatched Device and Subsystem ID bios to the card, it supposedly is to help take the card out of write lockout/protect mode.

In your situation you do not need it since I gave you specific files that match your ram and Device/Subsystem IDs.
 
Top