• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[Solved] Fans spinning a bit at startup but never after.

kingduckling

New Member
Joined
Jun 18, 2019
Messages
6 (0.02/day)
Got an rx 580 xfx, pulling it out for maintenance, open it blow dust out, clean paste application.
Place it back in, fans spin a bit at the start then stop.
PSU is a evga 750G+ supernova @1.5 years old.
Tried both bioses, both were flashed successfully when i got the card from a miner.
reinstalled drivers, removed msi afterbuners, installed a ancient gt 640 (fans worked).

Any suggestions?

[Solved]
one of the fan controller pins was slightly pulled out, pushed it back in gently, everything is working.
 
Last edited:
Joined
Jul 10, 2009
Messages
57 (0.01/day)
System Name RyZEN
Processor AMD Ryzen 9 3900X
Motherboard Gigabyte X470 Aorus Gaming 7 WIFI
Cooling Noctua NH-D15 SE-AM4
Memory 4 x 8GB G.SKILL @ 3800MHz 16-16-16-32 1T
Video Card(s) MSI GeForce RTX 2080 SUPER GAMING X TRIO
Storage Samsung 970 Evo Plus 500GB & 850Pro 1TB
Display(s) ASUS PG279Q IPS G-Sync 165Hz
Case Phanteks Eclipse P600S White
Audio Device(s) Edifier r1280t / Audio-Technica ATH-M40X
Power Supply Seasonic FOCUS Plus 650W Gold
Mouse SteelSeries Sensei Ten
Keyboard Fnatic Streak MX Red Silent
Software Windows 10 Pro
Benchmark Scores https://www.3dmark.com/3dm/46112957
if the gpu has fan stop feature, then the fans wont spin until the gpu temperature gets high enough.
i just built a pc for a friend with sapphire rx580, and the fans wont start until gpu reaches 60c

there's an option in amd software that keeps the fans running constantly too somewhere.
 

kingduckling

New Member
Joined
Jun 18, 2019
Messages
6 (0.02/day)
if the gpu has fan stop feature, then the fans wont spin until the gpu temperature gets high enough.
i just built a pc for a friend with sapphire rx580, and the fans wont start until gpu reaches 60c

there's an option in amd software that keeps the fans running constantly too somewhere.
Only its not that, ive tried disabling it from radeon. Also just reinstalled windows as well, like 10 minutes ago. In Radeon RPM says its running at 694123 RPM, that was the same before as well, clocks are also now stuck at 300 mhz and fans are still not spinning.
1591290290573.png


This is how the rpm looks like, zero rpm seems like it cant be disabled it just goes back to enabled, advanced control doesnt respond either when trying to set a fan curve.
 
Last edited:

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
2,306 (0.43/day)
See this thread to learn how to restore the original BIOS.

Uninstall all display drivers and then perform a cleanup with Display Driver Uninstaller (DDU) from safe mode.

Take the PC outside, open the case, and remove all the dust with air blower or hair dryer with a cold setting.

Remove the graphics card and blow some air in the x16 PCI express slot.

Carefully remove the heatsink from the graphics card and clean the fans with a toothbrush.

Clean the graphic cards with isopropyl alcohol and cotton swabs. Especially the GPU area and PCIe pins.

Unplug the 4-pin VGA fan power cable, clean the pins and replug it.

When you're done, reapply thermal paste on the GPU, remount the heatsink, plug it back in.

Download and install the latest drivers from AMD's website.

If the fans still misbehave, they're either defective or the fan controller is. In this case, just return the card.

If you can't return the card, you can use an alternative like this cable, you even try to mod one yourself if you have a dead case fan laying around (plug wires: red to red, black to black).

If the fans get too loud without a controller, consider buying a 3rd party VGA cooler like Arctic Accelero Xtreme.
 
Last edited:

kingduckling

New Member
Joined
Jun 18, 2019
Messages
6 (0.02/day)
Went to sleep to avoid making further mistakes.
[Solved]
one of the fan controller pins was slightly pulled out, pushed it back in gently, everything is working.

Thank you for the input!
 
Top