• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ThrottleStop issue with NVIDIA GPU

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#1
Hello everyone,
I've a weird problem I can't figure out: ThrottleStop somehow disables my NVIDIA GPU. I'm on a Dell XPS 15 9570 with intel i7-8750H and NVIDIA GTX 1050Ti Max-Q. If I use ThrottleStop (8.70.2), sometimes the NVIDIA GPU doesn't kick-in when I start a game. Sometimes it does right away, sometimes it does after a while I'm playing, and sometimes it doesn't at all. The issue seems related to ThrottleStop itself, not with undervolting, because if I use XTU with the same values, or if I start a game before starting ThrottleStop, there are no issues; but I'd rather stick with ThrottleStop which has more options I find useful.
Has anyone ever experienced something like this or have any idea how to solve it?
Thanks in advance, cheers!
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,274 (0.33/day)
Likes
850
#2
I cannot think of anything in ThrottleStop that would cause an Nvidia GPU to be disabled. ThrottleStop queries the Nvidia GPU driver for the GPU temperature as long as the GPU is not asleep due to Nvidia Optimus. You are the first person to report this problem.

In the ThrottleStop Options window, do not check the Nvidia GPU option. That will guarantee you that ThrottleStop is not interacting with the Nvidia GPU or its driver in any way.

How are you determining that the Nvidia GPU is not kicking in? Is your game full screen or in a window?
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#3
I know this is weird, and I don't have any valid explanation. I've used MSI afterburner to monitor CPU and GPU during gaming, and so I see the Nvidia GPU is not working properly. I already did a clean Windows install and nothing has changed.
Only thing I know is that if I start Windows with ThrottleStop off, then it's ok. The moment I start the program then I'm not sure I can play anymore.
 
Joined
Aug 5, 2018
Messages
15 (0.15/day)
Likes
0
#4
Ive heard using XTU and throttle stop together can make things glitchy. Do you have Nvidia GPU selected in options? Can you show use what your settings look like? There might be something if you played around with the Intel power balance, but thats the only thing I can think off that might do that.
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,274 (0.33/day)
Likes
850
#6
...and so I see the Nvidia GPU is not working properly
I am still not sure what this means. You need to post a picture of what you are seeing. The Nvidia GPU should run at a consistent MHz while in game. If you ALT+TAB out to the desktop, that could cause a problem.

A Core i7-8750H can run 1 or 2 cores at up to 4100 MHz. You have setup ThrottleStop so it is only running at a maximum of 3000 MHz. Why? Does your laptop have completely inadequate cooling so it cannot run at its full rated speed without thermal throttling?

Are you running any virtualization software or perhaps an antivirus program that includes a sand box type feature? Windows Defender has a Core Isolation feature that can interfere with ThrottleStop. Make sure that is disabled when testing.

Switch to the Windows High Performance power profile and set the EPP value in ThrottleStop to 0 for maximum performance.

In the ThrottleStop Options window select "Add Limit Reasons to Log File" and press OK. Go back to the main screen and select Log File, go play a game for a while and then exit ThrottleStop and have a look in the ThrottleStop / Logs folder for the log file. Copy and paste the data to www.pastebin.com or upload the log file somewhere convenient.

Something or multiple things are definitely not right. Without your laptop sitting in front of me, it might be difficult to solve this problem. No other user has mentioned this so I still think it is something you have set or installed on your laptop. When Nvidia GPU is not checked in ThrottleStop, it will have zero interaction with your GPU.

Try running GPU-Z. It can monitor the iGPU and the Nvidia GPU and it will draw a nice little graph that should show any throttling.

One last thing, are you plugged in or running on battery power while testing? Is your battery fully charged?
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#7
I am still not sure what this means. You need to post a picture of what you are seeing. The Nvidia GPU should run at a consistent MHz while in game. If you ALT+TAB out to the desktop, that could cause a problem.
I'll do some screenshot and try to explain better.
A Core i7-8750H can run 1 or 2 cores at up to 4100 MHz. You have setup ThrottleStop so it is only running at a maximum of 3000 MHz. Why? Does your laptop have completely inadequate cooling so it cannot run at its full rated speed without thermal throttling?
This is my gaming profile. I don't need to run 6 cores at 4100 MHz while gaming. Lovering turbo frequencies like this, I have good temperatures all the time, always below 70° Celsius, and CPU performance are more than enough. Anyway, I've tried even different profiles, with no restrictions on turbo frequencies, and the only different thing is CPU temperature.[/quote]
Are you running any virtualization software or perhaps an antivirus program that includes a sand box type feature? Windows Defender has a Core Isolation feature that can interfere with ThrottleStop. Make sure that is disabled when testing.

Switch to the Windows High Performance power profile and set the EPP value in ThrottleStop to 0 for maximum performance.
I'm not running any particular software. I've done a clean Windows install, and I have very few programs installed: Chrome, Premiere, Photoshop and not much else. No antivirus except for windows defender, but with core isolation off. I've tried various EEP values, but they didn't seem to make any difference with my issue.
In the ThrottleStop Options window select "Add Limit Reasons to Log File" and press OK. Go back to the main screen and select Log File, go play a game for a while and then exit ThrottleStop and have a look in the ThrottleStop / Logs folder for the log file. Copy and paste the data to www.pastebin.com or upload the log file somewhere convenient.

Something or multiple things are definitely not right. Without your laptop sitting in front of me, it might be difficult to solve this problem. No other user has mentioned this so I still think it is something you have set or installed on your laptop. When Nvidia GPU is not checked in ThrottleStop, it will have zero interaction with your GPU.

Try running GPU-Z. It can monitor the iGPU and the Nvidia GPU and it will draw a nice little graph that should show any throttling.

One last thing, are you plugged in or running on battery power while testing? Is your battery fully charged?
I'll try this, with ThrottleStop log and GPU-Z, thanks. Anyway, I'm always on AC and full charged. And I've not selected NVIDIA GPU in ThrottleStop.
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#8
Here we go. I've attached both GPU-Z and ThrottleStop logs. The problem is illustrated in the screenshot below. When I start a game, if I use ThrottleStop, the NVIDIA GPU doesn't always Kicks-in, and if it does, it's in a low-clock state at around 800MHz (with terrible framerates), while it shoud be about 1GHz more. At some point it goes up, but I can wait even 10 minutes before it does. Setting EPP to 0 somehow seems to help speed up the process, even if I don't see the link between Speedshiftting the CPU and the discrete GPU.

gpuz graph.gif
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,274 (0.33/day)
Likes
850
#9
Thanks for the test data.

One thing I noticed in your TS log file is that when you start gaming, your battery is being significantly charged. The battery data that TS collects is not live data. It is only updated about once a minute. A couple of minutes into your test, you can see the significant drop from charging the battery at 43833 mW to only being able to charge the battery at 24829 mW.

Code:
   DATE       TIME    MULTI   C0%   CKMOD  CHIPM   BAT_mW  TEMP    VID   POWER
2018-10-21  12:22:00  27.00   18.7  100.0  100.0    43833   69   0.7731   10.6
2018-10-21  12:22:01  27.00   19.7  100.0  100.0    43833   69   0.8383   11.1
2018-10-21  12:22:02  27.00   24.7  100.0  100.0    24829   72   0.8198   12.7
2018-10-21  12:22:03  27.00   25.5  100.0  100.0    24829   70   0.8121   13.0
That tells me your power adapter is marginal. It is not adequate to run your CPU, Nvidia GPU and fully charge your battery all at the same time. I would try another test but this time with your battery fully charged before you begin. See if that makes any difference. That will free up a few watts in the power budget which might allow your Nvidia GPU to go up to full speed sooner.

BatteryInfoView is a free utility that might be useful for monitoring live battery charging data. I also use the free version of BatteryBar.
www.nirsoft.net

Before your Nvidia GPU kicks into full speed mode, the Perf Cap Reason column in your log file shows a lot of values of 1 which is power related. You can read the Perf Cap Reason definitions in this post by the W1zzard.

https://www.techpowerup.com/forums/threads/gpu-z-perfcap-log-number-meanings.202433/post-3148971

Recent versions of Windows 10 are enabling Speed Shift and setting the EPP value based on what power plan you choose. Try leaving the Speed Shift - EPP box in ThrottleStop clear so Windows can manage the EPP value without interference from ThrottleStop. Select a high performance profile in Windows and then open up the FIVR window. In the monitoring table at the top right, make sure that Windows has set the EPP value to 0 for maximum performance.

Instead of changing the Turbo Power Limit values, with Speed Shift enabled, go into the TS - TPL window and set the Speed Shift Max value to 27. This should not make any difference. It is just another way to manage the maximum CPU speed.

Hopefully some more testing can help narrow down the source of this problem.
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#10
First of all, thanks unclewebb for the support, really appreciated.
I've attached two more logs, this time with battery at 100% and Speed Shif Max value to 27. If I disable Speed Shift in ThrottleStop and let Windows manage it, it's automatically set to 63 by the max performance profile of Windows, but not any less.
I don't think is a power reasons, because without ThrottleStop the problem doesn't show up, and my CPU goes all the way up to full Turbo Boost, which I limit with ThrottleStop, causing less consumption. It shouldn't be something related to undervolt either, since with XTU there are no problems at all, but I can't figure out what it is.
 

Attachments

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,274 (0.33/day)
Likes
850
#11
Windows 10 has an Ultimate performance power plan. Maybe that will keep the EPP value at 0.

https://www.thewindowsclub.com/ultimate-performance-power-plan

You should be able to limit your turbo ratios and CPU speed with XTU.

Have you tried a few different Nvidia GPU drivers?

Before starting your game, have you tried to exit ThrottleStop? The undervolt and lower CPU speed should remain in place even without ThrottleStop actively running. If that works, try renaming ThrottleStop.exe to something completely different like FullSpeed.exe. After you do this, when you run your new FullSpeed program, it will immediately create a new FullSpeed.INI configuration file. I added this hidden feature to ThrottleStop so if some other software or driver frowns upon you running ThrottleStop, you can call it whatever you like.

I am out of ideas why ThrottleStop would limit your Nvidia GPU. In theory it should not have anything to do with it so something else has to be going on but I have no idea what.
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#12
Unfortunately I can't limit turbo ratios with XTU, nor disable turbo boost: these options are greyed out.

I've tried different GPU Driver, meaning that that I've always kept them updated, and NVIDIA releases one ore more update per month.

I've also tried exiting ThrottleStop before starting a game, and it doesn't change a thing. It works only if I reboot and then I don't start ThrottleStop at all before starting a game. Once the game is up and running, I can launch ThrottleStop and nothing bad happens. It's a workaround, and I have to reboot all the time, but it works.

I'm out of ideas too, but I've noticed that somehow keeping GPU-Z running seems to help, which is only much more confusing to me.
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,274 (0.33/day)
Likes
850
#13
This sounds like an issue related to Nvidia Optimus.

In ThrottleStop - Options, when you check Nvidia GPU and the Nvidia GPU is idle at the desktop, ThrottleStop should look like this.



By design, when your computer is using the Intel GPU, ThrottleStop allows the Nvidia GPU to remain asleep. ThrottleStop does not query the Nvidia GPU for its temperature so it will report,

GPU --°C

If any software wakes up the Nvidia GPU, ThrottleStop recognizes this and will immediately start to report the Nvidia GPU temperature.

When you start up GPU-Z, it wakes up the Nvidia GPU so it can constantly poll its temperature, speed, etc. In this state, the Nvidia GPU is in a more ready state to get up to full speed faster compared to if it is asleep.

Have you tried setting the turbo ratios to their default values and using ThrottleStop to set the Speed Shift Max value instead?
 

Spillo

New Member
Joined
Oct 13, 2018
Messages
8 (0.24/day)
Likes
0
#14
This sounds like an issue related to Nvidia Optimus.

Have you tried setting the turbo ratios to their default values and using ThrottleStop to set the Speed Shift Max value instead?
Yes I have differente profiles, and one of the has all turbo ratios maxed out, but it makes no difference.
The one thing I really can't understand is why on earth undervolting e/o limiting turbo ratio should keep the GPU in a "more sleep" state, compared to no undervolting / limiting. Moreover I don't need EPP=0 to have high FPS: if ThrottleStop is off Windows sets EPP to no less than 64, and I can play with no issue.
 
Top